Subject: Re: [trill] [RTG-DIR] RtgDir review: draft-ietf-trill-tree-selection-01

From: "Susan Hares" <[email-masked]>
Date: Wed, 13 Jan 2016 20:19:48 -0500

Daniele: 

Thank you for this review.  

Sue Hares 

From: rtg-dir [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Wednesday, January 13, 2016 3:52 PM
To: <[email-masked]> ([email-masked])
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [RTG-DIR] RtgDir review: draft-ietf-trill-tree-selection-01

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see  <http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir> ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-trill-tree-selection-01
Reviewer: Daniele Ceccarelli
Review Date: Jan 07 2015
IETF LC End Date: September 2015 
Intended Status: Standard Track

Summary: 

*	This document is basically ready for publication, but has nits that should be considered prior to publication. 

Comments:

*	Overall the draft if well written and easy to understand. I found it quite difficult to go through section 1 but I guess it’s due to my lack of knowledge of the technology. A rearrangement accordingly to the minor issues IMO would improve readability of the document.  

Major Issues:

*	No major issues found

Minor Issues:

*	Section 3.2 – A list of the 4 TLVs with their name and one sentence summarizing its use would improve readability. Same applies in the following to e.g. section 3.2.1 where the paragraph before the figure is not very clear on the usage of the TLV.
*	Section 3.5 – Section 3.5 defines a fifth TLV, why not listing it with the other 4 ?

Nits:

*	Section 1.1: s/ the ingress RBridge use/the ingress RBridge uses
*	Section 2: s/campus/Campus
*	Section 3.1 s/is/has ??
*	Section 3.3 s/rfc7180bis/RFC7180bis

BR
Daniele

---

From: Liyizhou <[email-masked]>
Date: Thu, 14 Jan 2016 07:22:15 +0000

Daniele,
Thanks for the review.

I am going to update the document to reflect all the nits you pointed out.
For minor issues, proposed text change is as follow.

Minor Issues:

  *   Section 3.2 – A list of the 4 TLVs with their name and one sentence summarizing its use would improve readability. Same applies in the following to e.g. section 3.2.1 where the paragraph before the figure is not very clear on the usage of the TLV.
Text are modified as follows for section 3.2:
Two APPsub-TLVs supporting VLAN based tree selection are specified in Sections 3.2.1 and 3.2.2. They are used by the highest priority tree root to announce the allowed VLANs on each tree in the campus and by an ingress RBridge to announce the tree-VLAN correspondence it selects from the list announced by the highest priority tree root. Two APPsub-TLVs supporting FGL based tree selection are specified in Section 3.2.3 and 3.2.4 for the same purpose.

Add text to improve the readability of section 3.2.2 &3.2.4.
3.2.2: This APPsub-TLV is used by an ingress RBridge to distribute the tree-VLAN correspondence it selects from the list announced by the highest priority tree root.
3.2.4: This APPsub-TLV is used by an ingress RBridge to distribute the tree-FGL correspondence it selects from the list announced by the highest priority tree root.

  *   Section 3.5 – Section 3.5 defines a fifth TLV, why not listing it with the other 4 ?
It was an extension proposed in relatively late versions. You are right. I will move it to section 3.2.5 to make the document neat. And add one sentence in section 3.2 to introduce this TLV: Section 3.2.5 defines an APPsub-TLVs to support the finer granularity in selecting trees on multicast group base rather than data label base.

Thanks,
Yizhou

From: trill [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, January 14, 2016 9:20 AM
To: 'Daniele Ceccarelli'; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [trill] [RTG-DIR] RtgDir review: draft-ietf-trill-tree-selection-01

Daniele:

Sue Hares

From: rtg-dir [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Wednesday, January 13, 2016 3:52 PM
To: <[email-masked]<mailto:[email-masked]>> ([email-masked]<mailto:[email-masked]>)
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [RTG-DIR] RtgDir review: draft-ietf-trill-tree-selection-01

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir<http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir>

  *   No major issues found
Minor Issues: