Subject: Re: [trill] IPv6 examples in draft-ietf-trill-irb

From: Donald Eastlake <[email-masked]>
Date: Wed, 4 May 2016 12:21:26 -0400

Hi Fred,

draft-ietf-trill-irb-12 is now posted including IPv6 example addresses.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Wed, Apr 6, 2016 at 12:02 PM, Susan Hares <[email-masked]> wrote:

> Fred:
>
> Thank you for commenting on the missing examples in trill-irb.  We'll see
> about adding those examples.
>
> Sue  (TRILL co-chair)
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, April 06, 2016 11:01 AM
> To: [email-masked]
> Subject: IPv6 examples in draft-ietf-trill-irb
>
> Hello:
>
> I'd like to bring something to your attention with regard to
> draft-ietf-trill-irb, if I may.  It uses IPv4 examples (examples using
> addresses in 192.0.2.0/24, 198.51.100.0/24, or 203.0.113.0/24), but
> presents
> no IPv6 examples (which would use 2001:db8::/32, as specified in RFC 6890).
> This suggests that at some future time the protocol will likely need to be
> updated to use IPv6 in addition to IPv4.
>
> draft-robachevsky-mandating-use-of-ipv6-examples makes a very practical
> suggestion, which is that drafts should consider IPv6, as it is the
> direction the Internet is headed, and therefore provide either only IPv6
> examples or both IPv4 and IPv6 examples. This has not been agreed to in the
> IETF, nor is it a mandate in any sense. However, it seems practical.
>
> I can imagine that you just didn't think about IPv6, on the assumption that
> it is not a current reality in the Internet; while not true, that is a
> common perception.  However, as
>
> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,ch,us,pt
> ,de,gr,lu,pe,ec,ee,jp,fr,cz,my,fi,no,br,ca,ro,nl
> displays, Google, APNIC, and Akamai are reporting that at least 39
> countries
> worldwide have non-negligible IPv6 deployment (at least 1% of the traffic
> each of them sees uses IPv6 in those markets), 20 of them have at least 5%,
> and, in one case and one measurement, over 50% of their traffic.
> Additionally, AT&T, Comcast, Google, and T-Mobile indicate that a
> significant pecentage (around half to three quarters) of their mobile
> handsets or home computers are using IPv6 - in some cases, accessing IPv4
> sites only through NAT64 translation.
>
> In that spirit, would you please consider duplicating your IPv4 examples,
> or
> augmenting them, to display both the IPv4 and IPv6 variants?
>
> Thanks.
>
> Fred
>
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 4 May 2016 16:41:42 +0000

Thanks

> On May 4, 2016, at 9:21 AM, Donald Eastlake <[email-masked]> wrote:
> 
> Hi Fred,
> 
>  [email-masked] <mailto:[email-masked]>
> On Wed, Apr 6, 2016 at 12:02 PM, Susan Hares <[email-masked] <mailto:[email-masked]>> wrote:
> Fred:
> 
> From: [email-masked] <mailto:[email-masked]> [mailto:[email-masked] <mailto:[email-masked]>]
> To: [email-masked] <mailto:[email-masked]>
> addresses in 192.0.2.0/24 <http://192.0.2.0/24>, 198.51.100.0/24 <http://198.51.100.0/24>, or 203.0.113.0/24 <http://203.0.113.0/24>), but presents
> ,de,gr,lu,pe,ec,ee,jp,fr,cz,my,fi,no,br,ca,ro,nl <https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,ch,us,pt,de,gr,lu,pe,ec,ee,jp,fr,cz,my,fi,no,br,ca,ro,nl>
> displays, Google, APNIC, and Akamai are reporting that at least 39 countries
> In that spirit, would you please consider duplicating your IPv4 examples, or
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/trill <https://www.ietf.org/mailman/listinfo/trill>
>