Subject: Re: [trill] Spencer Dawkins' No Objection on draft-ietf-trill-rfc6439bis-04: (with COMMENT)

From: Donald Eastlake <[email-masked]>
Date: Tue, 21 Feb 2017 14:30:09 -0500

Hi Spencer,

Version -05, just posted, is intended to resolve your comments.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Tue, Jan 17, 2017 at 11:42 AM, Spencer Dawkins at IETF
<[email-masked]> wrote:
> Hi, Donald,
>
> On Tue, Jan 17, 2017 at 8:21 AM, Donald Eastlake <[email-masked]> wrote:
>>
>> Hi Spencer,
>>
>> Thanks for the comments. See below
>>
>> On Mon, Jan 16, 2017 at 7:23 PM, Spencer Dawkins
>> <[email-masked]> wrote:
>> >
>> > Spencer Dawkins has entered the following ballot position for
>> > draft-ietf-trill-rfc6439bis-04: No Objection
>> >
>> > ----------------------------------------------------------------------
>> > COMMENT:
>> > ----------------------------------------------------------------------
>> >
>> > I had trouble parsing "output it to or queue it for" (this occurs twice
>> > in the sentence).
>> >
>> >    However, it does not output it to or queue it for that link,
>> >    although, if appropriate (for example, the frame is multi-
>> >    destination), it may output it to or queue it for other links.
>>
>> It's kind of verbose but I believe that actual output port
>> implementations typically provide for directly streaming out a packet
>> even as other parts of the packet are still arriving at the switch,
>> particularly in cut-through routing, or just sticking it in a queue
>> for output later if the port is busy. Do you have any suggestion for
>> better wording?
>
>
> I was thinking that
>
>     However, it does not output it to, or queue it for, that link,
>     although, if appropriate (for example, the frame is multi-
>    destination), it may output it to, or queue it for, other links.
>
> might be clearer.
>
> If the RFC Editor removes the commas, of course, you can slap me in Chicago
> ;-)
>
> Spencer
>>
>>
>> > I don't think the text is incorrect, just awkward. Perhaps commas would
>> > help?
>> >
>> > In these three subsection titles,
>> >
>> >    3.2.1 Change Optimization One
>> >
>> >    3.2.2 Change Optimization Two
>> >
>> >    3.2.3 Settling Detection Optimization
>> >
>> > I found the title for 3.2.3 helpful, but not 3.2.1 or 3.2.2. Is it
>> > possible to come up with more descriptive titles?
>>
>> That's a reasonable point. Maybe
>>
>>    3.2.1 Optimization for Change to Lower Priority
>>
>>    3.2.2 Optimization for Change to Priority Only
>>
>>
>> > I found
>> >
>> >    For robustness, a TRILL switch sends a number of copies of a Port-
>> >    Shutdown messages configurable from one to three, which defaults to
>> >    two copies, at a configurable interval, which defaults to 20
>> >    milliseconds (see Section 6.6).
>> >
>> > difficult to parse. Perhaps
>> >
>> >    For robustness, a TRILL switch sends a configurable number of copies
>> >    of Port-Shutdown messages separated by a configurable interval. The
>> > default
>> >    number of copies is two, although this can be configured as one copy
>> >    or as three copies, and the default interval is 20 milliseconds
>> >    (see Section 6.6).
>> >
>> > ?
>>
>> Sure, that seems like an improvement. Might also be good to say "time
>> interval" instead of just "interval".
>>
>> Thanks,
>> Donald
>> ===============================
>>  Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
>>  155 Beaver Street, Milford, MA 01757 USA
>>  [email-masked]
>
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 21 Feb 2017 15:42:52 -0600

Hi, Donald,

On Feb 21, 2017 13:30, "Donald Eastlake" <[email-masked]> wrote:

Hi Spencer,

Thanks for that.

Spencer

Thanks,
Donald