Subject: [trill] AD review of draft-ietf-trill-multilevel-unique-nickname-03

From: Alia Atlas <[email-masked]>
Date: Tue, 20 Feb 2018 12:47:18 -0500

As is traditional, I have done my AD review
of draft-ietf-trill-multilevel-unique-nickname-03.  First, I would like to
thank the authors - Margaret, Donald, Mingui, and Dacheng - as well as the
reviewers and shepherd, Sue, for their work on this document.

I do have some minor comments, but these can be addressed ASAP while the
draft is in IETF Last Call.  I will request that to start and place this on
the IESG telechat on March 8.

Minor:

a) In Sec 3.1, it says "
      1) RB27 and RB3 have learned that D is connected to nickname 44.
      2) RB27 has learned that nickname 44 is accessible through RB3."

    Given that RB2 is the local area's Level Border Router, I think that is
RB2 not RB3. Granted, RB3 needs to know also - but that is info from its
local area.

b) In Sec 4.3:
" For nicknames in these ranges, other RBridges will deem that they are
owned by the originating border RBridge. The paths to nicknames that fall
in these ranges will be calculated to reach the originating border RBridge.
TRILL Data packets with egress nicknames that are neither in these ranges
nor announced by any RBridge in the area MUST be discarded. "

I think this only applies if OK = 0 - and that needs to be restated as part
of the condition.

Regards,
Alia

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 20 Feb 2018 13:36:42 -0500

Alia:

Thank you for reviewing the document and your suggestions on sections 3.1 and 4.3.  

Sue Hares

From: trill [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, February 20, 2018 12:47 PM
To: [email-masked]; [email-masked]
Subject: [trill] AD review of draft-ietf-trill-multilevel-unique-nickname-03

As is traditional, I have done my AD review of draft-ietf-trill-multilevel-unique-nickname-03.  First, I would like to thank the authors - Margaret, Donald, Mingui, and Dacheng - as well as the reviewers and shepherd, Sue, for their work on this document.

I do have some minor comments, but these can be addressed ASAP while the draft is in IETF Last Call.  I will request that to start and place this on the IESG telechat on March 8.

Minor:

a) In Sec 3.1, it says " 

    Given that RB2 is the local area's Level Border Router, I think that is RB2 not RB3. Granted, RB3 needs to know also - but that is info from its local area.

b) In Sec 4.3:

" For nicknames in these ranges, other RBridges will deem that they are owned by the originating border RBridge. The paths to nicknames that fall in these ranges will be calculated to reach the originating border RBridge. TRILL Data packets with egress nicknames that are neither in these ranges nor announced by any RBridge in the area MUST be discarded. " 

I think this only applies if OK = 0 - and that needs to be restated as part of the condition.

Regards,

Alia

---

From: "Zhangmingui (Martin)" <[email-masked]>
Date: Thu, 22 Feb 2018 06:43:22 +0000

Hi Alia,

Thanks for the review. Please refer the response inline below. The 05 version incorporated those comments and has been uploaded.

From: Alia Atlas [mailto:[email-masked]]
Sent: Wednesday, February 21, 2018 1:47 AM
To: [email-masked]; [email-masked]
Subject: AD review of draft-ietf-trill-multilevel-unique-nickname-03

Minor:

a) In Sec 3.1, it says "

[Mingui] While it’s correct to say both RB2 and RB3 know D is connected to nickname 44 beforehand, it’s not a necessary condition. Consider this: RB27 learned D is connected to nickname 44, it will set the egress nickname to 44. RB2 and RB3 can acquire this info from the TRILL header rather than the local MAC table.  So the accurate sentence is “RB27 has learned that D is connected to nickname 44.”

b) In Sec 4.3:

[Mingui]  Correct. The “OK=1” bullet does not apply here. So, this paragraph is now merged into the “OK=0” bullet.

Thanks,
Mingui

Regards,
Alia