Subject: [trill] Tsvart last call review of draft-ietf-trill-ecn-support-04

From: Michael Tüxen <[email-masked]>
Date: Sun, 04 Feb 2018 10:54:04 -0800

Reviewer: Michael Tüxen
Review result: Ready with Nits

I've reviewed this document as part of the transport area directorate's ongoing
effort to review key IETF documents. These comments were written primarily for
the transport area directors, but are copied to the document's authors for
their information and to allow them to address any issues raised.
When done at the time of IETF Last Call, the authors should consider this
review together with any other last-call comments they receive.
Please always CC [email-masked] if you reply to or forward this review.

This draft is basically ready for publication, but has nits that should be fixed before publication.

Nits:

Section 1:

Old text:
This can improve network efficiency through better flow
control without packet drops.

New text:
This can improve network efficiency through better congestion
control without packet drops.

Old text:
This specification provides for any ECN marking in the traffic at the
ingress to be copied into the TRILL Extension Header Flags Word.

New Text:
This specification specifies for any ECN marking in the traffic at the
ingress to be copied into the TRILL Extension Header Flags Word.

Section 2:

Old text:
after the Extesnion Flags Word.

New text:
after the Extension Flags Word

Section 3.3

Please define "3-bit ECN codepoint" and refer to Table 3 BEFORE using it.
This might result in swapping Table 2 and Table 3.

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 4 Feb 2018 21:44:11 -0500

Hi Michael,

Thanks for the comments, see below.

> control without packet drops.

OK.

> ingress to be copied into the TRILL Extension Header Flags Word.

Well, it specifies how to copy the ECN marking for any traffic and it
mandates that it be copied from IP traffic but it doesn't and can't
mandate that it be copied from all arbitrary protocols that might have
ECN marking...  Also, I don't like "... specification specifies ..."

How about:
"This document specifies how ECN marking in traffic at the ingress is
copied into the TRILL Extension Header Flags Word and requires such
copying for IP traffic."

> after the Extension Flags Word

OK.

> This might result in swapping Table 2 and Table 3.

We'll look into doing that.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 5 Feb 2018 00:30:00 -0500

Hi Michael,

I've fixed these nits and posted a -05 version.

Thanks,
Donald

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 5 Feb 2018 12:19:03 +0100

> On 5. Feb 2018, at 03:44, Donald Eastlake <[email-masked]> wrote:
> 
> Hi Michael,
> 
OK.
> We'll look into doing that.
Great. Thanks.

Best regards
Michael