Subject: Re: TCP proxys in mobile networks

From: Frode Kileng <[email-masked]>
Date: Wed, 3 Aug 2016 15:01:00 +0200

On 28.07.2016 22:40, Olle E. Johansson wrote:

 > Does anyone know what the problem they are trying to solve is?
 > (Still trying to find information)

Without taking any position of the usefulness on TCP proxies, and as an individual.....:
They are deployed purely for performance reasons. It's a highly competitive area with
multiple the vendors and the details of the methods is kept secret and covered by NDAs.

But in general, the key belief is that the unique traffic characteristics in a mobile
network makes a mobile network optimized congestion algorithm perform better. And also
that the reduced latency between proxy and mobile helps. In addition, a proxy may also
have congestion state feedback from the mobile network to further increase performance.

The draft-johansson-cc-for-4g-5g may give some further insight into why a mobile network
optimized congestion algorithm may perform better. And also that the issue is not
too many retransmits but maybe to few due to bufferbloat....

Best regards
Frode Kileng

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Fri, 5 Aug 2016 20:21:20 +0000

> On Jul 27, 2016, at 11:51 AM, Joe Touch <[email-masked]> wrote:
> 
> Sure - my point is that the term "transparent proxy" is common, and ALL such animals break TCP semantics *by design*.

From my perspective (which is always right), the right way to fix these middle boxes is to let users have trouble with them and complain. Someone that installs idiot-ware deserves the cost of fixing it.

---

From: Yuchung Cheng <[email-masked]>
Date: Fri, 5 Aug 2016 13:49:26 -0700

FWIW Tmobile and Google talked about an experiment to bypass Tmo proxies on
YouTube traffic in the Velocity conference. It was recorded at
https://www.youtube.com/watch?v=G_SMCYu7qSw
(For the impatient, you can skip the first 11 mintues)

---

From: Joe Touch <[email-masked]>
Date: Fri, 5 Aug 2016 13:55:58 -0700

On 8/5/2016 1:21 PM, Fred Baker (fred) wrote:
>
>> On Jul 27, 2016, at 11:51 AM, Joe Touch <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> Sure - my point is that the term "transparent proxy" is common, and
>> ALL such animals break TCP semantics *by design*.
>
> From my perspective (which is always right), the right way to fix
> these middle boxes is to let users have trouble with them and complain.
I agree, but users don't always know where to direct their ire.

> Someone that installs idiot-ware deserves the cost of fixing it.

They deserve many costs - the cost of lost revenue while they use it,
the cost of fixing it, etc.

The trick (as always) is to put the pain where the power lies to solve
the problem.

Joe

---

From: Theodore V Faber <[email-masked]>
Date: Mon, 8 Aug 2016 15:28:14 +0000

On 08/05/2016 01:21 PM, Fred Baker (fred) wrote:
>> Sure - my point is that the term "transparent proxy" is common,
>> and ALL such animals break TCP semantics *by design*.
> 
> these middle boxes is to let users have trouble with them and
> complain. Someone that installs idiot-ware deserves the cost of
> fixing it.
+1

- -- 
Ted Faber <[email-masked]>
Engineering Specialist
Computer Systems Research Department
310-336-7373

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 8 Aug 2016 09:24:15 -0700

The google/t-mobilve video is a good perspective on the problem:
The transparent proxies where deployed for a reason. Why for example
could the same throughput goals not easier be achieved with explicit
proxies, eg: http proxies ? Some work from ART that could fix this ?

Given how we know that transparency is a problem, why not try to solve that
by offering options for explicitly visible proxies at transport layer,
eg: with PLUS. Could easily (IMHO) include diagnostics, ot-in or opt-out
options. Use case for example: do not use the proxy when the app thinks
it can do it better itself.

Btw: Diagnostics isn't only bad with most current transparent middleboxes
It eqully worse because of the end-to-end principle. Whats my best option
to localize throughput problems on my oh so wonderfully transparent internet
path - so i can complain to the right ISP ? Pathchar ??? 

Justs to keep things in perspective..

---

From: Joe Touch <[email-masked]>
Date: Mon, 8 Aug 2016 11:12:34 -0700

On 8/8/2016 9:24 AM, Toerless Eckert wrote:
> proxies, eg: http proxies ? Some work from ART that could fix this 

Transparent proxies can be deployed where the user or upstream proxy
either isn't configured or deliberately declines to use this proxy.

I'm not aware of performance differences; if anything, transparent
proxies need to do more work to hijack connections.

Joe