Subject: [Tsv-art] TSV-ART review of draft-pd-dispatch-msrp-websocket

From: Allison Mankin <[email-masked]>
Date: Mon, 1 Aug 2016 15:28:31 -0400

Hey, folks,

I've reviewed this draft (draft-pd-dispatch-msrp-websocket-13) as part of
the TSV Area Review Team, paying special attention to transport-related
concerns. Please take these as any other (belated) IETF last call comments,
addressing them in conjunction with the present IESG review.

Summary: This draft specifies the WebSocket sub-protocol for MSRP, the
SIP-based messaging protocol.   It is very similar to RFC 7118, WebSocket
as a Transport for SIP, which is already a PS.  It does not appear to pose
any transport-related danger, and is broadly ready for publication as a PS.

Although the draft looks ready to go from a transport point of view, I have
a couple of small questions:

Section 5

Does the second sentence in the following mean "impossible for a WebSocket
MSRP client to communicate directly with other MSRP clients"?  The
paragraph is confusing.

   WebSocket clients cannot receive WebSocket connections initiated by
   other WebSocket clients or WebSocket servers.  This means that it is
   impossible for an MSRP client to communicate directly with other MSRP
   clients.  Therefore, all MSRP over WebSocket messages MUST be routed
   via an MSRP WebSocket Server.

Section 8

bob.example.com:8145 occurs in many of the path examples.  Although I
notice it also occurs in the MSRP Relay RFC (4976) along with many other
unassigned port numbers from the User Space, I wonder if it could be
replaced with a port from the Dynamic space (49152-65535) - in this draft,
it's the only unassigned port, and this could be one RFC that doesn't
confuse port users IRL.

Thanks and good luck,

Allison

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 3 Aug 2016 05:17:58 +0000

Hi Allison,

Thanks for your review and  feedback, I will replace the text below with following. "impossible"->"challenging"

EXISTING:

NEW:

   challenging for an MSRP client to communicate directly with other MSRP

For the second comment, I am fine using a port in the range  Dynamic space (49152-65535) for the examples. Will update the draft with these and publish later along with other comments received.

Regards,
Ram

From: Allison Mankin <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 2 August 2016 at 12:58 AM
To: IETF Discussion <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Mary Barnes <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: TSV-ART review of draft-pd-dispatch-msrp-websocket
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Ram Mohan Ravindranath <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Tuesday, 2 August 2016 at 12:58 AM

Hey, folks,

I've reviewed this draft (draft-pd-dispatch-msrp-websocket-13) as part of the TSV Area Review Team, paying special attention to transport-related concerns. Please take these as any other (belated) IETF last call comments, addressing them in conjunction with the present IESG review.

Summary: This draft specifies the WebSocket sub-protocol for MSRP, the SIP-based messaging protocol.   It is very similar to RFC 7118, WebSocket as a Transport for SIP, which is already a PS.  It does not appear to pose any transport-related danger, and is broadly ready for publication as a PS.

Although the draft looks ready to go from a transport point of view, I have a couple of small questions:

Section 5

Does the second sentence in the following mean "impossible for a WebSocket MSRP client to communicate directly with other MSRP clients"?  The paragraph is confusing.

Section 8

bob.example.com:8145<http://bob.example.com:8145> occurs in many of the path examples.  Although I notice it also occurs in the MSRP Relay RFC (4976) along with many other unassigned port numbers from the User Space, I wonder if it could be replaced with a port from the Dynamic space (49152-65535) - in this draft, it's the only unassigned port, and this could be one RFC that doesn't confuse port users IRL.

Thanks and good luck,

Allison