Subject: [Tsvwg] SCTP checksum ID comment

From: Tuexen Michael <[email-masked]>
Date: Mon, 14 Jan 2002 16:43:53 +0100

Dear all,

looking at the code on page 9 there are constants
NMIN and NMAX used. I think they describe the message
length limits between the given algorithm is valid.

But there are no values given for NMIN and NMAX. Could
you state in the ID for what message length the algorthm is
valid. Or simply remove the lines of code which do the check.

Best regards
Michael

PS.: One editorial comment: my name should be Tuexen, not Tuxen in section 3.
Michael Tuexen    Tel.:   +49 89 722 47210
Siemens AG        Fax:    +49 89 722 48212
ICN WN CS SE 5    E-mail: [email-masked]

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart at work <[email-masked]>
Date: Mon, 14 Jan 2002 10:01:14 -0600

> ICN WN CS SE 5    E-mail: [email-masked]
Yes,

I think we should remove these lines.. since this is
what I did when I pulled it into our
FreeBSD implementation :-)

R
-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222 or 815-477-2127

---

From: "Douglas Otis" <[email-masked]>
Date: Mon, 14 Jan 2002 16:07:38 -0800

Michael,

These size limits are not directly related to the CRC algorithm and can be
safely removed provided there is a  check somewhere in the protocol ensuring
a proper length packet both with respect to a minimum such that the header
checksum manipulation is not beyond the end of a truncated packet or too
long to fit within system allocations.  Indeed this check can be removed,
but was included to ensure no false assumptions result from packets of
incorrect length.

Doug