Subject: Re: [Tsvwg] Section 4.1.9 sctpsocket-02.txt

From: Kacheong Poon <[email-masked]>
Date: Tue, 8 Jan 2002 19:21:51 -0800 (PST)

Sorry for the late reply.  I was on vacation the last month...

> Section 4.1.9 sctpsocket-02.txt
> 
> getsockname() is applicable to both TCP-Style and UDP-Style SCTP
> instances.  Section 4.1.9 can be moved to section 6.

Can you explain why?  For UDP-style socket, an fd is associated
with many associations.  And the different associations may actually
have different local info.  If getsockname() is applied to a UDP-style
socket, which associations' local info should be returned?

							K. Poon.
							[email-masked]

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 10 Jan 2002 07:07:46 -0600

Kacheong:

Sorry for my delayed answer... 

I have taken Scott's advise for our next pass since
getsockname() returns the LOCAL address of the endpoint. I 
believe this works on both TCP and UPD sockets in most
API's given back the bound endpoint address. 

The one that gets the peer address would be one that
we would need to have just for the TCP model...

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)