Subject: RE: [Tsvwg] I-D ACTION:draft-ietf-tsvwg-sctpcsum-01.txt

From: "Douglas Otis" <[email-masked]>
Date: Wed, 9 Jan 2002 13:00:23 -0800

Shivani,

The test was an arbitrary buffer.  The second test case was to allow an
architecture check on the data path.  The initialization of the CRC register
provides for a non-zero result even with an all zeros buffer.

Doug

> Ref Pg 8 which has an example of the crc validation :
>
>     /* Example of crc validation */
>     /* Test of 32 zeros should yield 0x756EC955 placed in network order
> */
>     /* 13 zeros followed by byte values of 1 - 0x1f should yield
>     /* 0x5b988D47 */
>
> Do you a mean an arbitrary buffer of 32 bytes - all zero ? Or an sctp
> (with a data chunk) packet with a payload of 32 bytes set to zero.
> I dont see how an all zero buffer can have a non-zero checksum.
> I am not getting either of the crc's  using the example code.
>
> Shivani
>

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 09 Jan 2002 18:55:11 -0600

An important normative reference is missing in the checksum draft -
[RFC2960] :-)

-Qiaobing

---

From: "Douglas Otis" <[email-masked]>
Date: Wed, 9 Jan 2002 17:23:53 -0800

Qiaobing,

In the Reference Section add:

[RFC2960] R. R. Stewart, Q. Xie, K. Morneault, C. Sharp, H. J. Schwarzbauer,
T. Taylor, I. Rytina, M. Kalla, L. Zhang, and, V. Paxson, "Stream Control
Transmission Protocol," RFC 2960, October 2000.

Doug

---

From: Randall Stewart <[email-masked]>
Date: Thu, 10 Jan 2002 06:12:23 -0600

> An important normative reference is missing in the checksum draft -

Thanks Q I already caught that after Scott pointed
out to me the missing RFC2129 reference as well :-0
(Plus the draft identifies itself as RFC2960 ... cut
 and paste errors that creep in are so much fun :-)

R
-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)