Subject: [Tsvwg] SCTP Error Cause Code conflict

From: [email-masked]
Date: Fri, 28 Jun 2002 16:02:44 +0800

Hi, all

In Stream Control Transmission Protocol (SCTP) Implementers Guide, in section 2.6.2,  there is error code 11 for  Restart of an association  with new addresses.

In   Stream Control Transmission Protocol (SCTP) Dynamic Address Reconfiguration, in section 3.3,   there is error code 0x000B for         Request to Delete Last Remaining IP Address.

Do they conflict?

Br
Dajiang Zhang

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 28 Jun 2002 10:35:53 +0200

Dajizang Zhang,

these values conflict and in draft-ietf-tsvwg-addip-sctp-06.txt they
will be changed to

     Cause Code
     Value          Cause Code
     ---------      ----------------
     0x0100          Request to Delete Last Remaining IP Address.
     0x0101          Operation Refused Due to Resource Shortage.
     0x0102          Request to Delete Source IP Address.
     0x0103          Association Aborted due to illegal ASCONF-ACK

           Table 4: New Error Causes

Best regards
Michael

On Friday, June 28, 2002, at 10:02 AM, [email-masked] wrote:

> Hi, all
>
> In Stream Control Transmission Protocol (SCTP) Implementers Guide, in 
> section 2.6.2,  there is error code 11 for  Restart of an association  
> with new addresses.
>
> In   Stream Control Transmission Protocol (SCTP) Dynamic Address 
> Reconfiguration, in section 3.3,   there is error code 0x000B 
> for         Request to Delete Last Remaining IP Address.
>
> Do they conflict?
>
> Br
> Dajiang Zhang
>
[email-masked]