Subject: [Tsvwg] Cause code conflict.

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 1 Jun 2002 12:54:59 -0500

Randall,

There is a conflict in cause code values between the IG and ADD-IP:

draft-ietf-tsvwg-addip-sctp-05.txt: Section 3.3

    Cause Code     
    Value          Cause Code 
    ---------      ----------------
    0x000B          Request to Delete Last Remaining IP Address.

draft-ietf-tsvwg-sctpimpguide-05.txt: Section 2.6.2

      Cause Code
      Value           Cause Code
      ---------      ----------------
      ...
      11              Restart of an association with new addresses

Please move one of these cause codes to remove the conflict.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Tuexen <[email-masked]>
Date: Sun, 2 Jun 2002 23:14:40 +0200

Brian,

the AddIP Cause Code will be shifted. The error codes in the IG should
stay contiguous. The error causes in the AddIP ID will start at 0x100.

It will be fixed in the next release of the IDs.

Best regards
Michael

> draft-ietf-tsvwg-addip-sctp-05.txt: Section 3.3
[email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 2 Jun 2002 16:24:30 -0500

Michael,

Thanx for the info.

--brian

---

From: Randall Stewart <[email-masked]>
Date: Mon, 03 Jun 2002 12:23:56 -0500

Yes.. I think what we will probably do is move
the add IP up to a 0x0100 range for now.. Michael Tuexen said
something about wanting to propose a new cause code of the
implementors guide... so moving to a different range would
probably be best....

In the end IANA will figure out what the "official" number
is down the road... they may take the docuements valule that
we suggest.. but then again they may change it in the final
RFC process.... don't know...

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)