Subject: [Tsvwg] Re: your mail

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Jun 2002 18:41:51 -0500

Randall,

Here's an attempt to explain:  view from the sender's side:

  TSN  98  SID 1  SSN 1 --->
  TSN  99  SID 1  SSN 2 --->
  TSN 100  SID 1  SSN 3 --->
  TSN 101  SID 2  SSN 1 --->
  TSN 102  SID 3  SSN 1 --->
  TSN 103  SID 4  SSN 1 --->
  TSN 104  SID 5  SSN 1 --->
  <-- SACK (CUM ACK 99, GAP ACK for 101, 102, 103, 104)
  (SID 1 SSN 3 expires)
  
  Now the draft tells use when moving the TSN forward, we
  include gap-acked TSNs, so we send:

  FORWARD TSN 104 -->
  <-- SACK (CUM ACK 99, GAP ACK none) (101 thru 104 were discarded)

  Now, it could happen that the data in streams 2 thru 5 were being
  sent "reliably".  They have been lost to the receiver (it discarded
  them when reneging) and are also lost to the sender.  Not terribly
  reliable, is it?

My problem is with C2.

Now, this effect is also true within a stream as between streams (because
each individual SSN within a stream could be sent "reliably" or not).

The proposed solution is that C2 be reworded to advance the
Adv.Peer.Ack.Pnt only over "abandonned" TSNs.  So, in the above
example, the FORWARD TSN would be:

  FORWARD TSN 100 --->

If there are no renegs, the peer should immediately reply with

  <-- SACK (CUM ACK 104)

anyway (this was Armando's point earlier in this thread), so
performance is not impaired and reliability is restored.

--brian

On Thu, 06 Jun 2002, [email-masked] wrote:
> 
> "Brian F. G. Bidulock" wrote:
> > > Hmm... I had not thought in detail on this case...
> > >
> > > Now so I send
> > >
> > > Last SACK
> > > cum-ack=90
> > > Gap=92-94
> > > Gap=96-99
> > >
> > > and I now (as the sender) want
> > > to skip to 101..
> > > FWD-TSN(101)------->
> > >
> > >                    but in the mean time my peer is doing
> > >                       <----SACK(90) ... NO GAPS..
> > >
> > >
> > > If I do the above (as the current draft states) when the
> > > SACK arrives the SACK is the SAME point as the CUM-ACK... so
> > > It is not old or behind... I don't strike anything... and I would
> > > in theory go to put a mark on the 92-94 and the 96-99 .. but they
> > > are already marked as being skipped...
> > 
> > What if the SSNs in these TSNs are reliable?  They have been
> > dropped and yet they have not been successfully delivered to
> > the peer.  This compromises the reliability of all other "reliable"
> > messages.
> > 
> 
> Brian:
> 
> I am a bit confused.. it is probably just late in the day and also
> the classes I am in :0
> 
> So could you help me with this ... I want to understand (and I am not
> :<)
> 
> So in my example...
> 
> Are you saying something before 101 is NOT to be skipped i.e. reliable?
> 
> If so I would not do a fwd-tsn to 101 but to an earlier number....
> 
> If you could illustrate this with the above example it might help
> me understand what you mean...
> 
> 
> R
> 
> -- 
> Randall R. Stewart
> [email-masked] 815-342-5222 (cell phone)

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Qiaobing Xie <[email-masked]>
Date: Thu, 06 Jun 2002 21:34:48 -0500

...
> example, the FORWARD TSN would be:

This looks like a fine solution to me.

-Qiaobing

---

From: Randall Stewart <[email-masked]>
Date: Fri, 07 Jun 2002 11:42:57 -0500

This sounds fine to me too... we will get it into the next
version as well as the other word changes...

Note to brian: my cisco account is [email-masked] NOT [email-masked]

R