Subject: Re: [Tsvwg] More on PRSCTP-00

From: "Armando L. Caro Jr." <[email-masked]>
Date: Wed, 5 Jun 2002 16:09:03 -0400 (EDT)

On Wed, 5 Jun 2002, Randall Stewart wrote:

> After watching this debate.. I think I have come to the conclusion that
> Brian is correct :)
>
> Michael R. is here... I will discuss it with him.. I want to get
> the other co-author's take on this one... If the others agree with
> Brian (and me :>) then I think we will put this in.... also I would
> like to hear what the rest of the WG feels on this???

Well, you already know I agree with this change.

~armando

0--                                                --0
| Armando L. Caro Jr.     |       [email-masked] |
| University of Delaware  |  www.cis.udel.edu/~acaro |
0--                                                --0

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Mon, 03 Jun 2002 12:37:06 -0500

I agree here.. .maybe the FWD-TSN chunk should
report the new TSN and
all stream/sequence numbers dropped... this
would elimanate this...

I proposed this a long time back but Q did not like it :>

I think your reason here may be a good justification.. I will
catch up on this email thread when I get a chance :-0

R

"Brian F. G. Bidulock" wrote:
> 
> Randall,
> 
> More problem with PRSCTP:
> 
> Because FORWARD TSN is done on a TSN basis only, it reintroduces
> Head-Of-Line blocking: if the SSNs following a drop arrive at the
> receive out of order on an ordered stream, it is not possible for
> the receive to determine what is the next expected SSN in the
> stream because the FORWARD TSN contains no information about which
> SSNs were dropped.  Therefore, after a drop reported in an FORWARD
> TSN, every stream is blocked from delivering to the ULP until all
> missing TSNs have arrived.  This is HOL blocking again.  I would
> think that the FORWARD TSN procedure should reduce delay in delivery
> to the ULP rather than increase it.
> 
> One solution to this is to report dropped SSNs.
> 
> --brian
> 
> --
> Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                         ¦ Therefore  all  progress  depends on the ¦
>                         ¦ unreasonable man. -- George Bernard Shaw ¦
> 

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)