Subject: [Tsvwg] Question about special case for changing an address in SCTP-AddIP

From: [email-masked]
Date: Wed, 12 Jun 2002 08:36:08 -0400

Hi List,

In <draft-ietf-tsvwg-addip-sctp-05.txt>, we have:

4.3.2 A special case for changing an address.

The receiver of such a chunk MUST always first use the source address
    found in the IP header in looking up the association.  The
    receiver should attempt to use the address found in the Address
    Bytes field only if the lookup fails using the source address from
    the IP header.  The receiver MUST reply to the source address
    of the packet in this case which is the new address that
    was added by the ASCONF (since the old address is no longer a part
    of the association after processing).

My question is: why the sender of this ASCONF can use the new address as
source
address before it receives ASCONF-ACK?

Simon

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Wed, 12 Jun 2002 10:26:46 -0500

Simon:

One very good example of this would be where you have an
IPv6 renumber occur... and the former address is no
longer valid to source from. In this case you would stuff
the old address in to the address TLV so the peer has
a lookup mechanism. In fact one could even think about
using this address to always lookup the association the
more I think on it.. since you would never have a
lookup/miss-lookup/find..

There are other places it can be used as well... Michael Tuexen as
enumerated a few in his draft :>

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)