Subject: [Tsvwg] Problem regarding two connections

From: amit somani <[email-masked]>
Date: Tue, 4 Feb 2003 17:25:56 +0000 (GMT)

Hello everyone,

i am a student from Pune Institute od Computer
technology and i am doing a project of sending SS7
signals over IP. for this i am using SCTP as transport
layer protocol. i am using linux kernel 2.5.55 for the
same. the problem is that when i open a socket using
SCTP and send some data, the data is sent successfully
but when i close this connection and try to open
another connection only INIT and INIT_ACK messeges are
exchanged and no data can be sent. the system doesn't
give any error but the data is not received. So can
anyone please help me solve this problem.

waiting for reply.
                                  Regards
                                    Amit

________________________________________________________________________
Missed your favourite TV serial last night? Try the new, Yahoo! TV.
       visit http://in.tv.yahoo.com
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Venkatesh S Obanaik <[email-masked]>
Date: Wed, 5 Feb 2003 13:04:42 +0800 (GMT-8)

2.5.X is a development version of the kernel 
meant for kernel developers.
 
Always use a stable kernel version 
(all the even numbered versions are stable versions of
the kernel ..like 2.0.X, 2.2.X, 2.4.X )

http://www.kernel.org/
the latest stable version is 2.4.20

Regards,
Venkatesh

---

From: Andreas Jungmaier <[email-masked]>
Date: Wed, 5 Feb 2003 10:36:31 +0100

Venkatesh,

I think you are missing a point here: 
the lksctp is only integral part of the linux kernel since some 
2.5. version. This means it has been integrated into the mainstream
developers kernels. So, if you want up-to-date kernel level SCTP,
you *need* to use a recent 2.5. kernel.

Also, please note that implementation dependent questions should
be discussed on the SCTP-IMP list, which is at
<[email-masked]>

To subscribe, send a message to <[email-masked]> with the
following text in the body:

subscribe sctp-impl <your email address goes here>

Best regards,
Andreas

> > anyone please help me solve this problem.

- -- 
- ---------------------------------------------------------------------------
Dipl.-Ing. Andreas Jungmaier              |  Stop sending E-POSTCARDS ! 
Computer Networking Technology Group      |  Send E-MAILS --  Use PGP !
University of Essen                       | 
http://www.exp-math.uni-essen.de/~ajung   |   http://www.gnupg.org
My PGP Key-ID: D3824AC0                   |   http://wwwkeys.pgp.net
- ---------------------------------------------------------------------------
My PGP Key-Fingerprint: 228C 7C2C 3381 2DD4  9998 2812 5C0B 0B04  D382 4AC0 
- ---------------------------------------------------------------------------

---

From: Jon Grimm <[email-masked]>
Date: Wed, 05 Feb 2003 08:28:26 -0600

Yes, Andreas is quite correct here that lksctp is integrated into the 
2.5 branch of Linux.   Amit's request for assistance was inappropriately 
addressed to the tsvwg and will be addressed over on the 
lksctp-developer's list, as I've already mailed Amit.

Sorry for the intrusion into tswvg-land,
Jon Grimm

Andreas Jungmaier wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Venkatesh,
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.7 (GNU/Linux)
> 
> iD8DBQE+QNskXAsLBNOCSsARAhhzAJ4lRZpYXfMbBGAgn439RcGz5M11SQCg9nIC
> U7cTxpBOsuPmfcGNbgnyINY=
> =NOCY
> -----END PGP SIGNATURE-----
>