Subject: Re: [Tsvwg] A question of Un-Ordered SCTP

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 12 Feb 2003 04:33:53 -0700

Michael,

I disagree.  Adding an new INIT/INIT ACK procedure to start
counting at 0 instead of 1 seems excessive to me.

--brian

On Wed, 12 Feb 2003, Tuexen Michael wrote:

> Brian,
> 
> I understand your point, but I think it is clearer to
> define a new parameter of length 8 bytes to be included
> in the INIT / INIT-ACK which indicates that this feature used.
> Like in the case of PR-SCTP. This make the stuff explicit
> and introduces almost no additional complexity.
> 
> Best regards
> Michael
> 
> Michael Tuexen   Tel.:   +49 89 722 47210
> Siemens AG       Fax:    +49 89 722 48212
> ICN CP SE C 7    e-mail: [email-masked]
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Wednesday, February 12, 2003 10:44 AM
> > To: Tuexen Michael
> > Cc: Randall Stewart; Michael Tuexen; Caitlin Bestler; [email-masked]
> > Subject: Re: [Tsvwg] A question of Un-Ordered SCTP
> > 
> > 
> > Michael,
> > 
> > Tuexen Michael wrote:                                         
> >                       (Wed, 12 Feb 2003 09:39:41)
> > > > 
> > > > I think it would be good to see the requirement that the sequence
> > > > number begin at 1 and be monotonically increasing in the 
> > saem fashion
> > > > as ordered streams.
> > > > 
> > > I would prefer that the two sequence spaces are handled the same
> > > way. Thus both start with SSN=0.
> > 
> > That would make it impossible to distinguish between SCTP's supporting
> > the feature and SCTP's not supporting the feature on the first message
> > in a stream.
> > 
> > Leaving '0' for unordered packets of unspecified transmission 
> > order has
> > some value for backwards compatibility and interoperability.
> > 
> > --brian
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Tuexen Michael <[email-masked]>
Date: Wed, 12 Feb 2003 12:26:13 +0100

Brian,

Best regards
Michael