Subject: RE: [Tsvwg] Re: I-D ACTION:draft-xie-tsvwg-sctp-nat-00.txt

From: Schruefer Wolfgang <[email-masked]>
Date: Fri, 23 Jul 2004 10:59:14 +0200

For multi-homed associations I think the described procedure has a problem if a NAT box manipulates the port number. 
Is it a restriction or am I wrong?

Wolfgang

> 
> All,
> 
> I'd like to get your feedback on this I-D. Our intention is 
> to put together some guidelines 
> and information for people 1) who want to run SCTP across 
> NATs, and 2) who want to make 
> future NAT/middleboxes more SCTP friendly.
> 
> regards,
> -Qiaobing
> 
> 
> > A New Internet-Draft is available from the on-line Internet-Drafts 
> > directories.
> > 
> > 
> >         Title           : SCTP NAT Transverse Considerations
> >         Author(s)       : Q. Xie, et al.
> >         Filename        : draft-xie-tsvwg-sctp-nat-00.txt
> >         Pages           : 8
> >         Date            : 2004-7-14
> > 
> > This document provides guidelines and solutions for dealing 
> with SCTP
> >    association transversing NAT and similar middleboxes.
> > 
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-xie-tsvwg-sctp-nat-00.txt
> > 
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 23 Jul 2004 19:21:45 +0200

I think he is talking about NAT (which only affects
IP addresses) and not about NAPT (which affect IP addresses
and port numbers). But just my guess...

Best regards
Michael

On Jul 23, 2004, at 10:59 AM, Schruefer Wolfgang wrote:

> For multi-homed associations I think the described procedure has a 
> problem if a NAT box manipulates the port number.

---

From: Qiaobing Xie <[email-masked]>
Date: Fri, 23 Jul 2004 13:23:48 -0500

Yes, the description right now is focused on NAT only. Enhancement of the text will be 
needed to address NAPT properly.

regards,
-Qiaobing