Subject: [Tsvwg] SCTP Dynamic Address Reconfiguration

From: Salvatore Loreto <[email-masked]>
Date: Wed, 27 Apr 2005 13:54:37 +0200 (CEST)

Hi all,

I know the rationale of Dynamic Address
Reconfiguration is not the mobility, but it seems to
become a valid solution for mobility.

in your opinion is it possible carrying a SACK
information in the same SCTP packet carrying an ASCONF
chunk ?
This could be useful in "congestion control" of a
mobile with single nic.

I think the scenario with a Mobile with a single nic
(no multihomed) will not an unusual Mobile
configuration so this case must be study in deep.

So from a performance point of view I don't agree with
par. 4.3.2 and 4.4 of
draft-ietf-tsvwg-addip-sctp-11.txt

br
/Sal

___________________________________ 
Nuovo Yahoo! Messenger: E' molto più divertente: Audibles, Avatar, Webcam, Giochi, Rubrica… Scaricalo ora! 
http://it.messenger.yahoo.it

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 27 Apr 2005 20:16:24 +0200

Hi Salvatore,
see my comments in-line.
Best regards
Michael

> information in the same SCTP packet carrying an ASCONF
Why not? You can bundle them.
> draft-ietf-tsvwg-addip-sctp-11.txt
I do not see what these paragraphs have to do with performance.
Could you be a bit more precise?

---

From: Randall Stewart <[email-masked]>
Date: Tue, 03 May 2005 06:01:56 -0400

> Why not? You can bundle them.

I agree here.. if you want to include a SACK you bundle
it with the ACONF... no problem... you can also
bundle DATA if you so desire...
> Could you be a bit more precise?

And all 4.4 does is make it so you must ORDER the add-address
BEFORE the set-primary.. it does not mean you can't use it.

if you are also thinking of performance based on lookup of
the association... realize that most implementations use the
V-tag as a hash.. so I doubt very much they will even worry
about using the source address.. other than to verify that
the lookup-address is in the association being reconfigured.. and
with the new requirment to auth the packet.. the auth would
fail unless you know the secrets.. so I don't see an issue.

R

-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)

---

From: giuseppe <[email-masked]>
Date: Thu, 05 May 2005 13:05:09 +0900

> fail unless you know the secrets.. so I don't see an issue.
An other issue on this topic could be the need of multipath in mobile 
scenario.
For double-nic equipped terminal, maybe it'll be useful, to increase 
reliability and throughput. Moreover, multipath could be useful
for fast movements and returning of mobile node into the previous 
network. But, maybe this will add some buffering stuff at the AP...
G

-- 
----------------------
----------------------
Giuseppe De Marco, Ph.D.

Dipartimento di Ingegneria 
dell'Informazione e Ingegneria Elettrica
DIIIE, University of Salerno
via ponte don Melillo 1, Fisciano, Salerno
tel: +39 089 964012
email: [email-masked]

Department of Information and 
Communication Engineering 
Faculty of Information Engineering 
Fukuoka Institute of Technology (FIT)
3-30-1 Wajiro-Higashi, Higashi-ku, Fukuoka 811-0295 
Japan
email: [email-masked]
--------------------