Subject: Re: [Tsvwg] SCTP IG: Reception of bundled chunks

From: Randall Stewart <[email-masked]>
Date: Sat, 01 Oct 2005 06:50:07 -0400

Michael:

Why not something more along the lines of:
----------------------------------------------------------
When a packet containing multiple control or DATA chunks
is received and the processing of the packet
requires the sending of multiple chunks in
response. The sender of the response chunk('s) MUST NOT send
more than one packet. If bundling is supported
multiple response chunks that fit into a single packet may
be bundled together into one single response packet. If bundling
is NOT supported then the sender MUST send only one response
chunk and MUST discard all other responses. Note that this
rule does NOT apply to a SACK chunk since a SACK chunk
is, in itself, a response to DATA and a SACK does not
require a response of more DATA.
--------------------------------------------------------

I think the above would handle all the cases you
list below yours.. and yet at the same time
allows the exception case for the DATA/SACK..
since really a SACK does NOT require a response.

Note: wordsmithing welcome on the above.. I will no go
get some more coffee.. and think about the HB.verification
wording :-D

R

Michael Tuexen wrote:
> Hi Brian,
> 
> here is a text suggestion.
> 
> The following could be added to section 6.10.
> 
> When a packet containing multiple control chunks or DATA
> chunks which results in sending of an ERROR chunk is received
> and the processing of the packet requires the sending of multiple
> chunks no more than one packet MUST be sent. If bundling is
> supported multiple chunks that fit into one packet can be put
> into the packet. All other chunks MUST be discarded. If bundling
> is not supported, only the first chunk can be sent back.
> 
> Should we also have some examples: Reception of
> - multiple HB
> - multiple unknown chunks
> - multiple SHUTDOWN-ACKs
> - DATA with errors in fields
> - multiple COOKIE-ECHOs
> 

-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 1 Oct 2005 05:24:46 -0600

Randall,

That sounds good too.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: Michael Tuexen <[email-masked]>
Date: Sat, 1 Oct 2005 20:57:52 +0200

Randy,

some minor changes:

When a packet containing multiple control or DATA chunks
is received and the processing of the packet
requires the sending of multiple chunks in
response, the sender of the response chunk('s) MUST NOT send
more than one packet. If bundling is supported
multiple response chunks that fit into a single packet MAY
be bundled together into one single response packet. If bundling
is not supported then the sender MUST NOT send more than one response
chunk and MUST discard all other responses. Note that this
rule does NOT apply to a SACK chunk since a SACK chunk
is, in itself, a response to DATA and a SACK does not
require a response of more DATA.

And then a question: What is the intention of the last sentence?

What is allowed to send back when you receive HB,UNKOWN,DATA,DATA[param 
error]?
If the receiver supports bundling, it can send back a packet containing
HB-ACK, ERROR, SACK, ERROR if it fits. I would assume that only a HB-ACK
is sent back, when the receiver of the packet does not support bundling?

Best regards
Michael

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 1 Oct 2005 18:11:59 -0600

Michael,

Same question as on the other thread: does this need to apply
to verified addresses?  Or only unverified addresses.

Consider that many DATA chunks can ultimately be sent in response
to a single DATA chunk (by the application).

--brian

---

From: Michael Tuexen <[email-masked]>
Date: Sun, 2 Oct 2005 13:34:12 +0200

Hi Brian,

see my comments in-line.

Best regards
Michael

> to verified addresses?  Or only unverified addresses.
Soo my other mail.
> to a single DATA chunk (by the application).
When I say 'response' I'm looking at the SCTP layer only. So a DATA
chunk is never sent (in this sense) in response to a DATA chunk
(it might be on the upper layer, for example an ASPUP-ACK in
response to an ASPUP, but that is at a different layer).
When I mean response, I mean a HB-ACK in response to an HB,
an ERROR in response to an unknown chunk or a chunk with
some kind of error, an INIT-ACK in response to an INIT,
a COOKIE-ECHO in response to an INIT-ACK, a COOKIE-ACK in response
to an COOKIE-ECHO, and so on... I also mean an ERROR in response
to an INIT-ACK containing unknown parameters...

I hope this makes this point clearer.

Best regards
Michael