Subject: [Tsvwg] Clarification on sctp library.

From: "Balamurugan T, TLS-Chennai" <[email-masked]>
Date: Wed, 6 Jun 2007 12:50:42 +0530

Hi All,

I am new to sctp protocol and need the below clarifications. I have installed lksctp-tools-1.0.6 on Suse linux.

1. How to get the association id  for a successful connection.?

2. Is there any system call available to set a sctp socket as NON_blocking.

3. Is it possible to call sctp_connectx from a 1-to-1 sctp socket (sctp client ) to 1-to-N socket (sctp server).

4. How to set non-blocking on sctp server socket.

Thanks in Advance,

Bala

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 7 Jun 2007 00:43:44 +0200

Hi Bala,

question regarding the Linux SCTP implementation should be sent to
[email-masked]

Regarding you questions you might want to open an sctp socket,
put it into non blocking mode via a fnctl call and call sctp_connectx().
Please note that the function has recently be extended to provide
the assoc_id via a result parameter. This has been implemented in
the FreeBSD/MacOS X implementation, but not yet in the Linux one.

Best regards
Michael

On Jun 6, 2007, at 9:20 AM, Balamurugan T, TLS-Chennai wrote:

> Hi All,
>
>      I am new to sctp protocol and need the below clarifications. I  
> have installed lksctp-tools-1.0.6 on Suse linux.
>
>       3. Is it possible to call sctp_connectx from a 1-to-1 sctp  
> socket (sctp client ) to 1-to-N socket (sctp server).
> ---------------------------------------------------------------------- 
> -------------------------------------------------
>
> The contents of this e-mail and any attachment(s) are confidential  
> and intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its  
> affiliates. Any views or opinions presented in
> this email are solely those of the author and may not necessarily  
> reflect the opinions of HCL or its affiliates.
> Any form of reproduction, dissemination, copying, disclosure,  
> modification, distribution and / or publication of
> this message without the prior written consent of the author of  
> this e-mail is strictly prohibited. If you have
> ---------------------------------------------------------------------- 
> -------------------------------------------------