Subject: I-D Action: draft-ietf-tsvwg-sctpsocket-30.txt

From: [email-masked]
Date: Fri, 24 Jun 2011 09:33:36 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Transport Area Working Group Working Group of the IETF.

	Title           : Sockets API Extensions for Stream Control Transmission Protocol (SCTP)
	Author(s)       : Randall R. Stewart
                          Michael Tuexen
                          Kacheong Poon
                          Peter Lei
                          Vladislav Yasevich
	Filename        : draft-ietf-tsvwg-sctpsocket-30.txt
	Pages           : 112
	Date            : 2011-06-24

   This document describes a mapping of the Stream Control Transmission
   Protocol (SCTP) into a sockets API.  The benefits of this mapping
   include compatibility for TCP applications, access to new SCTP
   features and a consolidated error and event notification scheme.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpsocket-30.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpsocket-30.txt

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 28 Jun 2011 12:09:29 -0700

I noticed draft-ietf-tsvwg-sctpsocket-30 doesn't mention the DISABLE_RESTART
defined in draft-ietf-tsvwg-natsupp.  Is draft-ietf-tsvwg-natsupp expected
to Update draft-ietf-tsvwg-sctpsocket?   If so, it doesn't do that at the
moment.

-d

> -----Original Message-----
> From: [email-masked] [mailto:i-d-announce-
> [email-masked]] On Behalf Of [email-masked]
> Sent: Friday, June 24, 2011 9:34 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-tsvwg-sctpsocket-30.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Transport Area Working
> Group Working Group of the IETF.
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Michael Tüxen <[email-masked]>
Date: Tue, 28 Jun 2011 22:21:35 +0200

> to Update draft-ietf-tsvwg-sctpsocket?   If so, it doesn't do that at the
Hi Dan,

documents can have a socket API section, if the stuff described in the
document needs some user interaction. We do this for example in the
SCTP Stream Reset ID, the I-Bit extension and so on.
These documents also do not update the socket API RFC (once it is
an RFC).

So the socket API ID can progress without being affected by the
NAT documents.

Best regards
Michael

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 28 Jun 2011 14:59:58 -0700

> From: Michael Tüxen [mailto:[email-masked]]
> Sent: Tuesday, June 28, 2011 1:22 PM
> To: Dan Wing
> Cc: [email-masked]; [email-masked]
> Subject: Re: I-D Action: draft-ietf-tsvwg-sctpsocket-30.txt
> 

I see.

Is DISABLE_RESTART necessary with NPTv6 (draft-mrw-nat66)?

-d

---

From: Michael Tüxen <[email-masked]>
Date: Wed, 29 Jun 2011 00:08:24 +0200

> Is DISABLE_RESTART necessary with NPTv6 (draft-mrw-nat66)?
Not sure. Is it possible that multiple hosts behind the NAT
will be exposed to the Internet using the same IP address?
If this is possible, DISABLE_RESTART is required, if not,
it is not required.

Best regards
Michael

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 28 Jun 2011 15:37:13 -0700

> Sent: Tuesday, June 28, 2011 3:08 PM
> To: Dan Wing
> >>> to Update draft-ietf-tsvwg-sctpsocket?   If so, it doesn't do that
> at
> >> the
> >>> moment.
> >> Hi Dan,
> >>

No, not with NPTv6.

> If this is possible, DISABLE_RESTART is required, if not,

Ok, great.  Thanks.

-d