Subject: TSVWG Status Sept 2011

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 07 Sep 2011 08:37:50 +0100

The list below shows the status of the working group documents as we see 
it. Please check below and comment on drafts using the list. Please also 
send any corrections/omissions to the chairs.

Best wishes,

James and Gorry

---

draft-ietf-tsvwg-iana-ports was published as RFC 6335.

IDs in RFC Editor Queue:

draft-ietf-tsvwg-emergency-rsvp-15 (MISREF)
Norm. ref to router alert draft (in the INT-area WG, now in WGLC)

-------------------------------------------------------------------

IDs in IESG processing:

draft-ietf-tsvwg-rsvp-security-groupkeying
      WGLC of previous version completed.
      SECDIR review comments received, and updated as version -05.
      Short WGLC to confirm new text ended August 11th 2010.
      New version (-09) 22-10-2010.
      Proto write-up sent 14/12/2010.
      IESG Review.
    James is Shepherd.
    DUE: New version required.

draft-ietf-tsvwg-sctpsocket
      New Rev -25, 07/01/2011.
      WGLC complete.
      WG-31, Aug 10, 2011
      Publication requested
      Proto write-up sent Aug 29th, 2011
    James is Shepherd.
    DUE: AD action needed.

-------------------------------------------------------------------

WG Drafts with Chairs:

draft-ietf-tsvwg-sctp-strrst
      Dependency on this for IPFIX document with RFC-Ed.
      Benoit Claise to review for IPFIX
      New revision (-08) 25 Oct 2010.
          Text on race-condition to be updated before WGLC.
      New text to address this in revision 04/01/2011.
      draft-stewart-tsvwg-reconfuse-sctp to assist in consensus
      IETF-80: need to discus whether one in-band mechanism is viable.
      IETF-81: discussed this and concluded no changes needed.
      WGLC completed.
    James is Shepherd.
    DUE: Proto Write-up by Shepherd (James)
         Waiting on author feedback to chair

-------------------------------------------------------------------
WG Drafts:

draft-ietf-tsvwg-source-quench
       (Replaced: draft-gont-tsvwg-source-quench-01.txt)
       IETF-79 suggested there was interest in this topic.
       Comments to list in 2010 from: Fred Baker, Antonio DeSimone,
          James Polk, Gorry Fairhurst, Andrew Yourtchenko, and others.
       WG agreed the draft should be a work item.
         More motivation needed to justify the SHOULD cases.
         Chair advice sent, working with editor (Gorry).
    Gorry is Shepherd.
    DUE: New revision expected.
     Needs clarification of keywords & verify new text

draft-ietf-tsvwg-byte-pkt-congest
      New editor added Jul 2010.
      New revision 25 Oct 2010.
      WG -01, June 10, 2011
     Previous: Update needed before deciding if ready for WGLC.
     Review sent by Gorry Fairhurst.
      IETF-81: discussed whether this should be BCP.
      Status changed to BCP, New revision needed.
    DUE: Reviewers need to volunteer for LC
    DUE: New revision expected
    Please comment on list.

draft-ietf-tsvwg-natsupp-tsvwg
      (Replaced: draft-stewart-natsupp-tsvw)
      Dependency from BEHAVE WG.
      Adopted as a work item 21 Sept 2010 (Gorry).
         WG -00, 29/11/2010
           uploaded as: draft-ietf-natsupp-tsvwg
         WG -01, June 1, 2011
       DUE: Reviews need.

draft-ietf-tsvwg-sctp-udp-encap
      (Replaced: draft-tuexen-sctp-udp-encap)
      Lars sent a note as AD agreeing to progress this work.
      Work to be coordinated with DCCP work on encaps.
      Adopted as a work item 21 Sept 2010 (Gorry).
      draft-tuexen-sctp-udp-encaps-06, January 10, 2011
      DUE: New revision need.

draft-ietf-tsvwg-intserv-multiple-tspec
       WG interest in this topic recorded at IETF-78.
      Charter update would be needed to progress this work.
      5 Reviews needed to determine energy/technical direction.
      Version -05 (presented in Beijing, IETF-79)
      Version -06 (presented in Prague, IETF-80)
      RSVP directorate was consulted.
         2 reviews from RSVP-DIR received (Bruce Davie, ?).
         2 additional reviews promised (Ken Carlberg, Francois LeF).
         Chairs asked AD for a Charter update (IESG agreed).
      Draft discussed at IETF-80, and request to update charter agreed.
      - AD advised 4 named reviewers will be required.
      Adopted for progression as PS, for May 2012.

draft-karagiannis-pcn-tsvwg-rsvp-pcn
        WG interest in this topic recorded at IETF-81.
        -01, 2011-07-11
      DUE: Awaiting AD decision on the WG to be allocated this work.

-------------------------------------------------------------------

WG action required:

draft-touch-tsvwg-port-use-00
       - Intended to be advice to protocol designers needing a port.
         5 people have looked at this document, Prague IETF-80
      -01 July 2011
      IETF-81 insufficient feedback from WG at this time.
       WG needs to assess if the new draft should be a work item.
     DUE: Chairs need to assess energy for work on this topic.
     DUE: Please comment on list.

draft-nishida-tsvwg-sctp-failover
       -00 Presented in Prague, IETF-80.
       - understood not to conflict with draft-tuexen-tsvwg-sctp-multipath
     DUE: New revision need.

draft-tuexen-tsvwg-sctp-multipath
       -00 Presented in Prague, IETF-80.
       - understood not to conflict with draft-nishida-tsvwg-sctp-failover
       -01, 2010-12-27
       Please comment to list.

draft-tuexen-tsvwg-sctp-sack-immediately
        -05, 2011-01-02
        - Aug 2011, discussed on list and issues raised.
     DUE: Chairs need to confirm adoption (need to do work).
     DUE: New revision need (to address comments)

-------------------------------------------------------------------

The following have received recent discussion at TSVWG meetings or on
the list. Inclusion in the list below does not indicate support for
these specific drafts and other contributions are also warmly welcomed.

   draft-stewart-tsvwg-sctpecn-00
       Partially replaces (draft-stewart-tsvwg-sctp-nonce)
       IETF-78 suggested there was interest in this topic.
       Please comment to list.
       Revised uploaded with new name.
         - The draft needs to be updated for multihoming (IETF-80)
         - new revision expected April 2011 (IETF-80)
       WG needs to assess if the new draft should be a work item.

  draft-briscoe-tsvwg-ecn-encap-guidelines
       -00 Presented in Prague, IETF-80.
       - comments at IETF-80 (see minutes)
       WG needs to assess if the new draft should be a work item.
       Please comment on list.
      DUE: Chairs to check liaison status with other SDOs.

-------------------------------------------------------------------

    draft-polk-tsvwg-rsvp-app-id-vv-profiles
       -01 Presented in Beijing, IETF-79.
       -02, 14-Mar-2011
       Presented IET-80.
       WG needs to assess if the new draft should be a work item.
       Seek to coordinate with music with partner ID:
      draft-polk-mmusic-traffic-class-for-sdp
       Please comment on list.
      DUE: Chairs to liaise with MMUSIC WG (Gorry).

   draft-lefaucheur-tsvwg-rsvp-multiple-preemption
       RSVP directorate to be consulted.
          - Reviewers: Bruce Davie (awaiting other reviews)
       Please comment to list.

   draft-wing-tsvwg-happy-eyeballs-sctp
       This appears dead

-------------------------------------------------------------------

Related non-WG items:

draft-ietf-behave-sctpnat-03.txt
       BEHAVE WG item linked to SCTP encapsulation work.

draft-ietf-6man-udpzero
       was: draft-fairhurst-tsvwg-6man-udpzero
       Draft was adopted by 6man, please discuss on the 6man list.
       A WGLC of this draft is expected in 6MAN WG.
         related draft: draft-ietf-6man-udpchecksums-00
       Expected to start WGLC in Jul 2011.
       This draft will be LC'ed in TSVWG also.

------------------------------------------------------------------

Other news:

   RSVP Directorate (formed in May 2010)
     - directorate consulted on

   Charter updated Aug 2011.

------------------------------------------------------------------

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 7 Sep 2011 10:44:12 +0200

Hi James,

>        2 additional reviews promised (Ken Carlberg, Francois LeF).

You have been looking into a potential restructuring of the encoding based on Lou's suggestion. If you're going to do this, I'd rather do the review on the updated document. If not, I can review the current version. I'm not arguing you should, or should not do that change, but can you let us know if/when you see that happening, so I plan the review accordingly?

Thanks

Francois

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 07 Sep 2011 13:29:18 -0500

As an editor of both efforts, I'd say wait for the proposal from me a 
Lou to materialize, then comment on that (thumbs up or down on that), 
then do a review of what the WG is moving forward with.

My co-chair might have a different take though.

James

At 03:44 AM 9/7/2011, Francois Le Faucheur wrote:
>You have been looking into a potential restructuring of the encoding 
>based on Lou's suggestion. If you're going to do this, I'd rather do 
>the review on the updated document. If not, I can review the current 
>version. I'm not arguing you should, or should not do that change, 
>but can you let us know if/when you see that happening, so I plan 
>the review accordingly?
>
>Thanks
>
>Francois