Subject: Re: WGLC for draft-ietf-tsvwg-sctp-udp-encaps-03, ending Friday 20th April 2012

From: Chris Benson <[email-masked]>
Date: Thu, 5 Apr 2012 13:26:03 -0700 (PDT)

James and Gorry,

I support this.

I have read and followed development of this draft for 
encapsulating SCTP over UDP.  I recognize the need in
this area, and approve of its content as useful, correct
and complete.

With thanks, from Chris Benson, Adax Inc.

On Wed, 28 Mar 2012, Gorry Fairhurst wrote:

>>  Date: Wed, 28 Mar 2012 15:25:39 +0200
>>  From: Gorry Fairhurst <[email-masked]>
>>  To:  <[email-masked]>
>>  Cc:  <[email-masked]>
>>  Subject: WGLC for draft-ietf-tsvwg-sctp-udp-encaps-03,
>>      ending Friday 20th April 2012
>>  
>>  This email announces the start of a working group last call for
>>  draft-ietf-tsvwg-sctp-udp-encaps, "UDP Encapsulation of SCTP Packets".
>>  
>>  Following the meeting this week, this document is now thought to be ready to
>>  proceed to be published as a BCP. Please send any comments to the TSVWG
>>  list.
>>  
>>  The draft is available at:
>>  http://tools.ietf.org/html/draft-ietf-tsvwg-sctp-udp-encaps-03
>>  
>>  The last call will run for THREE weeks, ending Friday 20th April 2012.
>>  
>>  Emails saying "I support" or "I don't support" publication are also most
>>  helpful in judging the WG consensus. Please let us know if this draft is
>>  useful and seems to provide the correct advice.
>>  
>>  James and Gorry
>>  (TSVWG Chairs)
>>  [email-masked]
>>

---

From: Robin Seggelmann <[email-masked]>
Date: Mon, 23 Apr 2012 15:35:25 +0200

I just had a look at the draft again, and I'm wondering how the Path MTU Discovery (section 4.6) is handled when the Don't Fragment bit cannot be set. If a userland implementation is used, this is the case on Mac OS X, for example.

Best regards
Robin

On Mar 28, 2012, at 3:25 PM, Gorry Fairhurst wrote:

> Following the meeting this week, this document is now thought to be ready to proceed to be published as a BCP. Please send any comments to the TSVWG list.
> 
> Emails saying "I support" or "I don't support" publication are also most helpful in judging the WG consensus. Please let us know if this draft is useful and seems to provide the correct advice.
> 
> James and Gorry
> (TSVWG Chairs)
> [email-masked]

---

From: "Becke, Martin" <[email-masked]>
Date: Mon, 23 Apr 2012 14:36:39 +0000

AFAIK, on MAC OS X you could do a work around by set the DF bit on a raw socket, but I do not think that this will work for a SCTP userland implementation.

Am 23.04.2012 um 15:35 schrieb Robin Seggelmann:

Best regards
Robin

James and Gorry
(TSVWG Chairs)
[email-masked]<mailto:[email-masked]>

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 23 Apr 2012 16:49:45 +0200

> AFAIK, on MAC OS X you could do a work around by set the DF bit on a raw socket, but I do not think that this will work for a SCTP userland implementation. 
I guess Robins points is the you SCTP/UDP because you don't have the privileges to open a raw socket.
Some OSes support the controlling of the DF bit for a normal user, some don't.

I'll update the text accordingly. I guess if you can't control the DF bit, you can't do PMTU discovery.
So you need to choose a small MTU value... Or use IPv6, which doesn't have this problem.

Best regards
Michael

---

From: "Becke, Martin" <[email-masked]>
Date: Mon, 23 Apr 2012 16:06:39 +0000

> Some OSes support the controlling of the DF bit for a normal user, some don't.

Yes, this results in a privilege issue. 

> So you need to choose a small MTU value…

I agree. 

Is "you" for you the protocol developer or the user of the protocol.  
If I, as a user, have enough knowledge about the connection (even without control and without PMTUD) I would like to change the value to increase my performance. 

Martin

> Or use IPv6, which doesn't have this problem.
> 
> Best regards
> Michael
>> 
>>

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 23 Apr 2012 19:29:45 +0200

> Is "you" for you the protocol developer or the user of the protocol.  
I meant the developer of the SCTP stack...
> If I, as a user, have enough knowledge about the connection (even without control and without PMTUD) I would like to change the value to increase my performance. 
... then you as a user of an SCTP stack providing a socket API will allow you set
the MTU and disable PMTU discovery by using the SCTP_PEER_ADDR_PARAMS socket option
as specified in
http://tools.ietf.org/html/rfc6458#section-8.1.12

Best regards
Michael