Subject: [tsvwg] [Technical Errata Reported] RFC3168 (3680)

From: RFC Errata System <[email-masked]>
Date: Fri, 12 Jul 2013 04:15:16 -0700 (PDT)

The following errata report has been submitted for RFC3168,
"The Addition of Explicit Congestion Notification (ECN) to IP".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3168&eid=3680

--------------------------------------
Type: Technical
Reported by: Mirja Kühlewind <[email-masked]>

Section: 6.1.1.

Original Text
-------------
If the TCP connection does not
wish to use ECN notification for a particular packet, the sending TCP
sets the ECN codepoint to not-ECT, and the TCP receiver ignores the
CE codepoint in the received packet.

Corrected Text
--------------
If the TCP connection does not
wish to use ECN notification for a particular packet, the sending TCP
sets the ECN codepoint to not-ECT.

Notes
-----
The receiver should not ignore any CE codepoint.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3168 (draft-ietf-tsvwg-ecn-04)
--------------------------------------
Title               : The Addition of Explicit Congestion Notification (ECN) to IP
Publication Date    : September 2001
Author(s)           : K. Ramakrishnan, S. Floyd, D. Black
Category            : PROPOSED STANDARD
Source              : Transport Area Working Group
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: "Black, David" <[email-masked]>
Date: Wed, 17 Jul 2013 18:56:20 -0400

I believe this errata is correct.

Thanks,
--David (as RFC 3168 author and tsvwg WG co-chair)

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: Friday, July 12, 2013 7:15 AM
> To: [email-masked]; [email-masked]; Black, David;
> [email-masked]; [email-masked];
> [email-masked]; Black, David; [email-masked]
> Cc: [email-masked]; [email-masked]; rfc-editor@rfc-
> editor.org
> Subject: [Technical Errata Reported] RFC3168 (3680)
>