Subject: [tsvwg] (no subject)

From: Madan Mohan Mishra <[email-masked]>
Date: Mon, 8 Jul 2013 05:59:42 +0000

Hi Group,

    I have a doubt in one of the scenario related to restart duing shutdown which is not very clear to my understanding as per the RFC4960. The scenario is as below:

Clause as per the RFC:

-------------------------------------------------------------------------------------

9.2.  Shutdown of an Association
"If an endpoint is in the SHUTDOWN-ACK-SENT state and receives an INIT
   chunk (e.g., if the SHUTDOWN COMPLETE was lost) with source and
   destination transport addresses (either in the IP addresses or in the
   INIT chunk) that belong to this association, it should discard the
   INIT chunk and retransmit the SHUTDOWN ACK chunk."

-------------------------------------------------------------------------------------

Network scenario as per the above RFC snippet:

SCTP-A                                                                    SCTP-B

Local IP List: L-IP1, L-IP2                                             Local IP List: R-IP1, R-IP2

ESTABLISHED                                                            ESTABLISHED

---------------------------SHUT-DOWN (L-IP1->R-IP1)-------------------->

<-------------------------SHUT-DOWN-ACK (R-IP1<- L-IP1)--------------

---------------------------SHUT-DOWN-COMP (L-IP1->R-IP1)-----lost in network

Now, local end point rebooted

It might create a new association as below:

local IP addresses.

Local IP List: L-IP2, L-IP3

----------------------------INIT (L-IP2->R-IP1)-------------------------------->

                                                                                SHUT-DOWN-ACK sent state

                                                                                As per RFC, upon receiving INIT message

                                                                                in SHUT-DOWN-ACK-SENT state, it should

                                                                                retransmit SHUT-DOWN-ACK and discard INIT message.

<-----------SHUT-DOWN-ACK (L-IP1<-R-IP1)------------------- This mesage wil be discarded at L-IP1, since there will be

                                                                                                no association in L-IP1

The destination IP address of last SHUT-DOWN-ACK message is no more exist. So , all

the SHUT-DOWN-ACK messages sent by SCTP-B will be discarded in network.

RFC4960 does not mention explicitly to handle this kind of situation?

As, retransmission of SHUT-DOWN-ACK message is not due to T2 timer expiry, path switching

is not applicable. So, SHUT-DOWN-ACK message will always be sent on the primary address.

So, I believe, SCTP-B should send SHUT-DOWN-ACK message to the same destination address

which is exist in both INIT and current association destination address list so that the message will

not be discarded.

Please share your opinion.

Thanks and Regards,

Madan

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 8 Jul 2013 11:33:40 +0200

>     I have a doubt in one of the scenario related to restart duing shutdown which is not very clear to my understanding as per the RFC4960. The scenario is as below:
Well, you can consider the SHUTDOWN-ACK as a response to the received INIT in
this particular case. That would mean that it is a good idea to send the SHUTDOWN-ACK
to the source address of the received INIT. This would resolve your issue here.

Best regards
Michael