Subject: [tsvwg] Fwd: New Version Notification for draft-touch-tsvwg-udp-options-01.txt

From: Joe Touch <[email-masked]>
Date: Tue, 21 Jul 2015 15:12:06 -0700

FYI. Minor changes for clarification.

Joe

-------- Forwarded Message --------
Subject: New Version Notification for draft-touch-tsvwg-udp-options-01.txt
Date: Tue, 21 Jul 2015 15:04:46 -0700
From: [email-masked]
To: Dr. Joseph D. Touch <[email-masked]>, Joe Touch <[email-masked]>

A new version of I-D, draft-touch-tsvwg-udp-options-01.txt
has been successfully submitted by Joe Touch and posted to the
IETF repository.

Name:		draft-touch-tsvwg-udp-options
Revision:	01
Title:		Transport Options for UDP
Document date:	2015-07-21
Group:		Individual Submission
Pages:		8
URL:
https://www.ietf.org/internet-drafts/draft-touch-tsvwg-udp-options-01.txt
Status:
https://datatracker.ietf.org/doc/draft-touch-tsvwg-udp-options/
Htmlized:       https://tools.ietf.org/html/draft-touch-tsvwg-udp-options-01
Diff:
https://www.ietf.org/rfcdiff?url2=draft-touch-tsvwg-udp-options-01

Abstract:
   Transport protocols are extended through the use of transport header
   options. This document experimentally extends UDP to provide a
   location, syntax, and semantics for transport layer options.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Brian Trammell <[email-masked]>
Date: Wed, 22 Jul 2015 08:22:08 +0200

hi Joe,

Thanks for this draft; I appreciate the elegant redundancy-reducing length hack. :)

Data in this case is, I know, hard to come by, but would you have any feel for how much stuff out there will just break when they see an inconsistency between IP and UDP length information?

Thanks, cheers,

Brian

> On 22 Jul 2015, at 00:12, Joe Touch <[email-masked]> wrote:
>

---

From: Christian Huitema <[email-masked]>
Date: Wed, 22 Jul 2015 04:23:17 +0000

Looks good to me.

-----Original Message-----
From: Spud [mailto:[email-masked]] On Behalf Of Joe Touch
Sent: Wednesday, July 22, 2015 12:12 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Spud] Fwd: New Version Notification for draft-touch-tsvwg-udp-options-01.txt

Joe

-------- Forwarded Message --------
Subject: New Version Notification for draft-touch-tsvwg-udp-options-01.txt
Date: Tue, 21 Jul 2015 15:04:46 -0700
From: [email-masked]
To: Dr. Joseph D. Touch <[email-masked]>, Joe Touch <[email-masked]>

Abstract:

The IETF Secretariat

_______________________________________________
Spud mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spud

---

From: Christian Huitema <[email-masked]>
Date: Wed, 22 Jul 2015 04:24:31 +0000

Oops. Sorry about that, I was replying to a different message. I have yet to review Joe's draft.

-----Original Message-----
From: Spud [mailto:[email-masked]] On Behalf Of Christian Huitema
Sent: Wednesday, July 22, 2015 6:23 AM
To: Joe Touch; [email-masked]
Cc: [email-masked]
Subject: Re: [Spud] Fwd: New Version Notification for draft-touch-tsvwg-udp-options-01.txt

Looks good to me.

-----Original Message-----
From: Spud [mailto:[email-masked]] On Behalf Of Joe Touch
Sent: Wednesday, July 22, 2015 12:12 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Spud] Fwd: New Version Notification for draft-touch-tsvwg-udp-options-01.txt

Joe

-------- Forwarded Message --------
Subject: New Version Notification for draft-touch-tsvwg-udp-options-01.txt
Date: Tue, 21 Jul 2015 15:04:46 -0700
From: [email-masked]
To: Dr. Joseph D. Touch <[email-masked]>, Joe Touch <[email-masked]>

Abstract:

The IETF Secretariat

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 22 Jul 2015 14:30:57 +0200

I don't have data, but I am interested in such measurements. I 
previously proposed UDPTT, which if agreed would allow UDP-Lite-based 
behaviour for a tunnel:
https://tools.ietf.org/html/draft-fairhurst-6man-tsvwg-udptt-03

Maybe we should be bolder to allow UDP-Lite behaviour on the UDP 
protocol number?

This would allow the options usage also - all/any of these would require 
some network observations to determine what actually is passable across 
a path and what are the actual sideffects. RFC 6936 discussed potential 
failures, but presents no data.

Gorry

On 22/07/2015 08:22, Brian Trammell wrote:
>> On 22 Jul 2015, at 00:12, Joe Touch<[email-masked]>  wrote:
>>
>> To: Dr. Joseph D. Touch<[email-masked]>, Joe Touch<[email-masked]>
>>
>>

---

From: Joe Touch <[email-masked]>
Date: Wed, 22 Jul 2015 09:52:12 -0700

On 7/21/2015 11:22 PM, Brian Trammell wrote:
> Data in this case is, I know, hard to come by, but would you have
> any feel for how much stuff out there will just break when they see an
> inconsistency between IP and UDP length information?

I have students starting this fall who will look into this and do some
tests. We have no information yet.

Joe

---

From: Joe Touch <[email-masked]>
Date: Wed, 22 Jul 2015 09:54:24 -0700

> Maybe we should be bolder to allow UDP-Lite behaviour on the UDP

I can't yet see how to do this. A key difference between udp-options and
UDP-Lite is that udp-options doesn't change the semantics of the
existing UDP checksum field - which is critical to transiting NATs (who
recompute that checksum).

We also need to add an option-area checksum for udp-options (I'm working
on that). It might be possible to use some area after the option area as
a trailing, un-protected data area too - which might do what UDP-Lite
does but in a slightly different way.

Is that what you're looking for? I'll post that change later.

Joe

>> Data in this case is, I know, hard to come by, but would you have any
>> feel for how much stuff out there will just break when they see an
>>> Htmlized:      
>>> https://tools.ietf.org/html/draft-touch-tsvwg-udp-options-01
>>> Diff: