Subject: [tsvwg] Implementation status for draft-ietf-tsvwg-sctp-ndata?

From: G Fairhurst <[email-masked]>
Date: Wed, 21 Jun 2017 17:43:04 +0100

TSVWG,

The WGLC for i-Data, draft-ietf-tsvwg-sctp-ndata, has concluded and the 
Chairs are now preparing a publication request for this document as PS.

To complete the write-up of this spec, we would be interested to hear of 
any implementations of the spec. Please let the Chairs know if you plan 
to or have already completed implementation of this SCTP update (and 
provide a few lines of text that we may compile into the write-up for 
this document).

Gorry

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 21 Jun 2017 20:33:29 +0200

> On 21. Jun 2017, at 18:43, G Fairhurst <[email-masked]> wrote:
> 
> 
> TSVWG,
> 
> The WGLC for i-Data, draft-ietf-tsvwg-sctp-ndata, has concluded and the Chairs are now preparing a publication request for this document as PS.
> 
> To complete the write-up of this spec, we would be interested to hear of any implementations of the spec. Please let the Chairs know if you plan to or have already completed implementation of this SCTP update (and provide a few lines of text that we may compile into the write-up for this document).
Hi Gorry,

The FreeBSD kernel implementation and the userland stack usrsctp (which is shares most of the code) support
the sending and receiving of I-DATA chunks. The implementation of interleaving schedulers is still missing,
but it is planned to implement them in the timeframe of IETF 99.

Best regards
Michael