Subject: [tsvwg] New Version draft-ietf-tsvwg-rfc6040update-shim-02

From: Bob Briscoe <[email-masked]>
Date: Fri, 16 Jun 2017 15:47:58 +0100

David, as doc shepherd.

I have just posted a major revision to draft-ietf-tsvwg-rfc6040update-shim

Please also take this as a request to give a 10min presentation in tsvwg.

As requested, I included specific text necessary to update certain shim 
tunnel protocols that didn't mention ECN at all (L2TPv2, L2TPv3, GRE).
There are two others to do:
* Teredo: I'll do this once I hear from the original author, Christian 
Huitema
* VXLAN-GPE: This is a draft currently going through NVO3 on the 
standards track. AFAIK the Linux implementation already supports ECN via 
RFC6040, but the authors will need to add ECN text to the spec, so there 
is something for other implementations to follow. I have contacted them 
- they should do this, not me.

I have also added more protocols to the list (e.g. CAPWAP, LISP), but 
these already supported ECN.

As you have seen, I have been in conversation with people on the l2tpext 
list, and on opsawg (for CAPWAP). I haven't found anyone specific to 
talk to regarding GRE yet, but I have notified int-area and I gave a 
heads-up at a recent IETF.

BTW, your plan was to last call draft-ietf-tsvwg-rfc6040update-shim 
along with ecn-encap-guidelines, deadline Sep 2017.
I should point out that draft-ietf-trill-ecn-support is in WGLC in 
trill, and it depends normatively on ecn-encap-guidelines

opsawg would like to last call draft-ietf-tsvwg-rfc6040update-shim as 
well (altho I have now realized that no update to CAPWAP is needed, but 
opsawg is now working on alternative tunnelling protocols to CAPWAP: 
draft-ietf-opsawg-capwap-alt-tunnel ). I guess int-area might want to 
last call draft-ietf-tsvwg-rfc6040update-shim too.

Bob

-------- Forwarded Message --------
Subject: 	New Version Notification for 
draft-ietf-tsvwg-rfc6040update-shim-02.txt
Date: 	Fri, 16 Jun 2017 07:14:46 -0700
From: 	[email-masked]
To: 	Bob Briscoe <[email-masked]>

A new version of I-D, draft-ietf-tsvwg-rfc6040update-shim-02.txt
has been successfully submitted by Bob Briscoe and posted to the
IETF repository.

Name:		draft-ietf-tsvwg-rfc6040update-shim
Revision:	02
Title:		Propagating Explicit Congestion Notification Across IP Tunnel Headers Separated by a Shim
Document date:	2017-06-16
Group:		tsvwg
Pages:		15
URL:            https://www.ietf.org/internet-drafts/draft-ietf-tsvwg-rfc6040update-shim-02.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rfc6040update-shim/
Htmlized:       https://tools.ietf.org/html/draft-ietf-tsvwg-rfc6040update-shim-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-rfc6040update-shim-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-rfc6040update-shim-02

Abstract:
    RFC 6040 on "Tunnelling of Explicit Congestion Notification" made the
    rules for propagation of ECN consistent for all forms of IP in IP
    tunnel.  This specification extends the scope of RFC 6040 to include
    tunnels where two IP headers are separated by at least one shim
    header that is not sufficient on its own for packet forwarding.  It
    surveys widely deployed IP tunnelling protocols separated by a shim
    and updates the specifications of those that do not mention ECN
    propagation (L2TPv2, L2TPv3, GRE and Teredo).  The specification also
    updates RFC 6040 with configuration requirements needed to make any
    legacy tunnel ingress safe.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Black, David" <[email-masked]>
Date: Wed, 21 Jun 2017 19:00:39 +0000

> opsawg would like to last call draft-ietf-tsvwg-rfc6040update-shim as well (altho I have now realized that no update to CAPWAP is needed,
> but opsawg is now working on alternative tunnelling protocols to CAPWAP: draft-ietf-opsawg-capwap-alt-tunnel ). I guess int-area might want
> to last call draft-ietf-tsvwg-rfc6040update-shim too.

We can certainly announce the tsvwg WGLC to those two WGs in order to invite reviews and comments.

Thanks, --David

From: Bob Briscoe [mailto:[email-masked]]
Sent: Friday, June 16, 2017 10:48 AM
To: Black, David <[email-masked]>
Cc: tsvwg IETF list <[email-masked]>
Subject: New Version draft-ietf-tsvwg-rfc6040update-shim-02

David, as doc shepherd.

As requested, I included specific text necessary to update certain shim tunnel protocols that didn't mention ECN at all (L2TPv2, L2TPv3, GRE).
There are two others to do:
* Teredo: I'll do this once I hear from the original author, Christian Huitema
* VXLAN-GPE: This is a draft currently going through NVO3 on the standards track. AFAIK the Linux implementation already supports ECN via RFC6040, but the authors will need to add ECN text to the spec, so there is something for other implementations to follow. I have contacted them - they should do this, not me.

I have also added more protocols to the list (e.g. CAPWAP, LISP), but these already supported ECN.

As you have seen, I have been in conversation with people on the l2tpext list, and on opsawg (for CAPWAP). I haven't found anyone specific to talk to regarding GRE yet, but I have notified int-area and I gave a heads-up at a recent IETF.

BTW, your plan was to last call draft-ietf-tsvwg-rfc6040update-shim along with ecn-encap-guidelines, deadline Sep 2017.
I should point out that draft-ietf-trill-ecn-support is in WGLC in trill, and it depends normatively on ecn-encap-guidelines

opsawg would like to last call draft-ietf-tsvwg-rfc6040update-shim as well (altho I have now realized that no update to CAPWAP is needed, but opsawg is now working on alternative tunnelling protocols to CAPWAP: draft-ietf-opsawg-capwap-alt-tunnel ). I guess int-area might want to last call draft-ietf-tsvwg-rfc6040update-shim too.

Bob

-------- Forwarded Message --------
Subject:

New Version Notification for draft-ietf-tsvwg-rfc6040update-shim-02.txt

Date:

Fri, 16 Jun 2017 07:14:46 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Bob Briscoe <[email-masked]><mailto:[email-masked]>

IETF repository.

Revision:     02

Group:        tsvwg

Pages:        15

Abstract:

The IETF Secretariat