Subject: Re: [tsvwg] Doubts regarding motivation of draft-ietf-tsvwg-iana-dscp-registry-04

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 8 May 2018 09:26:27 +0000

Mikael,
Lots of thanks for a prompt response. 

Your objective makes sense to me, but it does not appear in the draft in any form.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

-----Original Message-----
From: Mikael Abrahamsson [mailto:[email-masked]] 
Sent: Tuesday, May 8, 2018 12:14 PM
To: Alexander Vainshtein <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [tsvwg] Doubts regarding motivation of draft-ietf-tsvwg-iana-dscp-registry-04

On Tue, 8 May 2018, Alexander Vainshtein wrote:

> Godred and all,
> I have looked up the draft<https://tools.ietf.org/html/draft-ietf-tsvwg-iana-dscp-registry-04>, and I have doubts regarding validity of its motivation.
> The draft says - correctly -that 22 out of 32 values in Pool 1 of the DSCP code points have been already assigned, therefore it considers this pool as nearly exhausted.
>
> What the draft does not say that, out of these 22 assignments, 2o have been done in 1998 and one - in 1999. Only one assignment has been requested in the past 19 years, and no assignments have been requested after 2010.
>
> At this rate my estimate is that Pool 1 would suffice for the next 50+ years without its exhaustion becoming an issue. So why should the IETF do anything now?

The primary reason for this is not because pool 1 is becoming exhausted, but the fact that we want to use 000001 for LE (for practical/legacy reasons, not because pool 1 is becoming exhausted), so the suggestion is therefore to make Pool 3 have a different allocation policy so we can put in a standards track PHB LE RFC for 000001.

-- 
Mikael Abrahamsson    email: [email-masked]

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: "Black, David" <[email-masked]>
Date: Tue, 8 May 2018 14:04:31 +0000

>From the draft writeup (at https://datatracker.ietf.org/doc/draft-ietf-tsvwg-iana-dscp-registry/shepherdwriteup/):

The Transport Area WG (tsvwg) is in the process of updating the RFC 3662
specification of the Diffserv Lower Effort (LE) PHB/PDB, which provides
a less than best effort or scavenger forwarding behavior.  This update
includes assignment of a new default Diffserv Codepoint (DSCP) to
replace use of the CS1 DSCP (001000) for that purpose.  The IANA
registration policy for part of the IANA DSCP registry has to be changed
in order to make that assignment; this draft makes that necessary IANA
registration policy change.

The number of possible DSCPs for the LE PHB is surprisingly limited:
  - The three most significant bits have to be '000' to accommodate
     legacy (non-Diffserv) routers whose forwarding behavior is based
     upon only those three bits, the former IP Precedence field
  - The least significant bit must be '1' in order to avoid priority
     inversion that could result from legacy router zeroing of the former
     IP Precedence field in a DSCP that is intended to provide better
     than best effort forwarding.  That IP Precedence zeroing behavior
     has been observed in the Internet.  This requirement excludes
     DSCP Pool 1 (xxxxx0) values.
  - DSCP values whose two least significant bits are '11' are not
     available because DSCP Pool 2 (xxxx11) values have been reserved
     for Experimental or Local Use.
The only remaining DSCPs that could be assigned to the LE PHB are
000001 and 000101, both of which are in DSCP Pool 3 (xxxx01).

Thanks, --David

> From: tsvwg [mailto:[email-masked]] On Behalf Of Alexander
> Vainshtein
> Sent: Tuesday, May 8, 2018 5:26 AM
> To: Mikael Abrahamsson
> > I have looked up the draft<https://tools.ietf.org/html/draft-ietf-tsvwg-
> iana-dscp-registry-04>, and I have doubts regarding validity of its motivation.
> > The draft says - correctly -that 22 out of 32 values in Pool 1 of the DSCP
> code points have been already assigned, therefore it considers this pool as
> nearly exhausted.
> >
> > What the draft does not say that, out of these 22 assignments, 2o have
> been done in 1998 and one - in 1999. Only one assignment has been
> requested in the past 19 years, and no assignments have been requested
> after 2010.
> >
> > At this rate my estimate is that Pool 1 would suffice for the next 50+ years
> without its exhaustion becoming an issue. So why should the IETF do
> anything now?
> 
> The primary reason for this is not because pool 1 is becoming exhausted, but
> the fact that we want to use 000001 for LE (for practical/legacy reasons, not
> because pool 1 is becoming exhausted), so the suggestion is therefore to
> make Pool 3 have a different allocation policy so we can put in a standards
> track PHB LE RFC for 000001.
> 
> --