Subject: [GNAP] physical person

From: Tom Jones <[email-masked]>
Date: Sun, 13 Dec 2020 10:06:53 -0800

I dislike this. A robot can be a physical person. What's wrong with natural
person that others use?
Peace ..tom

---

From: Fabien Imbault <[email-masked]>
Date: Sun, 13 Dec 2020 19:43:48 +0100

Hi,

Wasn't thinking about that, but yes.
Natural person would be good. I change it in the wiki.

Thxs
Fabien

On Sun, Dec 13, 2020 at 7:07 PM Tom Jones <[email-masked]>
wrote:

> I dislike this. A robot can be a physical person. What's wrong with
> natural person that others use?
> Peace ..tom
> --
> TXAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>

---

From: Jim Willeke <[email-masked]>
Date: Sun, 13 Dec 2020 15:20:00 -0500

A natural person is usually implied to be a Human Being.
As in jurisprudence, fundamental human rights are implicitly granted only
to Natural Persons.

A person or entity seems to be more appropriate.

--
-jim
Jim Willeke

---

From: Fabien Imbault <[email-masked]>
Date: Sun, 13 Dec 2020 21:23:19 +0100

Hi,

Yes.

For end user at least, we wanted to convey that it is a real person.

The case is different for the RO, indeed here person would be enough I
believe.

Fabien

---

From: Tom Jones <[email-masked]>
Date: Sun, 13 Dec 2020 14:31:14 -0800

agree w/ Fabien on that point.  My own preference would be to call the RO
an entity, which means a named object.
Peace ..tom

---

From: Jim Willeke <[email-masked]>
Date: Mon, 14 Dec 2020 03:51:30 -0500

Yes, I agree.
--
-jim
Jim Willeke

On Sun, Dec 13, 2020 at 5:31 PM Tom Jones <[email-masked]>
wrote:

>>> As in jurisprudence, fundamental human rights are implicitly granted
>>> only to Natural Persons.
>>>

---

From: Fabien Imbault <[email-masked]>
Date: Mon, 14 Dec 2020 09:57:39 +0100

Thanks for your inputs, we can try to update the definition of RO
using "entity".

Currently we have : person acting on its own or representing an
organization, that may grant privileges on resources he has authority upon

Alternative 1 : personal or organizational entity that may grant privileges
on resources it has authority upon
Alternative 2 : entity that may grant privileges on resources it has
authority upon

What do you think?

Cheers
Fabien

On Mon, Dec 14, 2020 at 9:52 AM Jim Willeke <[email-masked]> wrote:

>>>> On Sun, Dec 13, 2020 at 1:44 PM Fabien Imbault <
>>>> [email-masked]> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> On Sun, Dec 13, 2020 at 7:07 PM Tom Jones <
>>>>> [email-masked]> wrote:
>>>>>

---

From: Tom Jones <[email-masked]>
Date: Mon, 14 Dec 2020 07:53:22 -0800

Either sounds good to me.

thx ..Tom (mobile)

On Mon, Dec 14, 2020, 12:57 AM Fabien Imbault <[email-masked]>
wrote:

> Alternative 1 : personal or organizational entity that may grant
> privileges on resources it has authority upon
>>> agree w/ Fabien on that point.  My own preference would be to call the
>>> RO an entity, which means a named object.
>>> Peace ..tom
>>>
>>>
>>> On Sun, Dec 13, 2020 at 12:23 PM Fabien Imbault <

---

From: Fabien Imbault <[email-masked]>
Date: Mon, 14 Dec 2020 18:30:06 +0100

Ok I've updated the wiki with alternative 1.
Cheers
Fabien