Subject: [GNAP] Build Previews on GitHub

From: Justin Richer <[email-masked]>
Date: Thu, 17 Dec 2020 16:48:45 -0500

Based on community feedback, the editors have deployed some tools to augment the GitHub repository and increase its usefulness to the working group.

First, we’ve set up a few checks to make sure that branches are properly tagged and reviewed before a pull request is merged. While no system is perfect, this should add at least one extra layer of sanity check.

Second, we’ve set up some automated systems so that the document is automatically built from the “main” branch whenever a new commit is pushed there. In addition, a rendered version of the current state of the repository should always be available at https://gnap-core-protocol-editors-draft.netlify.app/ <https://gnap-core-protocol-editors-draft.netlify.app/> as long as it is building successfully.

Furthermore, all future pull requests will now be automatically rendered as well. This feature has two purposes: it makes sure a commit doesn’t break the rendering toolchain (a failure will show up on the PR), and it also automatically makes the a rendered version of the changes in the pull request available on a draft URL. For example, the PR that added this functionality is here:

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/151 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/151>

On that pull request, you’ll see a comment from the “github-actions" bot with a URL link. This unique URL hosts a copy of the document including all changes in the pull request. 

IMPORTANT NOTE: All of these automatically deployed documents are provided as a convenience and are not official working group drafts. The only official drafts are those published in the IETF tool suite, available from the DataTracker page: https://datatracker.ietf.org/doc/draft-ietf-gnap-core-protocol/ <https://datatracker.ietf.org/doc/draft-ietf-gnap-core-protocol/>

In particular, this means that:

1) The editors’ draft preview is not the working group document, but it is the current state of the document in between published revisions.

2) The automatically generated editors’ draft, and the pull request previews in particular, should not be linked or referenced externally. These URLs could change or disappear at any time, without warning, for any reason. They are not intended to be archival, and the canonical copy of the current editors’ draft will always be the source document in the repository’s “main” branch itself.

As always, the document can be rendered directly by downloading the repository and following the build instructions in the README.md file. 

Thank you all,

 — Justin, Aaron, and Fabien

---

From: Dave Tonge <[email-masked]>
Date: Fri, 18 Dec 2020 09:15:20 +0100

Thank you editors, this is very helpful and hopefully can be a model for
standards development wider than this WG.

On Thu, 17 Dec 2020 at 22:48, Justin Richer <[email-masked]> wrote:

> Based on community feedback, the editors have deployed some tools to
> augment the GitHub repository and increase its usefulness to the working
> group.
>
> First, we’ve set up a few checks to make sure that branches are properly
> tagged and reviewed before a pull request is merged. While no system is
> perfect, this should add at least one extra layer of sanity check.
>
> Second, we’ve set up some automated systems so that the document is
> automatically built from the “main” branch whenever a new commit is pushed
> there. In addition, a rendered version of the current state of the
> repository should always be available at
> https://gnap-core-protocol-editors-draft.netlify.app/ as long as it is
> building successfully.
>
> Furthermore, all future pull requests will now be automatically rendered
> as well. This feature has two purposes: it makes sure a commit doesn’t
> break the rendering toolchain (a failure will show up on the PR), and it
> also automatically makes the a rendered version of the changes in the pull
> request available on a draft URL. For example, the PR that added this
> functionality is here:
>
> https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/151
>
> On that pull request, you’ll see a comment from the “github-actions" bot
> with a URL link. This unique URL hosts a copy of the document including all
> changes in the pull request.
>
> *IMPORTANT NOTE*: All of these automatically deployed documents are
> provided as a convenience and *are not official working group drafts*.
> The only official drafts are those published in the IETF tool suite,
> available from the DataTracker page:
> https://datatracker.ietf.org/doc/draft-ietf-gnap-core-protocol/
>
> 1) The editors’ draft preview is not the working group document, but it is
> the current state of the document in between published revisions.
>
> 2) The automatically generated editors’ draft, and the pull request
> previews in particular, should not be linked or referenced externally.
> These URLs could change or disappear at any time, without warning, for any
> reason. They are not intended to be archival, and the canonical copy of the
> current editors’ draft will always be the source document in the
> repository’s “main” branch itself.
>
>
> As always, the document can be rendered directly by downloading the
> repository and following the build instructions in the README.md file.
>
> Thank you all,
>
> --
> TXAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>

-- 
Dave Tonge

-- 

Moneyhub Enterprise is a trading style of Moneyhub Financial Technology 
Limited which is authorised and regulated by the Financial Conduct 
Authority ("FCA"). Moneyhub Financial Technology is entered on the 
Financial Services Register (FRN 809360) at https://register.fca.org.uk/ 
<https://register.fca.org.uk/>. Moneyhub Financial Technology is registered 
in England & Wales, company registration number 06909772. Moneyhub 
Financial Technology Limited 2020 © Moneyhub Enterprise, Regus Building, 
Temple Quay, 1 Friary, Bristol, BS1 6EA. 

DISCLAIMER: This email 
(including any attachments) is subject to copyright, and the information in 
it is confidential. Use of this email or of any information in it other 
than by the addressee is unauthorised and unlawful. Whilst reasonable 
efforts are made to ensure that any attachments are virus-free, it is the 
recipient's sole responsibility to scan all attachments for viruses. All 
calls and emails to and from this company may be monitored and recorded for 
legitimate purposes relating to this company's business. Any opinions 
expressed in this email (or in any attachments) are those of the author and 
do not necessarily represent the opinions of Moneyhub Financial Technology 
Limited or of any other group company.

---

From: Tim Cappalli <[email-masked]>
Date: Mon, 21 Dec 2020 18:09:44 +0000

+1, this is awesome Justin!

From: TXAuth <[email-masked]> on behalf of Dave Tonge <[email-masked]>
Date: Friday, December 18, 2020 at 03:16
To: Justin Richer <[email-masked]>
Cc: txauth gnap <[email-masked]>
Subject: Re: [GNAP] Build Previews on GitHub
Thank you editors, this is very helpful and hopefully can be a model for standards development wider than this WG.

On Thu, 17 Dec 2020 at 22:48, Justin Richer <[email-masked]<mailto:[email-masked]>> wrote:
Based on community feedback, the editors have deployed some tools to augment the GitHub repository and increase its usefulness to the working group.

Second, we’ve set up some automated systems so that the document is automatically built from the “main” branch whenever a new commit is pushed there. In addition, a rendered version of the current state of the repository should always be available at https://gnap-core-protocol-editors-draft.netlify.app/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgnap-core-protocol-editors-draft.netlify.app%2F&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C4bd873837e414d56a03a08d8a32d1bb2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637438761836779317%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=8T8KZYvT8s0psEW02bbhHQR9qys913j%2BfOPa5T6U2Po%3D&reserved=0> as long as it is building successfully.

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/151<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fietf-wg-gnap%2Fgnap-core-protocol%2Fpull%2F151&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C4bd873837e414d56a03a08d8a32d1bb2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637438761836779317%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2FccsCxktkgB43%2F6GIcQwt5dt3IdL%2Fpl7LyR%2BqyzXLbM%3D&reserved=0>

IMPORTANT NOTE: All of these automatically deployed documents are provided as a convenience and are not official working group drafts. The only official drafts are those published in the IETF tool suite, available from the DataTracker page: https://datatracker.ietf.org/doc/draft-ietf-gnap-core-protocol/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-gnap-core-protocol%2F&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C4bd873837e414d56a03a08d8a32d1bb2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637438761836789317%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=4NLd0p3HR%2FqElrx7PEi9Ed2R0HV27HY3qjX0yHzG59w%3D&reserved=0>

Thank you all,

 — Justin, Aaron, and Fabien
--
TXAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftxauth&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C4bd873837e414d56a03a08d8a32d1bb2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637438761836789317%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=kBBD6tlAFByCWd8RKOP02%2FLOs8L4pjFr0Rj32EQIvbI%3D&reserved=0>

--
Dave Tonge

Moneyhub Enterprise is a trading style of Moneyhub Financial Technology Limited which is authorised and regulated by the Financial Conduct Authority ("FCA"). Moneyhub Financial Technology is entered on the Financial Services Register (FRN 809360) at https://register.fca.org.uk/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fregister.fca.org.uk%2F&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C4bd873837e414d56a03a08d8a32d1bb2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637438761836799305%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=u9nymEXgowT%2B6cJk3eXqZ7t9X0JXOwyv26TkdBgPKk8%3D&reserved=0>. Moneyhub Financial Technology is registered in England & Wales, company registration number 06909772. Moneyhub Financial Technology Limited 2020 © Moneyhub Enterprise, Regus Building, Temple Quay, 1 Friary, Bristol, BS1 6EA.

DISCLAIMER: This email (including any attachments) is subject to copyright, and the information in it is confidential. Use of this email or of any information in it other than by the addressee is unauthorised and unlawful. Whilst reasonable efforts are made to ensure that any attachments are virus-free, it is the recipient's sole responsibility to scan all attachments for viruses. All calls and emails to and from this company may be monitored and recorded for legitimate purposes relating to this company's business. Any opinions expressed in this email (or in any attachments) are those of the author and do not necessarily represent the opinions of Moneyhub Financial Technology Limited or of any other group company.