Subject: [GNAP] Editors Update

From: Justin Richer <[email-masked]>
Date: Wed, 23 Feb 2022 19:38:51 -0500

Ahead of the IETF113 meeting, the editors have been working hard at putting together a set of targeted changes for a new revision. There are currently 13 pull requests tagged for inclusion in one week. Please review these and comment as you find things that need to be improved. Some of these are relatively minor syntax changes, some are mostly editorial, and some add or call out requirements where previously they had been implied. We know there’s a lot to cover here, but please take a look when you can.

Harmonize URL/URI
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/377 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/377>

Assertions as array
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/379 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/379>

Data URI for logo
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/380 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/380>

Strengthened normative requirements for continue timeout
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/388 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/388>

Redefine user code interaction methods
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/389 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/389>

Clarified user presence on interaction finish methods
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/390 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/390>

Specify the content type for Discovery’s endpoint response (thanks, Andrii!)
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/398 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/398>

New 7.1.2 section on key protection
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/399 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/399>

Consistent formatting of parameter lists
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/400 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/400>

Cleanup issue 43
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/401 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/401>

Rewording
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/402 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/402>

Rename overall diagram
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/403 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/403>

Plus one tagged editorial:

Minor edits (thanks, Yaron!)
https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/394 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/394>

These will stay open for comment for one week from today. The editors intend to create a new draft based on acceptance of all of these PRs, ahead of the deadlines for IETF113.

Thanks, and we hope to see you there!

 — Justin, Aaron, and Fabien

---

From: Yaron Sheffer <[email-masked]>
Date: Sat, 26 Feb 2022 20:32:27 +0200

Thanks editors.

I would like to encourage the editorial team to stabilize the protocol by defining must-implement mechanisms where it makes sense. 

In my opinion, we should consider a single MTI for:

Key formats
Key proof of possession (a.k.a.) message signatures.

But maybe also for:
Start interaction modes
Finish interaction modes

Eventually the market will decide. But at this stage of the protocol’s development, we should narrow the field somewhat to enable interoperability between minimal Client and minimal AS implementations.

Thanks,

                Yaron

From: TXAuth <[email-masked]> on behalf of Justin Richer <[email-masked]>
Date: Thursday, February 24, 2022 at 02:39
To: GNAP Mailing List <[email-masked]>
Subject: [GNAP] Editors Update

Harmonize URL/URI

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/377

Assertions as array

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/379

Data URI for logo

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/380

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/388

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/389

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/390

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/398

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/399

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/400

Cleanup issue 43

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/401

Rewording

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/402

Rename overall diagram

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/403

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/394

 

-- TXAuth mailing list [email-masked] https://www.ietf.org/mailman/listinfo/txauth