Subject: [Unbearable] Bangkok?

From: Leif Johansson <[email-masked]>
Date: Mon, 17 Sep 2018 12:16:07 +0200

Could folks who believe we have stuff to talk about at IETF103 suggest
agenda items before Friday pls!

	Cheers Leif

---

From: Brian Campbell <[email-masked]>
Date: Wed, 19 Sep 2018 11:55:50 -0600

I'll take a few minutes to discuss or update on anything that might come up
with TTRP as it goes through WGLC and hopefully on to the IESG.
https://datatracker.ietf.org/doc/draft-ietf-tokbind-ttrp/

On Mon, Sep 17, 2018 at 4:16 AM Leif Johansson <[email-masked]> wrote:

> _______________________________________________
> Unbearable mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/unbearable
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Brian Campbell <[email-masked]>
Date: Wed, 19 Sep 2018 13:22:10 -0600

And there's the active WG document "Token Binding for Transport Layer
Security (TLS) Version 1.3 Connections" which should probably be discussed.
Although that maybe raises other issues...
https://datatracker.ietf.org/doc/draft-ietf-tokbind-tls13/

On Wed, Sep 19, 2018 at 11:55 AM Brian Campbell <[email-masked]>
wrote:

> I'll take a few minutes to discuss or update on anything that might come
> up with TTRP as it goes through WGLC and hopefully on to the IESG.

---

From: Nick Harper <[email-masked]>
Date: Wed, 19 Sep 2018 12:37:44 -0700

I agree with Brian that we should probably discuss
draft-ietf-tokbind-tls13, which I think is ready for WGLC. (On the other
hand, the 0-RTT TB draft remains expired, where I think it should stay
until there's more interest in it.)

On Wed, Sep 19, 2018 at 12:22 PM, Brian Campbell <
bcampbell=[email-masked]> wrote:

> On Wed, Sep 19, 2018 at 11:55 AM Brian Campbell <
> [email-masked]> wrote:
>
> *CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly prohibited..
> If you have received this communication in error, please notify the sender
> immediately by e-mail and delete the message and any file attachments from
> your computer. Thank you.*
>

---

From: Andrei Popov <[email-masked]>
Date: Wed, 19 Sep 2018 19:45:28 +0000

+1: IMHO draft-ietf-tokbind-tls13 is ready for WGLC.

Cheers,

Andrei

From: Unbearable <[email-masked]> On Behalf Of Nick Harper
Sent: Wednesday, September 19, 2018 12:38 PM
To: Brian Campbell <bcampbell=[email-masked]>
Cc: IETF Tokbind WG <[email-masked]>; Leif Johansson <[email-masked]>
Subject: Re: [Unbearable] Bangkok?

I agree with Brian that we should probably discuss draft-ietf-tokbind-tls13, which I think is ready for WGLC. (On the other hand, the 0-RTT TB draft remains expired, where I think it should stay until there's more interest in it.)

On Wed, Sep 19, 2018 at 12:22 PM, Brian Campbell <bcampbell=[email-masked]<mailto:bcampbell=[email-masked]>> wrote:
And there's the active WG document "Token Binding for Transport Layer Security (TLS) Version 1.3 Connections" which should probably be discussed. Although that maybe raises other issues....
https://datatracker.ietf.org/doc/draft-ietf-tokbind-tls13/<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tokbind-tls13%2F&data=02%7C01%7CAndrei.Popov%40microsoft.com%7C9f8aef8080bc428756ea08d61e6771bc%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636729826986397048&sdata=GQ8aVyRs2RE2mJAmgOxPb%2BtsNgqQ02OeYPd3bY32j9Q%3D&reserved=0>

On Wed, Sep 19, 2018 at 11:55 AM Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:
I'll take a few minutes to discuss or update on anything that might come up with TTRP as it goes through WGLC and hopefully on to the IESG.
https://datatracker.ietf.org/doc/draft-ietf-tokbind-ttrp/<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tokbind-ttrp%2F&data=02%7C01%7CAndrei.Popov%40microsoft.com%7C9f8aef8080bc428756ea08d61e6771bc%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636729826986407056&sdata=%2Bo47dTDc83lA8UGBUp5I8IKUtmkStX0H%2Bj8L17ezgcs%3D&reserved=0>

On Mon, Sep 17, 2018 at 4:16 AM Leif Johansson <[email-masked]<mailto:[email-masked]>> wrote:

        Cheers Leif

_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/unbearable<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Funbearable&data=02%7C01%7CAndrei.Popov%40microsoft.com%7C9f8aef8080bc428756ea08d61e6771bc%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636729826986407056&sdata=fZxCIWVN83qoBhDxF9b0DB5N%2BBC0tfroC3GQAgMeFxI%3D&reserved=0>

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited...  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/unbearable<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Funbearable&data=02%7C01%7CAndrei.Popov%40microsoft.com%7C9f8aef8080bc428756ea08d61e6771bc%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636729826986417069&sdata=BHZIuDpCXtOiQodJEvCV4OGF%2FL6sAD9%2FTqWhCRob0QQ%3D&reserved=0>

---

From: John Bradley <[email-masked]>
Date: Wed, 19 Sep 2018 18:08:18 -0300

Nick,

Are you coming to Bangkok?

If so a summery of the 0RTT issues and options like you did previously
may be useful to help people get there heads around the issue.

John B.

On 9/19/2018 4:37 PM, Nick Harper wrote:
> draft-ietf-tokbind-tls13, which I think is ready for WGLC. (On the
> other hand, the 0-RTT TB draft remains expired, where I think it
> should stay until there's more interest in it.)
>
> On Wed, Sep 19, 2018 at 12:22 PM, Brian Campbell
> <bcampbell=[email-masked]
> <mailto:bcampbell=[email-masked]>> wrote:
>
>     And there's the active WG document "Token Binding for Transport
>     Layer Security (TLS) Version 1.3 Connections" which should
>     probably be discussed. Although that maybe raises other issues....  
>     <https://datatracker.ietf.org/doc/draft-ietf-tokbind-tls13/>
>
>     On Wed, Sep 19, 2018 at 11:55 AM Brian Campbell
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:
>
>         I'll take a few minutes to discuss or update on anything that
>         might come up with TTRP as it goes through WGLC and hopefully
>         on to the IESG.
>         <https://datatracker.ietf.org/doc/draft-ietf-tokbind-ttrp/>
>
>
>
>
>             [email-masked] <mailto:[email-masked]>
>             <https://www.ietf.org/mailman/listinfo/unbearable>
>
>
>     /CONFIDENTIALITY NOTICE: This email may contain confidential and
>     privileged material for the sole use of the intended recipient(s).
>     Any review, use, distribution or disclosure by others is strictly
>     prohibited...  If you have received this communication in error,
>     please notify the sender immediately by e-mail and delete the
>     message and any file attachments from your computer. Thank you./
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/unbearable>
>
>
>

---

From: Nick Harper <[email-masked]>
Date: Wed, 19 Sep 2018 14:28:42 -0700

Yes, I'm coming to Bangkok (although if quic or tls conflicts with tokbind,
I'll be at those instead of tokbind). I can review my previous slides and
put together an overview of the space for 0-RTT Token Binding.

On Wed, Sep 19, 2018 at 2:08 PM, John Bradley <[email-masked]> wrote:

> If so a summery of the 0RTT issues and options like you did previously may
> be useful to help people get there heads around the issue.
>
> John B.
>> Although that maybe raises other issues....
>> review, use, distribution or disclosure by others is strictly
>> prohibited...  If you have received this communication in error, please
>> notify the sender immediately by e-mail and delete the message and any file
>> attachments from your computer. Thank you.*
>>
> Unbearable mailing [email-masked]://www.ietf.org/mailman/listinfo/unbearable
>
>

---

From: John Bradley <[email-masked]>
Date: Wed, 19 Sep 2018 19:40:38 -0300

Thanks

On Wed, Sep 19, 2018, 6:29 PM Nick Harper <[email-masked]> wrote:

> Yes, I'm coming to Bangkok (although if quic or tls conflicts with
> tokbind, I'll be at those instead of tokbind). I can review my previous
> slides and put together an overview of the space for 0-RTT Token Binding.
>
>>>> I'll take a few minutes to discuss or update on anything that might
>>>> come up with TTRP as it goes through WGLC and hopefully on to the IESG.