Subject: Signed/Encrypted Mail URL

From: "Amit Kapoor" <[email-masked]>
Date: Tue, 24 Aug 1999 15:10:22 -0700

While fiddling around with S/MIME and
	mailto:, it struck me that it would be
	nice to allow browsers to invoke the
	mail client to generate a signed and/or
	encrypted mail message (with appropriate
	warnings to the user).  This would be
	very useful for bill payment and delivery
	and do not force the browsers to create
	a SSL connection with the server.

	I thought of extending mailto: to do the
	same, and have already received objections
	on that..:).  I guess we can always create
	a new url for the same..

	Anyway, this message is to find out if
	anyone else is interested in this and
	what would be the best way to solve it.

	cheers-

Amit

---

From: "Larry Masinter" <[email-masked]>
Date: Tue, 24 Aug 1999 16:22:51 PDT

There's no reason why 'mailto:[email-masked]' shouldn't
send a signed and encrypted message, if there's mutual
agreement about the preference to receive and the capability
to send.

Negotiation about capabilities and preferences seems to
be better handled in a protocol-dependent way, for HTTP
using UPGRADE and for mail using RESCAP.

For the former, see draft-ietf-tls-http-upgrade-02.txt;
for the latter, see draft-hoffman-rescap-mua-01.txt
http://www.ietf.org/ietf/99mar/rescap-agenda-99mar.txt,
draft-beck-rescap-req-02.txt, draft-hoffman-rescap-protocol-01.txt.

There's been a lot of pushback about creating new URL
schemes that differ from the 'original' URL scheme only
in the security parameters (https vs http), and an intent
to not continue in that direction.

Larry
-- 
http://www.parc.xerox.com/masinter

---

From: "Amit Kapoor" <[email-masked]>
Date: Tue, 24 Aug 1999 16:53:53 -0700

<snip>

> agreement about the preference to receive and the capability

	Agreed.  The problem is how to communicate a server
	side requirement (i.e the mail message should be signed
	and/or encrypted) for the URL.

<snip>

> draft-beck-rescap-req-02.txt, draft-hoffman-rescap-protocol-01.txt.

	I will look them over and transfer this discussion there.

	Thanks for the information.

Amit