Subject: Re: [urn] 2141bis questions - (10) Backward compatibility

From: Juha Hakala <[email-masked]>
Date: Mon, 05 Jan 2015 13:08:13 +0200

Hello,

On 25.12.2014 9:01, John C Klensin wrote:
> The registration procedures for formal and informal namespaces
> (Sections 8.1 and 8.2) both provide for revisions of the
> registration by updating the template.   Especially given some
> discussions in the WG, I think we should impose an explicit
> requirement for a description of differences from prior versions
> and/or backward compatibility in updated registrations.
>
> Do others agree?
+ 1

Juha
>
>     john
>
> _______________________________________________
> urn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/urn

-- 

  Juha Hakala
  Senior advisor

  The National Library of Finland
  Library Network Services
  P.O.Box 26 (Teollisuuskatu 23)
  FIN-00014 Helsinki University
  Tel. +358 9 191 44293
  Mobile +358 50 3827678

---

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Sat, 24 Jan 2015 20:14:15 -0700

>> and/or backward compatibility in updated registrations.

Good idea.

Peter

-- 
Peter Saint-Andre
https://andyet.com/

---

From: John C Klensin <[email-masked]>
Date: Sun, 25 Jan 2015 04:58:31 -0500

--On Saturday, January 24, 2015 20:14 -0700 Peter Saint-Andre -
&yet <[email-masked]> wrote:

>>> The registration procedures for formal and informal
>>> namespaces (Sections 8.1 and 8.2) both provide for revisions
>>> of the registration by updating the template.   Especially
>>> given some discussions in the WG, I think we should impose
>>> an explicit requirement for a description of differences
>>> from prior versions and/or backward compatibility in updated
>>> registrations.
>>> 
>>> Do others agree?
>> + 1
> 
> Good idea.

I rarely object to making a requirement stronger.   In the
working draft, ast sentence of section 8.1 tentatively revised
to read:

	"A revised registration MUST describe differences from
	prior versions and SHOULD make special note of any
	relevant changes in the underlying technologies or
	namespace management processes."

and a new template section added (A.10) to provide an explicit
slot for revision information.

That work?

    john

---

From: Juha Hakala <[email-masked]>
Date: Mon, 26 Jan 2015 07:21:31 +0200

Hello,

on the basis of experiences gathered during the revision of ISBN and NBN 
namespace registration requests, the revised text below works fine.

It is important to include changes both in namespace management 
processes and in underlying technologies, since a technological change 
may have a major impact on the management of the namespace (for 
instance, a change in the syntax of the identifier  may alter the way in 
which the URNs can be resolved).

Juha

-- 

  Juha Hakala
  Senior advisor