Subject: [urn] questions on new namespace registrations

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 10 Sep 2015 14:03:54 +0000

Dear urnbis,
I've just joined this list after discovering that the urnbis WG is busy working on updates to the URN registration template and procedures. I read that one goal of urnbis is to avoid the occurrence of "squatting" on namespaces, by making the process easier.

I have a "friend" who was intending to start the registration process to ask for a new formal, registered namespace; but who has been "squatting" on 2 namespace NIDs (to publish widely used xsd and xml documents). I think my friend needs advice.

The 2 squatted namespace NIDs are derived from the current and former domain names. Hypothetically, I'll call these "dslforum-org" and "broadband-forum-org".

Would it make sense to register both of these once the new registration process is in place?

My friend has expressed some sensitivity that these look nothing like currently registered formal URNs (none of which have hyphens, and which are all shorter). 
Would it make sense to register a new formal NID (for example, "bbf") that looks more like the other formally registered URNs? Or, if the squatted ones were to be registered, would those be just fine, and my friend should feel no shame in the lengthy and hyphenated nature of those NIDs?

Thanks,
Barbara

---

From: Barry Leiba <[email-masked]>
Date: Tue, 29 Sep 2015 15:14:23 -0400

Hi, Barbara.  I'm sorry you haven't gotten a response to this yet, so
in the hope of getting either a "Yes, what Barry said," or a "Oh, my,
Barry's totally full of potatoes, and here's what you should do
instead of listening to him," I'll give an answer.

> I have a "friend" [...]  I think my friend needs advice.

Wink-wink.

> The 2 squatted namespace NIDs are derived from the current and former
> domain names. Hypothetically, I'll call these "dslforum-org" and
> "broadband-forum-org".
>
> My friend has expressed some sensitivity that these look nothing like
> currently registered formal URNs (none of which have hyphens, and
> which are all shorter). Would it make sense to register a new formal
> NID (for example, "bbf") that looks more like the other formally
> registered URNs? Or, if the squatted ones were to be registered, would
> those be just fine, and my friend should feel no shame in the lengthy
> and hyphenated nature of those NIDs?

If the two in the first paragraph are already in use, I see no reason
to change them, and I'd suggest registering them as is.  If they're
theoretical, or if the current use is limited and easy to change, and
if they belong to the same organization (hypothetically, BBF), then
it'd be nicer (but not really because of the hyphens) to group them
together under the same NID, and just make them two "branches" that
are defined there (and then BBF could hypothetically define more
branches now or later if it needs them).

Barry