Subject: [urn] Formal request for URN for Persistent Web Identifier (PWID)

From: "Hakala, Juha E" <[email-masked]>
Date: Mon, 16 Jul 2018 08:34:08 +0000

Hello all,

Eld Zierau has sent today a revised namespace registration request for PWID to [email-masked]<mailto:[email-masked]>. The first version arrived in December 8th 2017. However, I don't remember having seen Eld's message back then, and as far as I remember correctly we have not processed the PWID template which is an Internet draft. Eld did remind me about her request in February, and I forwarded her email to Lars, but my email archive does not tell if he responded. Be that as it may, I should have been more active in getting this review started earlier - sorry.

Eld's original I-D was renewed in June; the brand new July version is -03 and can be found from

https://datatracker.ietf.org/doc/draft-pwid-urn-specification/

Versions are not radically different from one another, but the latest one - which I have not red yet - adds examples based on a prototype urn:pwid resolver under development in Denmark.

There is one sentence in the draft that I want to comment. Eld writes that:

"The textual version of the PWID is also suggested in a textual form in a draft of the revision of the ISO 690 reference standard."

I am the editor of ISO 690 (Guidelines for bibliographic references and citations to information resources). It is currently under revision, but the process is in the early stages (working draft). The draft standard shall not contain examples for URN:PWIDs as long as the URN namespace has not been formally registered. Some examples for PWIDs may however be added, since the importance of citing web archives is growing and we need not only guidelines on how to do that, but also increased stability the usage of persistent identifiers can provide.

I cannot claim to understand PWID fully since I don't know enough about web archiving. But I wonder if PWID were one of those namespaces which might benefit from the usage of r-component. If coverage-spec were not part of the identifier but included in r-component, it would be easier to add new functionality in the future and use similar functionality, when relevant, to other kind of resources.

Eld is a digital preservation specialist from the Royal Danish Library, with a lot of experience in web archiving. Any questions about PWID should be sent to her at [email-masked]; alas, she may not respond quickly since she is on summer vacation until 6th of August.

All the best,

Juha

---

From: "Svensson, Lars" <[email-masked]>
Date: Thu, 19 Jul 2018 06:56:55 +0000

Dear Juha,

On Monday, July 16, 2018 10:34 AM, urn [mailto:[email-masked]] On Behalf Of Hakala, Juha E wrote:

> Eld Zierau has sent today a revised namespace registration request for PWID to
> mailto:[email-masked]. The first version arrived in December 8th 2017. However, I don’t
> remember having seen Eld’s message back then, and as far as I remember correctly
> we have not processed the PWID template which is an Internet draft. Eld did remind
> me about her request in February, and I forwarded her email to Lars, but my email
> archive does not tell if he responded. Be that as it may, I should have been more
> active in getting this review started earlier – sorry.

No, I didn't see this registration request on the list in December (and cannot seem to find it in the list archive, either).

I'll have a closer look at it as soon as possible and consult with our web archiving specialists.

Best,

Lars

---

From: "Patrik Fältström" <[email-masked]>
Date: Thu, 19 Jul 2018 11:39:51 +0200

Hi,

FWIW 1, the acronym PWID is already used for pseudo wires. See for example RFC 6667. Whether that collision is a problem or not is not something I can judge.

FWIW 2, I have also not seen any earlier request to the [email-masked] mailing list, although I have seen the I-D posted.

   Patrik

On 16 Jul 2018, at 10:34, Hakala, Juha E wrote:

> _______________________________________________
> urn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/urn

---

From: John C Klensin <[email-masked]>
Date: Thu, 19 Jul 2018 07:09:19 -0400

If we can figure out how to do so, we should ask W3C to comment
on this, not to control whether the registration occurs, but to
get input on the specification to the authors and try to
generally improve things.  I think Mark Nottingham is still the
official liaison -- if he is not on this list (which he may be)
could someone who sees him today or tomorrow call it to his
attention and ask him to alert the relevant people.

thanks,
   john

--On Thursday, July 19, 2018 11:39 +0200 Patrik Fältström
<[email-masked]> wrote:

> Hi,
> 
> FWIW 1, the acronym PWID is already used for pseudo wires. See
> for example RFC 6667. Whether that collision is a problem or
> not is not something I can judge.
> 
> FWIW 2, I have also not seen any earlier request to the
> [email-masked] mailing list, although I have seen the I-D posted.
> 
>    Patrik
> 
>> Eld Zierau has sent today a revised namespace registration
>> request for PWID to [email-masked]<mailto:[email-masked]>. The
>> first version arrived in December 8th 2017. However, I don't
>> remember having seen Eld's message back then, and as far as I
>> remember correctly we have not processed the PWID template
>> which is an Internet draft. Eld did remind me about her
>> request in February, and I forwarded her email to Lars, but
>> my email archive does not tell if he responded. Be that as it
>> may, I should have been more active in getting this review
>> started earlier - sorry.
>> 
>> Versions are not radically different from one another, but
>> the latest one - which I have not red yet - adds examples
>> based on a prototype urn:pwid resolver under development in
>> Denmark.
>> 
>> "The textual version of the PWID is also suggested in a
>> textual form in a draft of the revision of the ISO 690
>> reference standard."
>> 
>> I am the editor of ISO 690 (Guidelines for bibliographic
>> references and citations to information resources). It is
>> currently under revision, but the process is in the early
>> stages (working draft). The draft standard shall not contain
>> examples for URN:PWIDs as long as the URN namespace has not
>> been formally registered. Some examples for PWIDs may however
>> be added, since the importance of citing web archives is
>> growing and we need not only guidelines on how to do that,
>> but also increased stability the usage of persistent
>> identifiers can provide.
>> 
>> I cannot claim to understand PWID fully since I don't know
>> enough about web archiving. But I wonder if PWID were one of
>> those namespaces which might benefit from the usage of
>> r-component. If coverage-spec were not part of the identifier
>> but included in r-component, it would be easier to add new
>> functionality in the future and use similar functionality,
>> when relevant, to other kind of resources.
>> 
>> Eld is a digital preservation specialist from the Royal
>> Danish Library, with a lot of experience in web archiving.
>> Any questions about PWID should be sent to her at [email-masked];
>> alas, she may not respond quickly since she is on summer
>> vacation until 6th of August.
>> 
>> All the best,
>> 
>> Juha
>>

---

From: [email-masked] (Henry S. Thompson)
Date: Thu, 19 Jul 2018 13:20:00 +0100

> attention and ask him to alert the relevant people.

I'm _not_ the official liaison, but I'll try to have a look and also to
pass this by some people I know in the persistent identifier community.

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/
 [mail from me _always_ has a .sig like this -- mail without it is forged spam]

---

From: John C Klensin <[email-masked]>
Date: Thu, 19 Jul 2018 08:30:27 -0400

Henry,

Thanks.  Again,, my goal is not to get a conclusion of "good" or
"bad" but to try to get the documentation and the registration
to reflect as much context and perspective as might be useful to
a reader or someone considering using the system.  In addition
and in parallel with a discussion that is going on in parallel,
if there are multiple proposals being developed in this area,
I'd like to be sure that everyone is aware of everyone else's
work.

   best,
    john

--On Thursday, July 19, 2018 13:20 +0100 "Henry S. Thompson"
<[email-masked]> wrote:

> John C Klensin writes:
> 
>> If we can figure out how to do so, we should ask W3C to
>> comment on this, not to control whether the registration
>> occurs, but to get input on the specification to the authors
>> and try to generally improve things.  I think Mark Nottingham
>> is still the official liaison -- if he is not on this list
>> (which he may be) could someone who sees him today or
>> tomorrow call it to his attention and ask him to alert the
>> relevant people.
> 
> I'm _not_ the official liaison, but I'll try to have a look
> and also to pass this by some people I know in the persistent
> identifier community.
> 
> ht