Subject: Last Call issues on USEPRO

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 28 Oct 2008 08:07:37 +0100

At long last, I've gotten around to doing what should have been done in 
September: Collate the list of Last Call comments.

The following were raised as ISSUEs, and have been assigned issue numbers:

*#1582** USEPRO LC 4.3 / 5.2.3: 4.3 overlooks chkscope
**#1583** USEPRO LC 5.2.3: Checkgroups control messages
**#1584 **USEPRO LC 3.2.1: Adding Injection-Date at posting agent
**#1585 **USEPRO LC : Length and final dots of newsgroups descriptions

I also have a couple of USEPRO issues in the tracker that don't seem to 
have been formally closed (another error by the chair, sorry 'bout that):

1412    USEPRO 5.3: Cancel newsgroups: matching
1413    USEPRO 5.5: ihave/sendme syntax
1414    USEPRO 3.2.1: delimiter for multiple Path identities
1415    USEPRO 3.2.1 - Number of path entries per site
1416    USEPRO 3.9: Reinjection and Injection-Date
1417    USEPRO 3.4: Injecting-agent modification of message-ID
1479    USEPRO: Whether moderators SHOULD retain message-ID
1482    USEPRO 3.2: Possibility to use non-resolvable domain name as 
path-identity

I believe #1416 is thoroughly closed; the others are, I believe, 
addressed, but not formally recorded as such.

Before I go through the comments and attempt to discern the consensus on 
these issues, I'm sending out this message to verify that I've got them all.

This is not an attempt to canvas new issues - just to verify that I've 
not overlooked anything on the mailing list. OK?

                        Harald

*

---

From: "Charles Lindsey" <[email-masked]>
Date: Thu, 30 Oct 2008 15:27:23 GMT

>**#1585 **USEPRO LC : Length and final dots of newsgroups descriptions

You are missing:

Date: Thu, 25 Sep 2008 15:06:35 GMT
Subject: Re: ISSUE: treatment of POSTED in proto articles

Which I think is the major item oustanding. Russ agrees that a current
MUST ought to be reduced to SHOULD, but I would prefer to reduce it beyond
that, so further opinions are needed.

#1584 also needs to be addressed, but Russ seems to agree that my
suggested wording is needed, or something like it, so it is just a matter
of rubber-stamping or otherwise by the WG.

I think the others are now fixed.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

To: [email-masked]
Xref: clerew local.usefor:24939
Path: clerew!chl
From: "Charles Lindsey" <[email-masked]>
Subject: Re: Last Call issues on USEPRO
Date: Thu, 30 Oct 2008 15:27:23 GMT
Lines: 37
Sender: [email-masked]

>**#1585 **USEPRO LC : Length and final dots of newsgroups descriptions

You are missing:

Date: Thu, 25 Sep 2008 15:06:35 GMT
Subject: Re: ISSUE: treatment of POSTED in proto articles

Which I think is the major item oustanding. Russ agrees that a current
MUST ought to be reduced to SHOULD, but I would prefer to reduce it beyond
that, so further opinions are needed.

#1584 also needs to be addressed, but Russ seems to agree that my
suggested wording is needed, or something like it, so it is just a matter
of rubber-stamping or otherwise by the WG.

I think the others are now fixed.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

Date: Tue, 28 Oct 2008 18:26:07 +0100
From: Harald Tveit Alvestrand <[email-masked]>
To: [email-masked]
CC: [email-masked]
Subject: #1582 Re: Commit in docs/usefor (usepro.xml)
Sender: [email-masked]

I'm taking this checkin as resolution of issue #1582.

This is not yet reflected in a published draft; I assume it will be in -13.

[email-masked] skrev:
>     Date: Sunday, September 21, 2008 @ 17:18:17
>   Author: eagle
> Revision: 5041
>
> Fix a conflict between the wording of the application/news-checkgroups
> message and the checkgroups control message around <chkscope>.  Clarify
> that a checkgroups can be limited by external information, and that
> limits the requirement for it to be complete to a SHOULD.
>
> Modified:
>   docs/usefor/usepro.xml
>
> Modified: docs/usefor/usepro.xml
> ===================================================================
> --- docs/usefor/usepro.xml	2008-09-22 00:13:33 UTC (rev 5040)
> +++ docs/usefor/usepro.xml	2008-09-22 00:18:17 UTC (rev 5041)
> @@ -1663,9 +1663,11 @@
>  
>          <t>One application/news-checkgroups message may contain
>          information for one or more hierarchies and is considered complete
> -        for any hierarchy for which it contains a &lt;valid-group>.  In
> -        other words, an application/news-checkgroups body part consisting
> -        of:</t>
> +        for any hierarchy for which it contains a &lt;valid-group> unless
> +        accompanied by external information limiting its scope (such as a
> +        &lt;chkscope> parameter to a checkgroups control message as
> +        described in <xref target="checkgroups" />).  In other words, an
> +        application/news-checkgroups body part consisting of:</t>
>  
>          <figure>
>            <artwork>
> @@ -1679,7 +1681,8 @@
>          This media type therefore MUST NOT be used for conveying partial
>          information about a hierarchy; if a group from a given hierarchy
>          is present, all groups that exist in that hierarchy MUST be
> -        listed.</t>
> +        listed unless its scope is limited by external information, in
> +        which case all groups SHOULD be listed.</t>
>        </section>
>      </section>
>  
>
>
>   

Date: Tue, 28 Oct 2008 18:22:50 +0100
From: Harald Tveit Alvestrand <[email-masked]>
To: =?windows-1252?Q?Julien_=C9LIE?= <[email-masked]>
CC: Usefor WG <[email-masked]>
Subject: #1585 Re: Tr: ISSUE: Length and final dots of newsgroups descriptions.
Sender: [email-masked]

Julien ÉLIE skrev:
>
>> I think the group decided that "Tale's rules" for checkgroups lines were
>> two arcane to standardize, and the best that could be done was to 
>> document
>> them (for historic pouposes) in USEAGE.
>
> All right.  Thanks, Charles.  (Also thanks for your other answers.)
>
I'm closing this one as "no change needed".

Date: Tue, 28 Oct 2008 08:07:37 +0100
From: Harald Tveit Alvestrand <[email-masked]>
To: Usefor Mailing List <[email-masked]>
Subject: Last Call issues on USEPRO
Sender: [email-masked]

                        Harald

*