Subject: [Uta] Welcome from the chairs and work organization

From: "Orit Levin (LCA)" <[email-masked]>
Date: Fri, 13 Dec 2013 21:00:55 +0000

Following the conclusions from the last IETF88 meeting, we are thrilled to welcome you to the "Using TLS in Applications" (UTA) WG!
We would like to organize the initial discussion around the two following topics:

1. The text of the charter   http://datatracker.ietf.org/wg/uta/charter/ is straight forward. Please, read it and post any questions for clarification as needed. It is important to clearly scope this effort from the start.

2. If you are aware of written works (e.g., IETF drafts) that would directly apply to the UTA effort, please share them with the list. Specify in a few sentences what part(s) of the WG charter this material applies to.

This will help us to translate the goals into a list of tangible deliverables in the following weeks.

Let's start this important effort!
Orit and Leif as the WG chairs.

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 13 Dec 2013 15:02:51 -0700

On 12/13/13 2:00 PM, Orit Levin (LCA) wrote:

> 2. If you are aware of written works (e.g., IETF drafts) that
> would directly apply to the UTA effort, please share them with the
> list. Specify in a few sentences what part(s) of the WG charter
> this material applies to.

I've worked on draft-saintandre-xmpp-tls, which starts to update the
definition of using TLS in XMPP and also makes recommendations
regarding cipher suites, TLS versions, etc. I'm hoping that we can
remove some of that content and point to draft-sheffer-tls-bcp about
the latter topics, but in part I was trying to have one document
containing everything that an XMPP developer would need to know.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Fabio Pietrosanti (naif)" <[email-masked]>
Date: Fri, 13 Dec 2013 23:19:03 +0100

> 1. The text of the charter   http://datatracker.ietf.org/wg/uta/charter/ is straight forward. Please, read it and post any questions for clarification as needed. It is important to clearly scope th…

I'd like to suggest to evaluate extending the goal of the [Uta]
regarding the "use unauthenticated encryption through TLS when server
and/or client authentication cannot be achieved." .

The current defined goal is to "Consider, and possibly define, a
standard way for an application client and server to use unauthenticated
encryption through TLS when server and/or client authentication cannot
be achieved" .

I would consider better to place as a goal of the UTA WG to "Specify and
Define" rather than "Consider and possibly define" the pervasive use of TLS.

That's maybe something that would more "quickly" achieve
default-TLS-encryption for all internet protocols.

-- 
Fabio Pietrosanti (naif)
HERMES - Center for Transparency and Digital Human Rights
http://logioshermes.org - http://globaleaks.org - http://tor2web.org

---

From: Pete Resnick <[email-masked]>
Date: Sat, 14 Dec 2013 19:40:46 -0500

> default-TLS-encryption for all internet protocols.

This was discussed during the WG chartering process. The idea is to 
first determine that there is a need for this *beyond HTTP*. If it's 
only HTTP, that work will be handled by the HTTPBIS WG in conjunction 
with W3C. If it is more general, and the WG determines that a general 
solution is desired, the chairs will make that call and *then* it's time 
to create the spec.

Let's not re-charter the WG when it only got created last week. :-)

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478