Subject: [Uta] Heartbleed... and best practices for app developers in linking to TLS/SSL libraries?

From: Dan York <[email-masked]>
Date: Thu, 10 Apr 2014 13:42:11 +0000

UTA members,

With the Heartbleed exploit all over the news lately, it was pointed out to me that web *client* applications could be vulnerable to this in that if they visit a site operated by a malicious server, the server could exploit the bug to capture memory blobs from the client systems.  There is even demonstration code out there that shows how this can work:

https://github.com/Lekensteyn/pacemaker

Now, the path to exploit this on the client side might be more difficult because:
1. The attacker would have to get the client to visit the malicious site (i.e. via phishing or shared links on social media); or
2. The attacker would have to do a MiTM or modify code on an existing legitimate site; and
3. The attacker would have to repeatedly be retrieving memory blobs to try to see if anything interesting was in there.

Still, the possibility is out there that the client can leak information.  Much is being made in the media right now about *servers* updating their use of OpenSSL, but I've not seen much yet about clients that link to the OpenSSL libraries to make TLS/SSL connections.

I guess my thought is... as we develop documents for application developers about how to best use TLS in their apps, are there lessons we can take from all of this to add into those documents?     (And I haven't really thought through it all myself, yet... more just posing the question.)

Dan

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>
Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/deploy360/

---

From: Richard Moore <[email-masked]>
Date: Thu, 10 Apr 2014 21:44:10 +0100

On 10 April 2014 14:42, Dan York <[email-masked]> wrote:

> 1. The attacker would have to get the client to visit the malicious site
> (i.e. via phishing or shared links on social media); or
Note that the attack works after the serverhello, but before the cert is
transmitted so there's no MITM protection for clients against the attack.

Rich.

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Apr 2014 15:33:47 -0700

> (i.e. via phishing or shared links on social media); or

Accepted wisdom suggests that this is not hard.  As ekr points out,
all you need is a link:

[Free porn: click here]

The good news is that most (not all) of the current browsers don't use
OpenSSL.  But there are a lot of other *things* that do.

Even though this is a major problem, the general guidance is largely
the same: make sure to update bad software, quickly.