Subject: Re: [Uta] draft-sheffer-tls-bcp-02 and signature algorithm extension

From: Johannes Merkle <[email-masked]>
Date: Fri, 25 Apr 2014 10:49:40 +0200

Johannes Merkle wrote on 19.03.2014 17:34:
> Yaron, Ralf,
> 
> shouldn't draft-sheffer-tls-bcp-02 also give recommendations for clients on signaling minimum required hash functions
> via the signature algorithm extensions?
> 

maybe my post has been overlooked... Or is there simply no interest in this aspect?
Shouldn't a BCP for TLS include an option to avoid SHA-1 in digital signatures.

-- 
Johannes

---

From: Ralph Holz <[email-masked]>
Date: Fri, 25 Apr 2014 13:53:29 +0200

Hi,

> Shouldn't a BCP for TLS include an option to avoid SHA-1 in digital signatures.

I am sure there is interest, but I am not so sure we've made up our mind
on what to recommend. :)

The BCP's scope is to make workable yet secure recommendations, so in
order to suggest something other/better than SHA-1, I would like to have
some data on what current implementations do already support and what
they may support in the near future.

At least on browser side, I think support for the SHA-2 family is pretty
good, and auto-updates take care of the upgrading problem.

Ralph

-- 
Ralph Holz
I8 - Network Architectures and Services
Technische Universität München
http://www.net.in.tum.de/de/mitarbeiter/holz/
Phone +49.89.289.18043
PGP: A805 D19C E23E 6BBB E0C4  86DC 520E 0C83 69B0 03EF