Subject: [Uta] Recommendations for network operators regarding TLS usage by apps?

From: Dan York <[email-masked]>
Date: Wed, 22 Oct 2014 21:09:19 +0000

Question for the group  - while UTA is chartered to document best practices for TLS clients and servers, and to create a document for application protocol developers...  has anyone developed a document for network operators about recommendations for how they can best support all these TLS-encrypted applications?

It occurs to me that if we want TLS to be used by applications everywhere, it would also be helpful to provide guidance to network operators about how they can help with this overall "security upgrade" by not blocking TLS-encrypted streams from applications. Has anyone come up with any suggestions for ISPs/network operators (including enterprise networks that might have a firewall at the edge)?   Or is there nothing more really to say than "don't block TLS-encrypted apps"?

Just curious,  
Dan

P.S. And please feel free to tell me this is better sent to OPSEC or OPSAWG - or better yet to point me to docs there that I haven't found yet...

---

From: Olle E Johansson <[email-masked]>
Date: Thu, 23 Oct 2014 08:50:32 +0200

> P.S. And please feel free to tell me this is better sent to OPSEC or OPSAWG - or better yet to point me to docs there that I haven't found yet...

I get a lot of worried questions much like: "Then we can't use 
wireshark" when I talk about crypto.

That needs to be adressed too.

/O

---

From: Tom Ritter <[email-masked]>
Date: Thu, 23 Oct 2014 09:15:19 -0400

On 23 October 2014 02:50, Olle E Johansson <[email-masked]> wrote:
> I get a lot of worried questions much like: "Then we can't use wireshark"
> when I talk about crypto.
>

A walkthrough of using SSLKEYLOGFILE may address that, depending on
the application.  IIRC it works for Firefox and Chrome.

Besides NSS, the feature is in BoringSSL
(https://code.google.com/p/chromium/issues/detail?id=393477) and could
likely be ported to OpenSSL fairly easily.

I say this to provide context, I actually think it's a bad idea to
have these features enabled by default in production-compiled
libraries.

-tom

---

From: Dan York <[email-masked]>
Date: Thu, 23 Oct 2014 14:00:35 +0000

Olle,

On Oct 23, 2014, at 2:50 AM, Olle E Johansson <[email-masked]<mailto:[email-masked]>>
 wrote:

I get a lot of worried questions much like: "Then we can't use wireshark" when I talk about crypto.

Yes, this was part of the context in which the topic came up for me.  As I've talked about the idea of adding TLS to more applications (and pointed people to the work happening here in UTA) I've had responses from network operators generally fall in three camps:

1. "Wait! If application developers run everything over TLS, all we'll see are TLS-encrypted streams.  We won't be able to see into the traffic and manage our network appropriately."

2. "That's cool! That will make the Internet more secure for our customers. What can we do to help make TLS flow through our network better?"

3. "That's nice" ... as the eyes glaze over because we're talking about something higher than layer 3 and they want to go back to talking about IPv6 or BGP...

For the folks in #1 I don't know that there really is an easy answer other than "you're right... TLS makes the kind of probably benign monitoring you want to do harder, because the goal is to prevent the kind of malicious monitoring being done by attackers."   While "Sorry, deal with it" isn't a great response, I'm not sure how we answer that otherwise. (And I'd love to hear suggestions!)

It's the folks in #2 I'm interested in (because those in #3 just don't care).  Someone pointed me to these sites:

 * https://bettercrypto.org<https://bettercrypto.org/>
 * https://wiki.mozilla.org/Security/Server_Side_TLS

... both of which are useful to network operators / sys admins for configuring their servers and systems to use TLS.  Part of me is wondering if there is guidance out there somewhere for how configure firewalls  and other network edge devices to best support TLS... but maybe that guidance just comes down to "don't block TLS-encrypted streams!"

Dan

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>
Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/deploy360/