Subject: [Uta] Fallback Dance as Informational?

From: Massimiliano Pala <[email-masked]>
Date: Tue, 11 Nov 2014 12:37:42 -1000

Hi all,

one option that was not voted on today (and that I would like the WG to consider) is the possibility for this work to be an Informational RFC rather than a WG item.

I say this because, as presented, this work seems to be a collection of "workarounds" that browsers implement to keep working with buggy implementations of TLS.

The concern about this being a WG item is that (as mentioned in the slides) this MIGHT promote not-upgrading (web) servers since clients keep working anyway. 

In the browsers' world, there is the pressure for not loosing users (since they - the users - do not really care about security neither understand the consequences of using broken/superseded crypto) pushes vendors to try every possible way to get the data to the user even if that might compromise the security by using less secure/buggy/superseded protocols.

Although I think it is useful and important to document what browsers do, I think that we definitely do not want to encourage this type of behavior (e.g. in the MTA/MUA) for other applications.

I think that this document might be useful for understanding better how to design future versions of TLS so that documents like this will not be needed anymore.

For these reasons, I would vote for it to be informational rather than a WG item.

Just my 2 cents...

Cheers,
Max

---

From: Leif Johansson <[email-masked]>
Date: Wed, 12 Nov 2014 00:30:30 +0100

> one option that was not voted on today (and that I would like the WG to consider) is the possibility for this work to be an Informational RFC rather than a WG item.

Since we don't have a document yet it may be a bit premature to talk
about what status to give it.

I'll only note that informational, experimental or standards track
are all perfectly reasonable both as WG or as individual submissions.

	Cheers Leif

---

From: "Dr. Massimiliano Pala" <[email-masked]>
Date: Tue, 11 Nov 2014 14:00:53 -1000

Hi Leif,

thanks for pointing it out - what I meant to say was informational vs. 
standards track (not WG vs. non-WG).

Cheers,
Max

On 11/11/14, 1:30 PM, Leif Johansson wrote:
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta

---

From: Leif Johansson <[email-masked]>
Date: Wed, 12 Nov 2014 01:37:17 +0100

> standards track (not WG vs. non-WG).

Yeah lets burn that bridge when we have a document to look at.

	Cheers Leif