Subject: [Uta] Splitting the draft? [was RE: draft-ietf-uta-email-deep-00 comments]

From: "Orit Levin (LCA)" <[email-masked]>
Date: Mon, 2 Mar 2015 23:45:40 +0000

During the last meeting, I expressed my opinion (as an individual, not as a chair) that it would be reasonable to split the draft into two:
1.	A "best current practices for e-mail" document expanding the tls-bcp document and based on existing protocols and mechanisms.
2.	A separate "proposed standard" document defining new mechanisms in order to improve email security, etc. These correspond to definitions in sections 5, 6, 7, the related procedures throughout the document, and the IANA Considerations.

There was no time for this discussion at the meeting, so we agreed to move it to the list. I would like to know what people think about this direction.
Thanks,
Orit.

---

From: Ralph Holz <[email-masked]>
Date: Tue, 3 Mar 2015 11:35:30 +1100

Hi Orin,

How does this relate to the new drafts for Opportunistic Security? It seems
to me that at least the TLS level should be synchronised. So maybe it makes
sense to split this up, go ahead with opportunistic security profiles for
certain applications (= OS + DEEP, part 1), enhanced with further privacy
measures for email (= DEEP, part 2)?

Ralph

On 3 March 2015 at 10:45, Orit Levin (LCA) <[email-masked]> wrote:

> During the last meeting, I expressed my opinion (as an individual, not as
> a chair) that it would be reasonable to split the draft into two:
> 1.      A "best current practices for e-mail" document expanding the
> tls-bcp document and based on existing protocols and mechanisms.
> 2.      A separate "proposed standard" document defining new mechanisms in
> order to improve email security, etc. These correspond to definitions in
> sections 5, 6, 7, the related procedures throughout the document, and the
> IANA Considerations.
>
> There was no time for this discussion at the meeting, so we agreed to move
> it to the list. I would like to know what people think about this direction.
> Thanks,
> Orit.
>
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta
>

---

From: Chris Newman <[email-masked]>
Date: Tue, 03 Mar 2015 17:43:40 -0800

--On March 2, 2015 23:45:40 +0000 "Orit Levin (LCA)" <[email-masked]>
wrote:
> During the last meeting, I expressed my opinion (as an individual, not as a
> chair) that it would be reasonable to split the draft into two:
> 1. A "best current practices for e-mail" document expanding the tls-bcp
document
> and based on existing protocols and mechanisms.

imaps and pop3s are not existing standards, so if we're recommending those
protocols we need a standards track document to define them. I think we should
recommend those protocols. As we need a standards track document anyway, I'd
prefer we keep the content together to make it easier on implementers/readers.

> 2. A separate "proposed standard" document defining new mechanisms in order to
> improve email security, etc.
> These correspond to definitions in sections 5, 6, 7, the related procedures
> throughout the document, and the IANA Considerations.

If the WG has rough consensus that sections 5, 6, and 7 are not proposed
standard quality, I will follow WG direction and delete those sections from the
document. However, if that happens I will not volunteer to edit a separate
document containing those sections. So unless someone else volunteers to edit
that, the decision is about "deletion" not about "splitting". So I'll ask you
the question: are you proposing deletion of sections 5, 6 and 7 as not suitable
for proposed standard? If so, please state the technical reasons you believe
they are not suitable or something actionable that would convince you they are
suitable.

		Thanks,
		- Chris

> There was no time for this discussion at the meeting, so we agreed to move it
> to the list. I would like to know what people think about this direction.
> Thanks,
> Orit.
>

---

From: t.p. <[email-masked]>
Date: Wed, 4 Mar 2015 09:32:59 +0000

---- Original Message -----
From: "Chris Newman" <[email-masked]>
To: "Orit Levin (LCA)" <[email-masked]>; <[email-masked]>
Sent: Wednesday, March 04, 2015 1:43 AM
> > 1. A "best current practices for e-mail" document expanding the
tls-bcp
> protocols we need a standards track document to define them. I think
we should

Well, you might recall RFC 2595 Using TLS with IMAP, POP3 and ACAP. C.
Newman. June 1999.  It  is a Proposed Standard so there is a precedent
for doing this.

I think that anything to do with e-mail is going to be fraught.  So many
people do so many things with it, based on standards or not, that I see
consensus on anything as a challenge (a small hint thereof surfaced in
the main IETF list discussion on draft-faltstrom.uri recently and then
there is DMARC and then there is the fact that e-mail is store and
forward and not end-to-end).  So keep it as simple as possible else we
will never produce anything that gains consensus.

Tom Petch

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 05 Mar 2015 11:13:15 +0000

Hi Orit,

> 2.	A separate "proposed standard" document defining new mechanisms in order to improve email security, etc. These correspond to definitions in sections 5, 6, 7, the related procedures throughout th…
I am not a fan of creating more editorial work just for the sake of 
keeping clear separation. I think a better first question to ask would 
be if people are willing to implement "2".

My personal answer is that I already implement 1 and would like to 
implement 2.
> There was no time for this discussion at the meeting, so we agreed to move it to the list. I would like to know what people think about this direction.
Best Regards,
Alexey