Subject: RE: dual stack & IPv6 on by default

From: "Bound, Jim" <[email-masked]>
Date: Tue, 11 Mar 2003 16:07:53 -0500

Folks,

Mozilla is going to fix this.  Part of the problem was we took so long
getting rfc 2553 updated to new RFC (its in the RFC editor queue now)
they used Richard Stevens old program model.   This will be updated to
getaddrinfo and I agree with Itojun.  Now as usual we await release
updates :--) We also updated the API after this code base that is must
specify AI_MAPPED to get both v4 and v6.

Regards,
/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, March 11, 2003 3:46 PM
> To: Steven M. Bellovin
> Cc: Pekka Savola; Alain Durand; Bound, Jim; Sebastien Roy; 
> Mika Liljeberg; Ronald van der Pol; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: dual stack & IPv6 on by default 
> 
> 
> >There have been reports of problems with some Web browsers trying to
> >use only the v6 address.
> 
> 	this is due to the way mozilla is written.
> 	mozilla did:
> 		hp = gethostbyname2(host, AF_INET6);
> 		if (!hp)
> 			hp = gethostbyname(host);
> 	so mozilla tries to connect to IPv6/v4 dual stack 
> destination, it
> 	would try to connect to IPv6 only.  it has to be fixed by using
> 	getaddrinfo(3).
> 
> itojun
>

---

From: [email-masked]
Date: Wed, 12 Mar 2003 06:10:42 +0900

>specify AI_MAPPED to get both v4 and v6.

	no need for that, you can use PF_UNSPEC in hints.ai_family to get both
	IPv4 address (as ai_family = AF_INET) and IPv6 address (as ai_family
	= AF_INET6) and socket(2) as appropriate.

itojun