Subject: Note on Scenarios for IPv6

From: "Bound, Jim" <[email-masked]>
Date: Mon, 10 Mar 2003 19:58:09 -0500

Just as note.  Users are now working on their own scenarios and other
forums (not the IPv6 Forum, they have good work who does what with the
IETF).   If we don't do this quickly no one will care.  But if they are
just template for us to build tools they are still useful. 
 
Also realize folks are designing networks using the methods from Teredo,
ISATAP, and DSTM.
Just as a note.  Products exist for each too or about to be released.
 
The market is not waiting for v6ops. But this is true in other IETF
areas not just here.
 
Picking on our Ent work as example.  We have had pretty much the same
intro and scope we believed was important since the v6ops interim
meeting and in Yokohamma.  Today we now learn there is a scope issue.
Yokohamma was 9 months or so ago.  We need to fix this folks.  It is not
all the teams fault or the working group.  Its some kind of process we
are stuck in.  We need to break it.
 
/jim

---

From: Margaret Wasserman <[email-masked]>
Date: Mon, 10 Mar 2003 20:47:49 -0500

Hi Jim,

>intro and scope we believed was important since the v6ops interim meeting 
>and in Yokohamma.  Today we now learn there is a scope issue.  Yokohamma 
>was 9 months or so ago.  We need to fix this folks.  It is not all the 
>teams fault or the working group.  Its some kind of process we are stuck 
>in.  We need to break it.

Why do you believe that there is a scope issue for this
document?  I have just read it, again, and I do not believe
that there is anything wrong with the scope of this document.

Obviously, there are still many incomplete sections that
need to be completed, and there is some further editing
needed, but I believe that the scope and structure are
fine.

The important thing is that we write a set of documents
that help us to understand how enterprise networks will move
to IPv6, where/when/how/if they will need to run both IPv4
and IPv6, and what coexistence mechanisms will be needed
to make this work.

We broke the task into two pieces, scenarios and analysis,
because we wanted to understand the problem space before
we started working on the applicability of each coexistence
mechanism to the problem space.  I think that this document
does a good job of defining the problem space for our later
analysis work.

Margaret

---

From: "Bound, Jim" <[email-masked]>
Date: Tue, 11 Mar 2003 09:46:51 -0500

As one of our Ent design team members stated Mr. Tony Hain the matrix or
points on a graph for all the variant possibilities of how an enterprise
will approach adoption of IPv6 are to large to document each case.  The
approach we have taken is to select the best case scenarios and methods
to cover the widest possible cases.

I think one thing we realized on the Ent team is that we believe the
phrase IPv6 Adoption applies to the initial scenarios rather than IPv6
Transition.  First the Enterprise will believe it is important to Adopt
IPv6.  Then the Enterprise will look at all the possibilities to reach
that Adoption and develop their plan.

The key here is the Enterprise will NOT just do what we say in specs for
Adoption or Transition.  They look for us to provide them INPUT not the
PLAN.  This is a key assumption by us on the Ent team and have discussed
it in depth.

Out of curiosity does anyone in v6ops not agree with this?  It is an
assumption about our role in the industry at large too.

Another point I want to make that is important for folks to understand.
Large Enterprises like Fortune 100 companies, Government, Military, etc.
all hire very knowledgable computer scientists and folks just like on
this list who are experts like us with as much senority as many of us in
the industry.  They have architects, engineers, operational expertise,
etc.  I tend to think vendors and standards bodies often don't get this
point. 

We also can never develop a one-size-fits all set of specs or
architecture for IPv6 operations, but only add to the tools the users
can use to build IPv6 networks.

Understanding what I say above (not that all agree) is important to
realize about our assumptions as a team working together and how/why one
of us may view our work and efforts differently.

I personally believe from reading mail on this list and hearing views
that a part of our team here do not get that the users are far more
educated, have deployed far more IPv6 than we realize in their labs, and
have far more experience with IPv6 operationally, architecturally, and
theoretically than we realize.

Also realize vendor have been pitching IPv6 to customers for 3 years
now, the users may actually know more about what products exist, next
product plans by vendors than this list too.

Regards,
/jim

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Tuesday, March 11, 2003 7:43 AM
> To: Margaret Wasserman
> Cc: Bound, Jim; [email-masked]
> Subject: RE: Note on Scenarios for IPv6
> 
> 
> Hi,
> 
> On Tue, 11 Mar 2003, Margaret Wasserman wrote:
> > >What I was referencing (not picking on Pekka) was Pekka's 
> mail to our 
> > >Ent draft and short discussion Pekka had with Bob Fink regarding 
> > >defining the IPv4 Enterprise in scenarios not IPv6.
> > 
> > I'll go back and check, but I think that the only scope
> > issue we've been discussing with a v6ops scenario draft
> > is the ISP draft, not the Enterprise draft.
> 
> My concern here was where do you draw the line.
>  
> > The ISP draft includes some execellent work that describes current 
> > IPv4 installations, but it doesn't (yet) explain how/when/where/if 
> > IPv6 will be introduced, so it doesn't set up scenarios that can be 
> > used to analyze the applicability of coexistence mechanisms.
> 
> My first though on scenarios documents were: "OK.  First we 
> must understand the problem (IPv4 networks, typically) to be 
> able to work on IPv6".  This has been done rather well in the ISP doc.
> 
> It doesn't discuss IPv6 all that much, but I'm a bit unsure 
> what kind of scenarios it could actually use without going 
> into _solutions_ (one could argue that even basic principles 
> like dual-stack or tunneling are solutions but I guess the 
> consensus is that such are OK to discuss them under 
> scenarios) -- this makes some assumptions about how v6 is enabled.
> 
> One could argue that describing "how/when/where/if IPv6 is 
> introducted" is part of the solutions space.
>  
> > I believe that the ISP team is aware of the need to expand 
> the scope 
> > of their draft, and that they are working on it.
> > 
> > So, unless I've missed something important (if I have, 
> Pekka, please 
> > tell me), there is no disagreement about the scope of the 
> Enterprise 
> > draft.
> 
> Enterprise has a more integrated approach to how basic IPv6 
> transition mechanisms are taken into consideration in the 
> text than ISP, yes -- but the general questions still arise:
> 
> What should the _scenario_ documents include? (And what not.) 
> What should the _solutions_ documents include? (And what not.)
> 
> This seems to be a critical thing to have a common 
> understanding on.  To me, at least, this seems a quite 
> uncertain.  If we don't know what we should be doing, it's no 
> wonder we haven't been able to make as much progress as we 
> might have hoped :-).
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Tue, 11 Mar 2003 09:49:52 -0500

Thanks then we can add that to our Ent docs without saying names. 
For example then Government would cover Commerce, Military, Energy, but
would differentiate research as different.  These folks are moving NOW
with IPv6 and ahead of this group with scenarios fyi in most
geographies.
/jim

> From: Brian E Carpenter [mailto:[email-masked]] 
> Sent: Tuesday, March 11, 2003 9:19 AM
> To: Bound, Jim
> Cc: Margaret Wasserman; [email-masked]
> Subject: Re: Note on Scenarios for IPv6
> 
> 
> Sure. "A bank". "A large IT company"....
> 
>    Brian
> 
> "Bound, Jim" wrote:
> > 
> > Brian,
> > 
> > Assume the customers can remain anonymous?
> > 
> > Thanks
> > /jim
> > 
> > 
> > 
> > > From: Brian E Carpenter [mailto:[email-masked]]
> > > Sent: Tuesday, March 11, 2003 5:34 AM
> > > To: Bound, Jim
> > > Cc: Margaret Wasserman; [email-masked]
> > > Subject: Re: Note on Scenarios for IPv6
> > >
> > >
> > > I made the comment a few weeks ago that the enterprise document 
> > > should include some customer-scenario use cases, to validate the 
> > > technical scenarios as being relevant - and Jim 
> acknowledged this as 
> > > a useful thing to add. But I don't think that means there 
> is a basic 
> > > scope problem with the document.
> > >
> > >    Brian
> > >
> > > "Bound, Jim" wrote:
> > > >
> > > > Hi Margaret,
> > > >
> > > > I won't inline comment (not because I am lazy) because I am in 
> > > > tune with your mail and agree.  I am fully on board with the
> > > v6ops charter
> > > > to see if it works.  I stated my input on that but can move
> > > on if that
> > > > is what the team wants to do, except for very rare cases (e.g. 
> > > > Stateful being a SHOULD in node reqs and will fight the to the 
> > > > IESG most likely).
> > > >
> > > Granted it was a
> > > > short mail exchange, and I could be reading to much into
> > > it.  But, I
> > > > have seen this type of mail in our culture cause raging debate 
> > > > over the assumptions and goals, and we end up back at the
> > > starting gate. So
> > > > given many years here I am a bit nervous on the amount of
> > > energy I put
> > > > into it.
> > > >
> > > > But I thought we were ok till today too.  Just 
> checking.  I also 
> > > > believe doing the scearios will make steps move very
> > > quickly for TTM
> > > > for our specs and output from this WG.  At least in theory.
> > > >
> > > > Thanks
> > > > /jim
> > > >
> > > >
> > > >
> > > > >From: Margaret Wasserman [mailto:[email-masked]]
> > > > >Sent: Monday, March 10, 2003 8:48 PM
> > > > >To: Bound, Jim
> > > > >Cc: [email-masked]
> > > > >Subject: Re: Note on Scenarios for IPv6
> > > > >
> > > > >
> > > > >
> > > > >Hi Jim,
> > > > >
> > > > >>Picking on our Ent work as example.  We have had 
> pretty much the 
> > > > >>same intro and scope we believed was important since the v6ops
> > > > >interim meeting
> > > document?  I
> > > > >have just read it, again, and I do not believe that there
> > > is anything
> > > > >wrong with the scope of this document.
> > > > >
> > > need to be
> > > > >completed, and there is some further editing needed, but I 
> > > > >believe that the scope and structure are fine.
> > > > >
> > > > >The important thing is that we write a set of 
> documents that help 
> > > > >us to understand how enterprise networks will
> > > move to IPv6,
> > > > >where/when/how/if they will need to run both IPv4 and
> > > IPv6, and what
> > > > >coexistence mechanisms will be needed to make this work.
> > > > >
> > > because we
> > > > >wanted to understand the problem space before we started
> > > working on
> > > > >the applicability of each coexistence mechanism to the
> > > problem space.
> > > > >I think that this document does a good job of defining the 
> > > > >problem space for our later analysis work.
> > > > >
> > > > >Margaret
> > >
>