Subject: RE: Note on Scenarios for IPv6

From: "Bound, Jim" <[email-masked]>
Date: Mon, 10 Mar 2003 21:08:07 -0500

Hi Margaret,

I won't inline comment (not because I am lazy) because I am in tune with
your mail and agree.  I am fully on board with the v6ops charter to see
if it works.  I stated my input on that but can move on if that is what
the team wants to do, except for very rare cases (e.g. Stateful being a
SHOULD in node reqs and will fight the to the IESG most likely).

What I was referencing (not picking on Pekka) was Pekka's mail to our
Ent draft and short discussion Pekka had with Bob Fink regarding
defining the IPv4 Enterprise in scenarios not IPv6.  Granted it was a
short mail exchange, and I could be reading to much into it.  But, I
have seen this type of mail in our culture cause raging debate over the
assumptions and goals, and we end up back at the starting gate. So given
many years here I am a bit nervous on the amount of energy I put into
it. 

But I thought we were ok till today too.  Just checking.  I also believe
doing the scearios will make steps move very quickly for TTM for our
specs and output from this WG.  At least in theory.

Thanks
/jim

>-----Original Message-----
>From: Margaret Wasserman [mailto:[email-masked]] 
>Sent: Monday, March 10, 2003 8:48 PM
>To: Bound, Jim
>Cc: [email-masked]
>Subject: Re: Note on Scenarios for IPv6
>
>
>
>Hi Jim,
>
>>Picking on our Ent work as example.  We have had pretty much the same
>>intro and scope we believed was important since the v6ops 
>interim meeting 
>>and in Yokohamma.  Today we now learn there is a scope issue. 
> Yokohamma 
>>was 9 months or so ago.  We need to fix this folks.  It is 
>not all the 
>>teams fault or the working group.  Its some kind of process 
>we are stuck 
>>in.  We need to break it.
>
>Why do you believe that there is a scope issue for this 
>document?  I have just read it, again, and I do not believe 
>that there is anything wrong with the scope of this document.
>
>Obviously, there are still many incomplete sections that
>need to be completed, and there is some further editing
>needed, but I believe that the scope and structure are
>fine.
>
>The important thing is that we write a set of documents
>that help us to understand how enterprise networks will move
>to IPv6, where/when/how/if they will need to run both IPv4
>and IPv6, and what coexistence mechanisms will be needed
>to make this work.
>
>We broke the task into two pieces, scenarios and analysis, 
>because we wanted to understand the problem space before we 
>started working on the applicability of each coexistence 
>mechanism to the problem space.  I think that this document 
>does a good job of defining the problem space for our later 
>analysis work.
>
>Margaret
>
>
>
>
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 11 Mar 2003 11:33:40 +0100

I made the comment a few weeks ago that the enterprise document should
include some customer-scenario use cases, to validate the technical
scenarios as being relevant - and Jim acknowledged this as a useful
thing to add. But I don't think that means there is a basic scope problem
with the document.

   Brian

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 11 Mar 2003 07:15:40 -0500

Hi Jim,

>defining the IPv4 Enterprise in scenarios not IPv6.

I'll go back and check, but I think that the only scope
issue we've been discussing with a v6ops scenario draft
is the ISP draft, not the Enterprise draft.

The ISP draft includes some execellent work that describes
current IPv4 installations, but it doesn't (yet) explain
how/when/where/if IPv6 will be introduced, so it doesn't
set up scenarios that can be used to analyze the applicability
of coexistence mechanisms.

I believe that the ISP team is aware of the need to expand
the scope of their draft, and that they are working on it.

So, unless I've missed something important (if I have, Pekka,
please tell me), there is no disagreement about the scope
of the Enterprise draft.

Margaret

---

From: Pekka Savola <[email-masked]>
Date: Tue, 11 Mar 2003 14:43:08 +0200 (EET)

Hi,

> is the ISP draft, not the Enterprise draft.

My concern here was where do you draw the line.
 
> of coexistence mechanisms.

My first though on scenarios documents were: "OK.  First we must
understand the problem (IPv4 networks, typically) to be able to work on
IPv6".  This has been done rather well in the ISP doc.

It doesn't discuss IPv6 all that much, but I'm a bit unsure what kind of
scenarios it could actually use without going into _solutions_ (one could
argue that even basic principles like dual-stack or tunneling are
solutions but I guess the consensus is that such are OK to discuss them
under scenarios) -- this makes some assumptions about how v6 is enabled.

One could argue that describing "how/when/where/if IPv6 is introducted" is
part of the solutions space.
 
> please tell me), there is no disagreement about the scope

Enterprise has a more integrated approach to how basic IPv6 transition
mechanisms are taken into consideration in the text than ISP, yes -- but
the general questions still arise:

What should the _scenario_ documents include? (And what not.)
What should the _solutions_ documents include? (And what not.)

This seems to be a critical thing to have a common understanding on.  To
me, at least, this seems a quite uncertain.  If we don't know what we
should be doing, it's no wonder we haven't been able to make as much
progress as we might have hoped :-).

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Tim Chown <[email-masked]>
Date: Tue, 11 Mar 2003 12:51:38 +0000

On Tue, Mar 11, 2003 at 07:15:40AM -0500, Margaret Wasserman wrote:
> <snip>

So this is the key observation?  If we cannot analyse the applicability
of transition/coexistence mechanisms from the scenarios document, then the
document is not sufficient.   

Completeness of the scenario space is another issue (i.e. we can create
scenarios that we can guess may lead to a certain solution, and probably
scenarios that would lead to use of many currently unadopted solutions).

Tim

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 11 Mar 2003 08:59:47 -0500

>This seems to be a critical thing to have a common understanding on.

Actually, I'm not so sure that this is critical...

The division of this work in to two documents is somewhat
artificial.  The idea is to have a first document, scenarios,
that describes the possible scenarios for introducing IPv6 into
a particular environment, and a second document, analysis, that
analyzes which coexistance mechanisms (existing or to be
developed) are needed for each scenario.

The enterprise, 3GPP and unmanaged docs all do include
discussion of where IPv6 will be introduced/available in
the scenarios document, and they break down the scenarios
that way, so it would be best if the ISP document is consistent
with them.

However, the _critical_ goal is to get to an end-state where
we understand which coexistence mechanisms are needed and
how/when they should be used.

Margaret