Subject: RE: Unreachability detection at tunnels servers WAS: RE: Comments onzeroconf draft

From: "Karen E. Nielsen (AH/TED)" <[email-masked]>
Date: Wed, 15 Sep 2004 10:07:20 +0200

Hi Radhakrisnan,

[snip]
> 
> If IPv6 NUD is also supported then we can either translate 
> the ICMPv4 error
> messages (faster) or cache out the NUD entry if address 
> resolution fails.

Note that I am talking about RFC 2461 "NUD-like" mechanism, as 
RFC 2461 NUD is based on the fact that address resolution gives proof
of reachability. This may not be the case on the tunnel links, e.g. in
Teredo, 6to4 and Isatap, where address resolution in itself may 
not provide proof of reachability.

> The tunnel server must support "packet too big" translation 
> anyway for IPv6
> PMTU. so as well have a couple of other error messages 
> translated as well
> which can be helpful.
> 
> IMHO, ICMPv4 error message translation & IPv6 NUD both should 
> be supported.
> 

OK, that's clear talk. Thanks.

I am still looking for the general sentiment in the WG
on this, though.

Any opinions ?

BR, Karen 

> Regards
> Radhakrishnan

---

From: Radhakrishnan Suryanarayanan <[email-masked]>
Date: Wed, 15 Sep 2004 18:17:08 +0530

I think pekka and other members of WG must provide their opinion to your
question.

----- Original Message ----- 
From: "Karen E. Nielsen (AH/TED)" <[email-masked]>
To: "'Radhakrishnan Suryanarayanan'" <[email-masked]>; "'Brian E
Carpenter'" <[email-masked]>
Cc: "'Pekka Savola'" <[email-masked]>; "V6OPS WG" <[email-masked]>;
<[email-masked]>; "'Jeroen Massar'" <[email-masked]>
Sent: Wednesday, September 15, 2004 1:37 PM
Subject: RE: Unreachability detection at tunnels servers WAS: RE: Comments
onzeroconf draft