Subject: RE: Comments on zeroconf draft

From: "Karen E. Nielsen (AH/TED)" <[email-masked]>
Date: Thu, 9 Sep 2004 11:13:53 +0200

> 
> > The authors of assisted-tunnelling have only thought about stateful
> > mechs, I think.
> Have the authors of zeroconf requirements have any stateless 
> mech in mind?
> I feel that  every tunnel server WILL have to maintain a min. 
> set of client
> parameters implicitly making it stateful.
> 

I know of at least one stateless protocol which comply with the
zeroconf goals.

I do not see any requirements for the mechanism to be stateful. A tunnel
server may want to implement some kind of NUD-like mech to prevent black holes,
but that's different.
Which are the parameters that you consider to be a must (for zeroconf that is) ?

BR, Karen

---

From: Radhakrishnan Suryanarayanan <[email-masked]>
Date: Thu, 09 Sep 2004 15:05:18 +0530

Hi karen,
  I have some doubts. Can you clarify this point?
The quote from the zerconf draft :
"
   Tunnel state here is considered to be any parameter kept by the

   server per client and without which the server is unable to serve the

   client (receive packets from/send packets to).

"
Isnt the client's/end-node's v6address reachability using the v6-in-v4
tunnel itself a parameter maintained at the tunnel server? If so, then
doesnt that itself means a tunnel state?