Subject: RE: REVIEW NEEDED: zeroconf requirements document

From: <[email-masked]>
Date: Fri, 3 Sep 2004 11:53:24 +0300

Sending this also on the v6ops list, the mail below was sent only to Radhakrishnan...

	-jw-

-----Original Message-----
From: Wiljakka Juha (Nokia-M/Tampere) 
Sent: 03 September, 2004 11:52
To: 'Radhakrishnan Suryanarayanan'
Subject: RE: REVIEW NEEDED: zeroconf requirements document

Hi, Radhakrishnan!

It is because 3GPP Analysis
www.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-analysis-10.txt
 (see sections 3.1 and 6)

has found a need for a simple tunneling mechanism. Commission has been given by the ADs to write down a minimal set of requirements required for 3GPP environment automatic tunneling. This was discussed in IETF#60 v6ops meeting.

However, this document *may* be applicable for other environments too.

BR,
	-Juha W.-

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of ext Radhakrishnan Suryanarayanan
Sent: 03 September, 2004 11:33
To: JORDI PALET MARTINEZ
Cc: [email-masked]
Subject: Re: REVIEW NEEDED: zeroconf requirements document

Hi Jordi,
    Why is there a special emphasis on 3GPP in this document?

Regards
Radhakrishnan

----- Original Message ----- 
From: "JORDI PALET MARTINEZ" <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 03, 2004 3:45 AM
Subject: Re: REVIEW NEEDED: zeroconf requirements document

Hi Yushun,

Sorry, yes you're right it will make no difference, something very weird
happened. Now is solved.

http://www.v6ops.euro6ix.net/ietf/draft-nielsen-v6ops-zeroconf-goals-01.txt
(at least is working for me, both IPv4 and IPv6).

But also it has already been published "officially":

http://www.ietf.org/internet-drafts/draft-nielsen-v6ops-zeroconf-goals-01.txt

Regards,
Jordi

----- Original Message ----- 
From: "Yu-Shun Wang" <[email-masked]>
To: "Karen E. Nielsen (AH/TED)" <[email-masked]>
Cc: <[email-masked]>; "JORDI PALET MARTINEZ"
<[email-masked]>
Sent: Friday, September 03, 2004 7:49 AM
Subject: Re: REVIEW NEEDED: zeroconf requirements document

> Karen E. Nielsen (AH/TED) wrote:
> > All,
> >
> > Please use the non-direct link
> > http://www.v6ops.euro6ix.net/zerotunnel.php#
> > to retrieve the document (draft-nielsen-v6ops-zeroconf-goals-01.txt).
>
> Hi, Karen,
>
> That's how I got it. The -00 is fine, but could you check
> the -01 file again?
>
> Thanks,
>
> yushun
>
> > I apologize for the inconvenience.
> >
> > Karen
> >
> >
> >>-----Original Message-----
> >>From: [email-masked] [mailto:[email-masked]]On
> >>Behalf Of Yu-Shun Wang
> >>Sent: Thursday, September 02, 2004 8:49 PM
> >>To: JORDI PALET MARTINEZ
> >>Cc: [email-masked]
> >>Subject: Re: REVIEW NEEDED: zeroconf requirements document
> >>
> >>
> >>JORDI PALET MARTINEZ wrote:
> >>
> >>>Hi all,
> >>>
> >>>There is also a direct link as
> >>
> >>http://www.v6ops.euro6ix.net/ietf/draft-nielsen-v6ops-zeroconf
> >>-goals-01.txt.
> >>
> >>Hi,
> >>
> >>Is it just me or are there non-ASCII characters in the doc file?
> >>
> >>Thanks,
> >>
> >>yushun
> >>
> >>
> >>>Regards,
> >>>Jordi
> >>>
> >>>----- Original Message ----- 
> >>>From: "Karen E. Nielsen (AH/TED)" <[email-masked]>
> >>>To: "'Pekka Savola'" <[email-masked]>; <[email-masked]>
> >>>Sent: Friday, September 03, 2004 12:56 AM
> >>>Subject: RE: REVIEW NEEDED: zeroconf requirements document
> >>>
> >>>
> >>>
> >>>
> >>>>Dear All,
> >>>>
> >>>>The promised revised version,
> >>>>draft-nielsen-v6ops-zeroconf-goals-01.txt,
> >>>>can be found on the following link:
> >>>>
> >>>>http://www.v6ops.euro6ix.net/zerotunnel.php#
> >>>>
> >>>>On behalf of the authors I would like to echo Pekka's
> >>>>request for a review of this work.
> >>>>
> >>>>Feedback are requested on the general scope
> >>>>of the documents as well as on the particular set of
> >>>>individual goals put forward.
> >>>>
> >>>>Please scrutinize.
> >>>>
> >>>>BR, Karen
> >>>>
> >>>>The drafts has been submitted to the IDs,
> >>>>but it will probably take a while for it to appear.
> >>>>
> >>>>
> >>>>
> >>>>>-----Original Message-----
> >>>>>From: [email-masked] [mailto:[email-masked]]On
> >>>>>Behalf Of Pekka Savola
> >>>>>Sent: Wednesday, September 01, 2004 12:29 PM
> >>>>>To: [email-masked]
> >>>>>Subject: Re: REVIEW NEEDED: zeroconf requirements document
> >>>>>
> >>>>>
> >>>>>(co-chair hat on)
> >>>>>
> >>>>>The document editor just said that a revised version,
> >>
> >>addressing the
> >>
> >>>>>input received so far, could be available for tomorrow.
> >>>>>
> >>>>>So, please hold off the review until the new revision has been made
> >>>>>available (-01 version).  Let's shift the review DL by one
> >>
> >>day, to 7th
> >>
> >>>>>September.
> >>>>>
> >>>>>Thanks to the surprisingly active document editor and authors! :-)
> >>>>>
> >>>>>(hat off)
> >>>>>
> >>>>>On Wed, 1 Sep 2004, Pekka Savola wrote:
> >>>>>
> >>>>>
> >>>>>>(co-chair hat on)
> >>>>>>
> >>>>>>If you recall from the IETF60 meeting, we set out a couple of
> >>>>>>milestonoes and deadlines to make progress well before the next
> >>>>>>meeting -- and now the planning and scheduling for IETF61
> >>>>>
> >>>>>has already
> >>>>>
> >>>>>
> >>>>>>started...
> >>>>>>
> >>>>>>We need to get more input especially on:
> >>>>>>
> >>>>>>
> >>>>
> >>>>http://www.ietf.org/internet-drafts/draft-nielsen-v6ops-zero
> >
> > conf-goals-00.txt
> >
> >>>>Please read it and send feedback on the list.  Please do this as soon
> >>>>as possible but on 6th September at the latest.
> >>>>
> >>>>In particular, opinions on whether the document should include the
> >>>>applicability in the ISP networks (e.g., when the access network
> >>>>cannot be upgraded [which seems to have similar requirements as 3GPP])
> >>>>would be highly appreciated.
> >>>>
> >>>>Thanks!
> >>>>
> >>>>(hat off)
> >>>>
> >>>>
> >>>
> >>>-- 
> >>>Pekka Savola                 "You each name yourselves king, yet the
> >>>Netcore Oy                    kingdom bleeds."
> >>>Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> >>>
> >
> >
> >>**********************************
> >>Madrid 2003 Global IPv6 Summit
> >>Presentations and videos on line at:
> >>http://www.ipv6-es.com
> >>
> >>This electronic message contains information which may be privileged or
confidential. The information is intended to be for the use of the
individual(s) named above. If you are not the intended recipient be aware
that any disclosure, copying, distribution or use of the contents of this
information, including attached files, is prohibited.
> >>
> >>
> >>
> >
> >
> >
>
>
> -- 
> Yu-Shun Wang <[email-masked]>
> USC Information Sciences Institute
>

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or
confidential. The information is intended to be for the use of the
individual(s) named above. If you are not the intended recipient be aware
that any disclosure, copying, distribution or use of the contents of this
information, including attached files, is prohibited.

---

From: Radhakrishnan Suryanarayanan <[email-masked]>
Date: Fri, 03 Sep 2004 14:42:22 +0530

Hi Juha,
   If that is the case, then  shouldnt the document name & introduction mention that
this document is intended to satisfy the provide zeroconf tunneling goals for transition in 3GPP?

 IMHO, i guess the need of zeroconf tunnelling is also there in other scenarios and not only in 3GPP.
If the document is made in such a way that it addresses zeroconf tunneling goals that can be used in more scenarios it will serve better.

Any opinions?

Regards
Radhakrishnan

IPng Team
Samsung India Software Operations
Bangalore
India.
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 03, 2004 2:21 PM
Subject: RE: REVIEW NEEDED: zeroconf requirements document

Hi, Radhakrishnan!

BR,
-Juha W.-

-----Original Message-----

Hi Jordi,

Regards
Radhakrishnan

----- Original Message ----- 
From: "JORDI PALET MARTINEZ" <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 03, 2004 3:45 AM
Subject: Re: REVIEW NEEDED: zeroconf requirements document

Hi Yushun,

Regards,
Jordi

---

From: <[email-masked]>
Date: Fri, 3 Sep 2004 12:34:57 +0300

Hi!

Pls see our presentation in San Diego:
http://www.6bone.net/v6ops/minutes/IETF-60-SanDiego/12_zeroconfig-reqs.pdf

"Starting Point of actual work
* Minimal set of goals required for the 3GPP environment
automatic tunneling scenario
....may widen to other environment scenarios (not
explicit assumption nor prerequisite)
* More advanced and feature rich tunneling is envisaged
provided in form of assisted-tunneling, <draft-ietf-v6ops-assisted-
tunneling-requirements-00.txt>"

Timing is critical in this work, so we have written our first two drafts in a short time - mainly focusing on the (important) 3GPP environment.

One point is that can the work done in assisted tunneling satisfy tunneling needs in other environments?
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-assisted-tunneling-requirements-00.txt 

If yes, then zeroconf document could more tightly be scoped to 3GPP...

Of course, zeroconf document team is open for comments from the people in the v6ops wg.

Cheers,
	 -Juha-

-----Original Message-----
From: ext Radhakrishnan Suryanarayanan [mailto:[email-masked]]
Sent: 03 September, 2004 12:12
To: Wiljakka Juha (Nokia-M/Tampere)
Cc: Pekka Savola; V6OPS WG
Subject: Re: REVIEW NEEDED: zeroconf requirements document

Hi Juha,

Any opinions?

Regards
Radhakrishnan

IPng Team
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 03, 2004 2:21 PM
Subject: RE: REVIEW NEEDED: zeroconf requirements document

Hi, Radhakrishnan!

BR,
-Juha W.-

-----Original Message-----

Hi Jordi,

Regards
Radhakrishnan

----- Original Message ----- 
From: "JORDI PALET MARTINEZ" <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 03, 2004 3:45 AM
Subject: Re: REVIEW NEEDED: zeroconf requirements document

Hi Yushun,

Regards,
Jordi