Subject: RE: ISATAP interface ... if PRL is empty disable interface?

From: "Tim Gleeson \(tgleeson\)" <[email-masked]>
Date: Wed, 28 Sep 2005 12:06:11 +0800

John,

The SHOULD NOT is there to discourage use of ISATAP on the Internet when
the PRL is empty. However, since it is a SHOULD NOT, within a site one
can configure ISATAP to be used anyway.

Tim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of John Spence
> Sent: Monday, September 26, 2005 11:17 PM
> To: [email-masked]
> Subject: ISATAP interface ... if PRL is empty disable interface?
> 
> 
> v24 of the ISATAP spec, 8.3.2, says that:
> 
> "After initializing an ISATAP interface's PRL, if the PRL is 
> empty the node SHOULD disable the interface."
> 
> Just because there is no default router, ISATAP client nodes 
> can exchange traffic using their link-local addresses on the 
> virtual ISATAP link.  That would be consistent with native 
> nodes - just because they have no router, and no way off the 
> link, they still configure link-local addresses and stand 
> ready to talk to other nodes that are on-link - they do not 
> disable the interface.
> 
> Is there something else in the Spec I missed that allows 
> nodes to communicate using link-local addresses in the 
> absence of an ISATAP router?
> 
> John Spence
> ----------------------------------------------------
> John Spence, CCSI, CCNA, CISSP
> Native6, Inc.
> IPv6 Training and Consulting
> [email-masked]
> (wk) 206-682-0275
> www.native6.com
> ----------------------------------------------------
>

---

From: "John Spence" <[email-masked]>
Date: Wed, 28 Sep 2005 07:54:06 -0700

Fair enough.  Thanks for the response Tim.

Spence 

> From: Tim Gleeson (tgleeson) [mailto:[email-masked]] 
> Sent: Tuesday, September 27, 2005 9:06 PM
> To: John Spence; [email-masked]
> Subject: RE: ISATAP interface ... if PRL is empty disable
interface?
> 
> John,
> 
> The SHOULD NOT is there to discourage use of ISATAP on the 
> Internet when the PRL is empty. However, since it is a SHOULD 
> NOT, within a site one can configure ISATAP to be used anyway.
> 
> Tim
> 
> > "After initializing an ISATAP interface's PRL, if the PRL 
> is empty the 
> > node SHOULD disable the interface."
> > 
can 
> > exchange traffic using their link-local addresses on the
virtual 
> > ISATAP link.  That would be consistent with native nodes -
just 
> > because they have no router, and no way off the link, they
still 
> > configure link-local addresses and stand ready to talk to 
> other nodes 
> > that are on-link - they do not disable the interface.
> > 
nodes to 
> > communicate using link-local addresses in the absence of an
ISATAP 
> > router?