Subject: Teredo assignements by IANA

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 30 Jan 2006 02:57:56 +0100

Hi,

It seems that we missed this before ;-)

IANA assigned for Teredo, on January 10th 2006:

2001:0000::/32

Also an IPv4 multicast address:
224.0.0.253 Teredo

Regards,
Jordi

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Slides available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Jeroen Massar <[email-masked]>
Date: Mon, 30 Jan 2006 03:40:56 +0100

JORDI PALET MARTINEZ wrote:
[..]
> IANA assigned for Teredo, on January 10th 2006:

Good catch as there indeed was no announcement of this afaik.
What I am wondering though is what we can conclude from
point 1 at http://www.iana.org/assignments/ipv6-unicast-address-assignments
8<------------
2001:0000::/23        IANA           01 Jul 99   [1] [7]
...
[1]  The prefix assigned to the IANA, 2001:0000::/23, is for
     assignment for testing, experimental and trial usage by IANA
     [RFC2928].
...
[7]  2001:0000::/32 has been allocated for Teredo on 10 Jan 2006, see
     RFC-huitema-v6ops-teredo-05.txt.
------------>8
Does this mean that Teredo is 'testing, experimental, trial' or is it
here to stay, just like 6to4? I hope it is the latter, even though it is
meant for transition only. An unused prefix can always be reclaimed
later in these cases.

Now hope that operators of Teredo also start using 2001::/32 instead
before 6/6/6 of course.

Only 4 months left till the end of the 6bone...

Greets,
 Jeroen

---

From: "Christian Huitema" <[email-masked]>
Date: Sun, 29 Jan 2006 20:26:54 -0800

> Good catch as there indeed was no announcement of this afaik.

I was waiting until the actual publication of the RFC, which should come
pretty soon now.

-- Christian Huitema

---

From: "Miguel Angel Diaz" <[email-masked]>
Date: Mon, 30 Jan 2006 08:48:01 +0100

> Jeroen Massar wrote:

[................................]

> Now hope that operators of Teredo also start using 2001::/32 instead

The point here is that both Teredo Servers/Relays and mainly Teredo Clients need to be updated to 
support such a new prefix. I guess the new Windows Vista will do but what about the current Windows XP 
users? A new service pack will be needed to update the Teredo Client but not sure all the users upgrade 
their O.S.

Regards
Miguel