Subject: RE: Flow label and its uses

From: "Bora Akyol" <[email-masked]>
Date: Tue, 17 Jan 2006 15:50:01 -0800

A pointer to some reference material on NIMROD:

http://ana-3.lcs.mit.edu/~jnc/nimrod/nimsl.html
 
http://ana-3.lcs.mit.edu/~jnc/nimrod/docs.html

http://www.ir.bbn.com/projects/nimrod

Is there any use in keeping flow label as is,
or should be relabeled as "Reserved"?

I think there is some agreement that
the label in 
(Label, IP Source Address, IP Destination Address)
triplet does not add a whole lot of value.

Regards,

Bora

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]] 
> Sent: Tuesday, January 17, 2006 3:33 PM
> To: Bora Akyol
> Cc: Vishwas Manral; [email-masked]
> Subject: Re: Flow label and its uses
> 
> I'd encourage you to look at the big-internet archives (if they
> exist) from about 1993. The flow label was proposed to 
> support the nimrod architecture, and in essence *was* what we 
> later described as "MPLS", but in the IPv6 header. That's one 
> of the reasons that the flow label isn't covered by the IPSEC 
> checksum - so it could be managed appropriately at ingress 
> and egress to the various "flows" or "LSPs".
> 
> Yes, there has been a lot of water under that bridge. Between 
> requiring the flow label to pass unchanged and making the 
> address fixed length and of the same construction as the IPv4 
> address, Nimrod became very difficult to implement in IPv6, 
> and Noel still isn't very happy with the IPv6 community.
> 
> On Jan 17, 2006, at 3:11 PM, Bora Akyol wrote:
> 
> >
> >
> >> -----Original Message-----
> >> From: Vishwas Manral [mailto:[email-masked]]
> >
> >> And a more recent draft
> >> http://www.faqs.org/ftp/pub/internet-drafts/draft-chakravorty-
> >> bcc-flowla
> >> bel-00.txt
> >
> > This last one looks a lot like MPLS in IPv6 ;-)
> >
> > Bora
> 
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 17 Jan 2006 16:46:45 -0800

personally, I would label it reserved. I think the authors of RFC  
3697 see it as something akin to a 20 bit DSCP, and if someone wants  
to see it that way it's fine by me. In any event, that is an ipv6wg  
question more than a v6ops question.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Jan 2006 14:02:30 +0100

Fred Baker wrote:
> personally, I would label it reserved. I think the authors of RFC  3697 
> see it as something akin to a 20 bit DSCP, and if someone wants  to see 
> it that way it's fine by me. In any event, that is an ipv6wg  question 
> more than a v6ops question.

Indeed. And it isn't "reserved"; it *is* part of the header with the
semantics defined to the extent of RFC 3697. My point is that people
who want to use it, e.g. for load balancing, ought to be writing
drafts.

    Brian