Subject: Comments on draft-krishnan-v6ops-teredo-update-02

From: Dave Thaler <[email-masked]>
Date: Mon, 10 Mar 2008 07:46:00 -0700

Attached is a PDF with my comments in context.
Most are editorial issues.

My technical comments are:

1)      The draft incorrectly changes a "MUST be 0" bit in RFC4380 (the 2nd bit from the left) to a "SHOULD be 0" bit for no good reason.

2)      The draft replaces the "cone bit" with a "z" (zero) bit without explaining the effect on the text in RFC 4380 that talks about using the cone bit.  I believe this is the wrong way to deprecate the cone bit.  Instead, it should leave it defined as the cone bit, but still say it SHOULD be set to 0.  The behavior on how its used is then unchanged, because it's still called the cone bit and interoperability with something that sets it to 1 is still clear.

I am happy to work with the authors on fixing the above, as well as the various editorial issues with the document.

However, I'll also point out that all of Microsoft's Teredo extensions (which includes all of the behavior specified in this I-D, plus other behaviors) to Teredo are published at
http://msdn2.microsoft.com/en-us/library/cc247482.aspx

I'd be interested in opinions on whether the other behaviors should also be published in the same or a separate I-D (or not in the IETF at all).
Currently the filename "draft-krishnan-v6ops-teredo-update-02" implies it's all updates to Teredo whereas the title says it's only Security updates.
Personally I'd be inclined to say the other behaviors should be included as well (and indeed it might be easiest for us to just recast portions of the MS-TERE spec into I-D form, if that is what people want).

-Dave

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Wed, 12 Mar 2008 20:41:30 +0200

Le Monday 10 March 2008 16:46:00 Dave Thaler, vous avez écrit :
> However, I'll also point out that all of Microsoft's Teredo extensions
> (which includes all of the behavior specified in this I-D, plus other
> behaviors) to Teredo are published at
> I'd be interested in opinions on whether the other behaviors should also be
> published in the same or a separate I-D (or not in the IETF at all).

I would rather have them published by IETF. But I suspect that would be 
stretching the current document way beyond its current scope. OTOH, I 
understand a full protocol update, while easier to read, would be harder to 
write...

> Currently the filename "draft-krishnan-v6ops-teredo-update-02" implies it's
> all updates to Teredo whereas the title says it's only Security updates.
> Personally I'd be inclined to say the other behaviors should be included as
> well (and indeed it might be easiest for us to just recast portions of the
> MS-TERE spec into I-D form, if that is what people want).

-- 
Rémi Denis-Courmont