Subject: Re: draft-kawamura-ipv6-isp-listings review

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Jul 2010 13:28:27 +1200

On 2010-07-16 03:19, Fred Baker wrote:
> Could I interest you in doing a thorough review of draft-kawamura-ipv6-isp-listings and commenting to v6ops?

Summary
-------

This short draft proposes guidelines for use by listing sites that report on
the level of IPv6 support from various ISPs. There are a number of such
sites, and they don't all report on the same criteria, so the draft proposes
seven common criteria, split into 'basic' and 'advanced'.

I believe this document is useful, but it needs some debate about the exact
criteria proposed, and it needs discussion with the people operating
existing listing sites. If they don't agree, the document is going nowhere.

More detail
-----------

It seems like a good idea for all these listing sites to use common criteria.
Whether they would do so in practice is another question. (How many ISPs
do you know who refer to RFC 4084 in their sales literature?) That's why
the sites need to be involved in the discussion.

The list of criteria needs some debate in the WG. For example, there is
no check whether IPv6-only clients would be satisfied. So as it stands,
an ISP could get a green light according to this draft, but its IPv6-only
users couldn't get SMTP service (for example). On the other hand, for
practical reasons, there should not be too many criteria.

There's no security text. There needs to be something if this is to proceed
as an RFC. We could discuss whether any security-related criteria should
be added; if not, we need to say why not.

The draft is short enough that there's no point in a section-by-section
review. There are a few places where the RFC Editor would need to tidy up
the English.

   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Jul 2010 13:28:27 +1200

Summary
-------

More detail
-----------

   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Jul 2010 13:28:27 +1200

Summary
-------

More detail
-----------

   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Jul 2010 13:28:27 +1200

Summary
-------

More detail
-----------

   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Jul 2010 13:28:27 +1200

Summary
-------

More detail
-----------

   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Jul 2010 13:28:27 +1200

Summary
-------

More detail
-----------

   Brian Carpenter

---

From: Seiichi Kawamura <[email-masked]>
Date: Wed, 21 Jul 2010 11:40:03 +0900

Hi Brian

Thanks for the review.
Appologies for the very roughly written draft.
My comments inline

> existing listing sites. If they don't agree, the document is going nowhere.

I agree with you.
I am talking with a few people on the IPv6 forum.
I believe some of them will be at Maatricht, hopefully
they will stay until Friday. That's only one of the
list makers, so I should go and contact more.

> More detail

This kind of discussion is exactly what I wanted to have at Maastricht.
To what extent, would and ISP need to cover for their service to be
called a "working IPv6 ISP"? SMTP? DNS caches? Would a single home
tunnel transited ISP be equally considered IPv6?  For example,
some ISPs can choose to provide SMTP via IPv4 only but their MX must be
dual stacked for their users to communicate with the global internet.

> review. There are a few places where the RFC Editor would need to tidy up

I agree with these comments.
Thanks.

Regards,
Seiichi

---

From: Lindqvist Kurt Erik <[email-masked]>
Date: Wed, 21 Jul 2010 08:25:03 +0200

> dual stacked for their users to communicate with the global internet.

Personally I believe the criteria for an ISP to be "v6" is that they have a PA block and that they are giving out customer assignments. I would prefer a requirement of native (i.e dual-stack or v6 only) upstream connection. 

Best regards,

- kurtis -

---

From: Seiichi Kawamura <[email-masked]>
Date: Sat, 24 Jul 2010 16:01:41 +0900

Hi Kurt

> Personally I believe the criteria for an ISP to be "v6" is that they have a PA block and that they are giving out customer assignments. I would prefer a requirement of native (i.e dual-stack or v6…

Although I'm mostly in agreement with you, having a PA and
assigning it to customers is more the definition of an LIR,
and if I am not mistaken, an ISP is not always an LIR.

One of the cases is where the ISP buys a wholesale ISP service
from another ISP and provides it to their customers. The job
of the non-LIR ISP is to provide customer support, mail services,
CPE delivery,etc and the LIR ISP providing the wholsale does most
of the network providing. I know a few "ISPs" in Japan that
provide internet services like this.

In this case, the requirement for cusotomer assingment of the PA block
falls into the responsibility of the LIR ISP.

So the PA assingning requirement doesn't have to be fullfilled by
the ISP that the customer interacts with, as long as the LIR ISP
involved in the service does so.

Regards,
Seiichi