Subject: Re: AW: I-D Action:draft-gundavelli-v6ops-l2-unicast-00.txt

From: Sri Gundavelli <[email-masked]>
Date: Sat, 17 Jul 2010 17:58:40 -0700

Thanks to Stig for his review of the draft. Will reword the below text,
should be in -01 version.

Sri

------ Forwarded Message
From: Stig Venaas <[email-masked]>
Date: Mon, 15 Feb 2010 13:03:29 -0800
To: Sri Gundavelli <[email-masked]>
Subject: Re: L2 Unicast of multicast messages - ID

>> I think the document is fine. I've followed some of the previous
>> discussion on this topic. Just one comment.
>>
>> In section 3 it says:
>>
>>        address in the link-layer header will be an unicast address.  It
>>        is up to to the system architecture as when to transmit a IPv6
>>        multicast message as an link-layer unicast message, as long as
>>        there is no real impact to the multicast communication.
>>
>> This sentence is pretty vague. Especially "no real impact", not sure
>> what that means. And what do you mean by "multicast communication".
>>
>> Also, the reason you may want the system architecture to transmit
>> unicast, is that it has a positive impact on the communication, right?
>> If whether you use unicast or not has no impact, then this would be
>> pointless ;)
>>
> 
> :) My point is that, if the usage of the semantic is used in the right away,
> there should be any impact to the multicast communication. If I'm hosting
> two IPv6 VLAN's on the same 802.11 link, if the AP ensures the RA's are
> segregated and sent to the right groups, its to me no impact to multicast
> communication.  But, I see your point, this needs to worded correctly. I
> will fix this in -01 version, posted it a hour back.

Sorry I was a bit late. I think the draft is good. Just trying to be a
bit difficult here :) But I think it can be made clearer.

Stig

---

From: <[email-masked]>
Date: Thu, 22 Jul 2010 14:35:33 +0200

Hi Sri,

had a read of your I-D right now and think that it is a very interesting and useful work. I see also some applicability in the BBF context for handling of RAs in a N:1 VLAN scenario for instance.
Unfortunately I don't recall the status of the I-D after the last IETF, is it on the road to become a WG item?
I would vote for that.
Kind regards
Olaf 

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] 
> [mailto:[email-masked]] Im Auftrag von Sri Gundavelli
> Gesendet: Sonntag, 18. Juli 2010 02:59
> An: IPv6 Operations
> Cc: Stig Venaas
> Betreff: Re: AW: I-D Action:draft-gundavelli-v6ops-l2-unicast-00.txt 
>

---

From: Sri Gundavelli <[email-masked]>
Date: Sun, 25 Jul 2010 15:53:50 -0700

Hi Olaf,

Thanks for the review comments and on the use-case. Its not WG doc yet, but
since its just a clarification note, I'm hoping this can be moved faster.

Regards
Sri

On 7/22/10 5:35 AM, "[email-masked]" <[email-masked]>
wrote:

> Hi Sri,
> 
> had a read of your I-D right now and think that it is a very interesting and
> useful work. I see also some applicability in the BBF context for handling of
> RAs in a N:1 VLAN scenario for instance.