Subject: Re: [v6ops] draft-ietf-v6ops-multihoming-without-nat66 WGLC

From: <[email-masked]>
Date: Tue, 1 Mar 2011 22:39:44 +0000

> Sure. But I think it's very important to separate the issues
> that apply to multihoming from the issues that are specific to
> multiple interfaces (and both from the issues that are specific
> to mobility). If we don't solve these problems separately we will
> end up with one big mess.

Just to clarify: need to separate issues specific to having multiple prefixes on a single interface from issues having multiple prefixes on different interfaces? Both of which are oftentimes called multihoming..

Would the terminology sound more sensible if we would talk e.g. about a case where: multi-interfaced smartphone is having simultaneous connection to multihomed corporate WLAN network and to cellular connection with a single /64?

(Mobility issues are clearly separate).

> Yes, but nevertheless, you will end up with multiple AAAA records if
> the remote host itself is multihomed - you can't avoid the address
> pair selection problem.

Not even trying to. I count that 6man's revisited-RFC3484 supported by the address selection policy distribution and v6ops Happy Eyeballs helps in that area.

I.e. with improved MIF DNS selection hosts resolve FQDNs to addresses, then with MIF+RFC4191 tools get some routing info and router preferences onboard (covering multiple interfaces), then with revisited 6man RFC3484+related policy distribution has also improved address selection capabilities, and when all that is covered with some v6ops Happy Eyeballs-cream we should have quite a cake to taste:-)

Teemu

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 02 Mar 2011 11:53:10 +1300

> Just to clarify: need to separate issues specific to having multiple prefixes on a single interface from issues having multiple prefixes on different interfaces? Both of which are oftentimes called…

Oh dear. This gets us back to an old discussion about stacks and virtual
interfaces and why draft-irtf-nsrg-report was never published. Maybe we
can just say: host-based multihoming is when a host has addresses
in more than one separately routed prefix, regardless of interfaces.

> Would the terminology sound more sensible if we would talk e.g. about a case where: multi-interfaced smartphone is having simultaneous connection to multihomed corporate WLAN network and to cellula…

That is certainly a scenario to be expected.

   Brian