Subject: [v6ops] Small comments on draft-ietf-v6ops-v6nd-problems

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Nov 2011 15:01:55 +1300

> 6.2.  Appropriate Subnet Sizing.
> 
>    By sizing subnets to reflect the number of addresses actually in use,
>    the problem can be avoided.  For example, [RFC6164] recommends sizing
>    the subnets for inter-router links to only have 2 addresses (a /127).
>    It is worth noting that this practice is common in IPv4 networks, in
>    part to protect against the harmful effects of ARP request flooding.

There seems to be a point missing here. The majority of subnets, i.e.
all subnets operating SLAAC, are constrained to be /64, so this advice
cannot be followed for them. It can only apply to specialised subnets
where SLAAC is not used.

As a more general comment, maybe an informative reference somewhere
to RFC 5157 would be useful. It talks about the kind of scanning attack
that might be mounted.

   Brian

---

From: rajabu kitindi <[email-masked]>
Date: Wed, 16 Nov 2011 05:06:08 +0300

Just a question, IPv6 was designed for 64-bits network and 64-bits host,
which makes largest prefix length to be /64. Does using /127 prefix length
requires IPv6 format modification in any way?

/Rajabu

On Wed, Nov 16, 2011 at 5:01 AM, Brian E Carpenter <
[email-masked]> wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

-- 
MOTD: When we stop to think, we often miss our opportunity

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Nov 2011 15:51:51 +1300

Rajabu,

See RFC 6164 "Using 127-Bit IPv6 Prefixes on Inter-Router Links".

Regards
   Brian

---

From: rajabu kitindi <[email-masked]>
Date: Wed, 16 Nov 2011 07:57:22 +0300

Thanks

/Rajabu
On 16 Nov 2011 10:51, "Brian E Carpenter" <[email-masked]>

---

From: Joel jaeggli <[email-masked]>
Date: Wed, 16 Nov 2011 13:06:26 +0800

On 11/16/11 10:06 , rajabu kitindi wrote:
> which makes largest prefix length to be /64. Does using /127 prefix
> length requires IPv6 format modification in any way?

No, it does however mean slaac doesn't work... in practical terms hosts
and routers support vlsm just fine.

see

http://tools.ietf.org/html/rfc6164

for detail on /127s...

> /Rajabu
> 
> On Wed, Nov 16, 2011 at 5:01 AM, Brian E Carpenter
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     [email-masked] <mailto:[email-masked]>

---

From: Joel jaeggli <[email-masked]>
Date: Wed, 16 Nov 2011 13:09:04 +0800

> cannot be followed for them. It can only apply to specialised subnets

correct. I can smith the text accordingly to reflect that.

> to RFC 5157 would be useful. It talks about the kind of scanning attack

ok