Subject: [v6ops] the nat64 operational document (draft-chen-v6ops-nat64-cpe)

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Nov 2011 15:07:50 +0800

I didn't get time on the mike to make my second comment.

I liked the presentation. Thank for you doing it.

Clearly, the ipv6.xxx.com stuff needs to be removed.

But people had a question about the role of the document. I think it is the job of the IETF and V6OPS to produce documents that provide operational views about IETF technology (such as 6RD, NAT64, etc). There can be multiple classes of such documents, ranging from documenting someone's operational experience to recommending a particular practice to letting the IETF know that it needs some further enhancements in the protocol suite. I think this document falls in the first class, it may be too early to make recommendations about specific modes of deployment for NAT64 yet. I generally like these types of documents and would like to see V6OPS publish them, or, as was done with some other NAT64 documents, take them to AD sponsored/RFC Editor publications.

I also agree with Lee that the presentation was great, the draft should be updated with all the information from the presentation.

Jari

---

From: Zhen Cao <[email-masked]>
Date: Thu, 17 Nov 2011 15:56:02 +0800

Our pleasure. Thank you.

For the naming part, how about rephrase to something like this:
Although some websites are only providing IPv6 via the sub-domain
names (ipv6.xxx.com), that's NOT RECOMMENDED. *reasons below*...

-Zhen
On Thu, Nov 17, 2011 at 3:07 PM, Jari Arkko <[email-masked]> wrote:
> But people had a question about the role of the document. I think it is the
> job of the IETF and V6OPS to produce documents that provide operational
> views about IETF technology (such as 6RD, NAT64, etc). There can be multiple
> classes of such documents, ranging from documenting someone's operational
> experience to recommending a particular practice to letting the IETF know
> that it needs some further enhancements in the protocol suite. I think this
> document falls in the first class, it may be too early to make
> recommendations about specific modes of deployment for NAT64 yet. I
> generally like these types of documents and would like to see V6OPS publish
> them, or, as was done with some other NAT64 documents, take them to AD
> sponsored/RFC Editor publications.
>
> I also agree with Lee that the presentation was great, the draft should be
> updated with all the information from the presentation.
>
> Jari
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Nov 2011 16:18:56 +0800

I'd remove the whole text. You are entering a topic that would be worthy of another 30-page document, with all the different considerations. Don't summarize it with one sentence, because it will leave the wrong impression. And we have some experience that is very difficult for the IETF to produce an agreeable answer in this space.

Jari

On 17.11.2011 15:56, Zhen Cao wrote:
> On Thu, Nov 17, 2011 at 3:07 PM, Jari Arkko<[email-masked]>  wrote:

---

From: "Lee Howard" <[email-masked]>
Date: Thu, 17 Nov 2011 17:21:11 +0800

> But people had a question about the role of the document. I think it is
the job of the IETF
> and V6OPS to produce documents that provide operational views about IETF
technology
> (such as 6RD, NAT64, etc). There can be multiple classes of such
documents, ranging from
> documenting someone's operational experience to recommending a particular
practice to
> letting the IETF know that it needs some further enhancements in the
protocol suite. I think
> this document falls in the first class, it may be too early to make
recommendations about
> specific modes of deployment for NAT64 yet

I agree, I like documents of this class, and I think you're right about
which kind of
document this is.  I'd like the document to be clearer in that regard, maybe
starting with
a title like "NAT64 Operational Experiences."

>. I generally like these types of documents and
> would like to see V6OPS publish them, or, as was done with some other
NAT64
> documents, take them to AD sponsored/RFC Editor publications.

I agree in general.  Not yet sure I agree in specific.

Lee