Subject: [v6ops] ULA #4 Refering Site-local addresses

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 29 May 2014 08:31:10 +0000

Hi, All

We're going to update the ULA draft. Before making a new version, I think it would be helpful to confirm/discuss several important topics which were discussed in last IETF meeting. 

I'd like to discuss the topics in different mail threads respectively.
(Current draft link: http://tools.ietf.org/html/draft-ietf-v6ops-ula-usage-recommendations-02)
******************************************************************************

# Refering Site-local addresses

Bill and Dave suggested to refer site-local addresses. Because ULAs were intended to replace the gap left when site-local addresses were deprecated. 

Especially, Dave mentioned the site-local address based anycast utilization in former RFCs (e.g. RFC4339 to use site-local anycast as Recursive DNS discovery) and gave a pointer to the relevant stuff. 

I think it is good to add some texts referring site-local address as a background in the introduction Section.
But for the site-local anycast use case, I think of it as out of the scope of this ULA draft. Because as I understood, since the site-local is deprecated, the anycast use cases based on site-local are invalid as well. And it is not a goal to re-produce these anycast use cases in a ULA form in a v6ops document, so I just feel like there is nothing to say about it. 

What are your thoughts?

Regards,
Bing

---

From: Randy Bush <[email-masked]>
Date: Thu, 29 May 2014 21:28:51 +0900

> background in the introduction Section.

definitely.  be very clear the site-local whack-a-mole was declared a
disaster and deprecated and should never be revived or emulated.

randy

---

From: Dave Thaler <[email-masked]>
Date: Thu, 29 May 2014 17:35:47 +0000

> -----Original Message-----
> From: Liubing (Leo) [mailto:[email-masked]]
> Sent: Thursday, May 29, 2014 1:31 AM
> To: v6ops WG
> Cc: [email-masked]; [email-masked]; Dave Thaler
> Subject: ULA #4 Refering Site-local addresses
> 
> Hi, All
> 
> We're going to update the ULA draft. Before making a new version, I think it
> would be helpful to confirm/discuss several important topics which were
> discussed in last IETF meeting.
> 
> Bill and Dave suggested to refer site-local addresses. Because ULAs were
> intended to replace the gap left when site-local addresses were deprecated.
> 
> Especially, Dave mentioned the site-local address based anycast utilization in
> former RFCs (e.g. RFC4339 to use site-local anycast as Recursive DNS
> discovery) and gave a pointer to the relevant stuff.
> 
> But for the site-local anycast use case, I think of it as out of the scope of this
> ULA draft. Because as I understood, since the site-local is deprecated, the
> anycast use cases based on site-local are invalid as well. 

Yes, that is the current bad state.

> And it is not a goal to
> re-produce these anycast use cases in a ULA form in a v6ops document, so I
> just feel like there is nothing to say about it.

Disagree.

> What are your thoughts?

I think v6ops needs to say what the replacement is.  Deprecating something 
useful with no replacement hasn't really helped anything.  The situation is
very similar to when NAT-PT was deprecated.  That didn't stop people from
doing NAT-PT because the IETF provided no alternative.  It wasn't until we
did NAT64/DNS64 in Behave that the problem was really "solved" (to the
extent that it's solved).   Until then, the IETF largely ignored the problem
and as a result some people ignored the IETF.   (Others would likely point
to the NPTv6 example too...)

The anycast problem isn't as widespread as the NAT-PT problem,
so we've survived this long, but the IETF is still in denial.

-Dave

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 30 May 2014 08:47:11 +1200

On 29/05/2014 20:31, Liubing (Leo) wrote:
> But for the site-local anycast use case, I think of it as out of the scope of this ULA draft. 

Yes. If that needs work, it should be a separate document. For this
document, why not simply refer to RFC3879? We had this discussion
in 2003/2004.

(And we said then "Further study is required on the need for anycast
addresses with scope between link-local and global.")

   Brian

> Because as I understood, since the site-local is deprecated, the anycast use cases based on site-local are invalid as well. And it is not a goal to re-produce these anycast use cases in a ULA form in a v6ops document, so I just feel like there is nothing to say about it. 
> 
> What are your thoughts?
> 
> Regards,
> Bing
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
> .
>

---

From: Lorenzo Colitti <[email-masked]>
Date: Fri, 30 May 2014 09:46:24 +0900

On Fri, May 30, 2014 at 2:35 AM, Dave Thaler <[email-masked]> wrote:

> useful with no replacement hasn't really helped anything.

I agree that deprecating something with no replacement is not useful, but
the fact of the matter is that there *is* no replacement, and this
infrormational document can't change that - that ship sailed in 2004 with
standards track RFC 3879.

I agree with Brian that if we need a replacement for this, it would have to
be a separate document. An informational about ULA usage is not the right
place to create such a replacement.