Subject: [v6ops] v6ops charter update discussion

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 13 Apr 2015 23:57:52 +0000

Lee and I are reviewing the v6ops charter. I have attached a proposed charter and diffs against the current one. Joel has not commented on this yet, and while we have run it by the sunset4 chairs, we haven’t gotten a reading from them. Sunset4 is relevant because possibly the ipv4-as-a-service discussion would be better handled there. In this email, I’m soliciting opinions in general.

The charter update started with Lee feeling that the fourth bullet of our current charter, which reads
    4. Publish Informational or BCP RFCs that identify and analyze 
       solutions for deploying IPv6 within common network environments,
       such as ISP Networks, Enterprise Networks, Unmanaged Networks
       (Home/Small Office), and Cellular Networks.
       (http://datatracker.ietf.org/wg/v6ops/charter/)
is largely done. We know how to deploy IPv6.

In addition, I think we need, collectively, to figure out how to get to IPv6-only. A large issue is “so how do we connect to IPv4 content and services from an IPv6-only network”, which is where ipv4-as-a-service comes in. I propose adding a bullet item regarding a road map to IPv6-only.

    4. Describe an operational roadmap to IPv6-only network deployment, 
       with or without IPv4 delivered as an overlay or translation
       service.

In my mind, that includes operational discussions of deployments and deployment issues in IPv4-as-a-service; one possible update would be to make that more explicit.

In other respects, the update is mostly editorial.

The other three tasks remain unchanged - collect operational experience, identify operational and security risks, and turn them over to other working groups - notably 6man.

Hoping for your input. Do you agree with these changes? If not, what changes, or further changes, would you recommend? 

As to proposed milestones, I’d like to believe that 

these are done:
   draft-ietf-v6ops-6to4-to-historic
   draft-ietf-v6ops-cidr-prefix

we can finalize and ship these by July:
   draft-ietf-v6ops-design-choices
   draft-ietf-v6ops-pmtud-ecmp-problem

and these by November:
   draft-ietf-v6ops-siit-dc-*
   (would like a deployment report for siit-dc and siit-dc-2xlat in support)
   (would like one for 464xlat as well)

On another point, Lee and I have been discussing the operational reports we had at IETF 92, and feel that was time well spent. Those had a common thread, which was the deployment of Softwire’s MAP-E and MAP-T technologies in their networks. We are thinking about asking companies deploying IPv6 in Europe, Asia, and South America to make reports in the coming three meetings, on their IPv6 deployments and the issues they face. Would that be of general interest? How would you propose to tune that concept?

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 14 Apr 2015 07:19:33 +0200 (CEST)

> is largely done. We know how to deploy IPv6.

Hm, while I generally agree with you, does this mean that these kinds of 
RFCs will be out-of-scope for v6ops going forward? I would hate for us to 
take this out of the charter and then turn people away when they show up 
with a document for a solution we didn't think of yet.

Or perhaps paragraph 1 is enough to allow for capturing these kinds of 
documents?

>       with or without IPv4 delivered as an overlay or translation

Fully agreed.

> On another point, Lee and I have been discussing the operational reports 
> we had at IETF 92, and feel that was time well spent. Those had a common 
> thread, which was the deployment of Softwire’s MAP-E and MAP-T 
> technologies in their networks. We are thinking about asking companies 
> deploying IPv6 in Europe, Asia, and South America to make reports in the 
> coming three meetings, on their IPv6 deployments and the issues they 
> face. Would that be of general interest? How would you propose to tune 
> that concept?

I think this is worthwile, as long as it's not going to be come a long 
list of 10-15 minute presentations saying the same thing. For those, we 
can keep it on the list. I always welcome operational reports in the 
meetings, but they need to contain news, not "we experienced the same 
thing as <foo> and solved it the same way".

I would like to hear from the ds.lite deployers out there, I know they 
exist. Also from 464XLAT+NAT64 deployments (probably in mobile).

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Apr 2015 08:51:47 +1200

On 14/04/2015 17:19, Mikael Abrahamsson wrote:
>> Lee and I are reviewing the v6ops charter. I have attached a proposed charter and diffs against the current one. Joel has not
>> commented on this yet, and while we have run it by the sunset4 chairs, we haven’t gotten a reading from them. Sunset4 is
>> relevant because possibly the ipv4-as-a-service discussion would be better handled there. In this email, I’m soliciting
>> opinions in general.
>>
> Hm, while I generally agree with you, does this mean that these kinds of RFCs will be out-of-scope for v6ops going forward? I
> would hate for us to take this out of the charter and then turn people away when they show up with a document for a solution we
> didn't think of yet.

I agree that we should not exclude such work, and it could be that the
existing documents need corrections, but on the other hand the time
for soliciting new work in this area is past.

> Or perhaps paragraph 1 is enough to allow for capturing these kinds of documents?

Yes, because it mentions "solutions".

>> On another point, Lee and I have been discussing the operational reports we had at IETF 92, and feel that was time well spent.
>> Those had a common thread, which was the deployment of Softwire’s MAP-E and MAP-T technologies in their networks. We are
>> thinking about asking companies deploying IPv6 in Europe, Asia, and South America to make reports in the coming three
>> meetings, on their IPv6 deployments and the issues they face. Would that be of general interest? How would you propose to tune
>> that concept?
> 
> I think this is worthwile, as long as it's not going to be come a long list of 10-15 minute presentations saying the same thing.
> For those, we can keep it on the list. I always welcome operational reports in the meetings, but they need to contain news, not
> "we experienced the same thing as <foo> and solved it the same way".

Correct, and I don't think it needs to be strictly regional, although
that may be a travel optimisation. I would suggesting soliciting lightning
talks on [email-masked]. There are handy messages there from
time to time, like
http://lists.cluenet.de/pipermail/ipv6-ops/2014-December/010402.html

   Brian

> 
> I would like to hear from the ds.lite deployers out there, I know they exist. Also from 464XLAT+NAT64 deployments (probably in
> mobile).
> 
> 
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: joel jaeggli <[email-masked]>
Date: Tue, 14 Apr 2015 20:49:14 -0700

On 4/13/15 4:57 PM, Fred Baker (fred) wrote:
> Lee and I are reviewing the v6ops charter. I have attached a proposed
> charter and diffs against the current one. Joel has not commented on
> this yet, and while we have run it by the sunset4 chairs, we haven’t
> gotten a reading from them. Sunset4 is relevant because possibly the
> ipv4-as-a-service discussion would be better handled there. In this
> email, I’m soliciting opinions in general.

not to cast aspersions in any direction in particular, but if we seem
operators running such things and have cause to provide advice on them
then by all means I'm fine with that here.

that seems consistent with work on for example 464xlat

> The charter update started with Lee feeling that the fourth bullet of
> our current charter, which reads 4. Publish Informational or BCP RFCs
> that identify and analyze solutions for deploying IPv6 within common
> network environments, such as ISP Networks, Enterprise Networks,
> Unmanaged Networks (Home/Small Office), and Cellular Networks. 
> (http://datatracker.ietf.org/wg/v6ops/charter/) is largely done. We
> know how to deploy IPv6.

I largely agree that some victory can be declared there.

> In addition, I think we need, collectively, to figure out how to get
> to IPv6-only. A large issue is “so how do we connect to IPv4 content
> and services from an IPv6-only network”, which is where
> ipv4-as-a-service comes in. I propose adding a bullet item regarding
> a road map to IPv6-only.

I think we're probably front-running the community of contributors by a
fair bit, but I think there are people and projects niddling around the
edges even as they employ some transition mechanism for backwards
compatibility.

> with or without IPv4 delivered as an overlay or translation service.
>
> In my mind, that includes operational discussions of deployments and
> deployment issues in IPv4-as-a-service; one possible update would be
> to make that more explicit.
> 
> The other three tasks remain unchanged - collect operational
> experience, identify operational and security risks, and turn them
> over to other working groups - notably 6man.

yup

> Hoping for your input. Do you agree with these changes? If not, what
> changes, or further changes, would you recommend?
> 
> these are done: draft-ietf-v6ops-6to4-to-historic 
> draft-ietf-v6ops-design-choices draft-ietf-v6ops-pmtud-ecmp-problem
> 
> and these by November: draft-ietf-v6ops-siit-dc-* (would like a
> deployment report for siit-dc and siit-dc-2xlat in support) (would
> like one for 464xlat as well)
> 
> On another point, Lee and I have been discussing the operational
> reports we had at IETF 92, and feel that was time well spent. Those
> had a common thread, which was the deployment of Softwire’s MAP-E and
> MAP-T technologies in their networks. We are thinking about asking
> companies deploying IPv6 in Europe, Asia, and South America to make
> reports in the coming three meetings, on their IPv6 deployments and
> the issues they face. Would that be of general interest? How would
> you propose to tune that concept?
> 
> 
> 
> _______________________________________________ sunset4 mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/sunset4
>