Subject: [v6ops] Comments on draft-ali-ipv6rtr-reqs-01

From: Mohammad Moghaddas <[email-masked]>
Date: Wed, 28 Dec 2016 20:55:52 +0100

​Hi,

I've some generally minor comments regarding draft-ali-ipv6rtr-reqs-01
which you can find below.

*​​2.4 <https://tools.ietf.org/html/draft-ali-ipv6rtr-reqs-01#section-2.4>
​​Routers*

> ​A router connects to two or more logical interfaces and
> *​​at least one** physical interface*.

Let's
​imagine a scenario where a VM is acting as a router for other VMs on the
same host; in that case the traffic isn't even touching a real physical
interface.

​

​Wrt. to how a
router
processes packets, I think an explanation about packets
destined for Control-Plane/Management-Plane, or packets which need to go
under some sort of operation before being forwarded, is missing.
(QoS, PBR, MPLS, SR, etc.)

*​​3.1 <https://tools.ietf.org/html/draft-ali-ipv6rtr-reqs-01#section-3.1>
​​Configuration*
​I'm wondering why NETCONF isn't mentioned. Or maybe I'm missing something?

*​​3.4 <https://tools.ietf.org/html/draft-ali-ipv6rtr-reqs-01#section-3.4>
​Device Protection against Denial of Service Attacks*

> ​
> Manufacturers and system integrators should test and clearly
> ​
> *​​report the packet/traffic load handling capabilities* of devices
> ​
> with and without various encryption methods enabled
> ​
>
​Can this be more specific like
​reporting ​
PPS / CPS, throughout, etc?

​Thank you!

/Mohammad​

--

Kind Regards,
*Mohammad Moghaddas*

<http://www.linkedin.com/in/moghaddas/>

---

From: Mark Smith <[email-masked]>
Date: Thu, 29 Dec 2016 08:50:49 +1100

This draft looks to be an individual draft, and I don't remember it being
posted here for discussion.

Send your comments direct to the author(s), and also ask them to send it to
this and perhaps the 6man WG for discussion when they're ready.

Regards,
Mark.

On 29 Dec. 2016 06:56, "Mohammad Moghaddas" <[email-masked]> wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 30 Dec 2016 13:49:34 -0800

> On Dec 28, 2016, at 11:55 AM, Mohammad Moghaddas <[email-masked]> wrote:
> 
> I've some generally minor comments regarding draft-ali-ipv6rtr-reqs-01 which you can find below.
> 
> ​​2.4 ​​Routers
> ​A router connects to two or more logical interfaces and ​​at least one physical interface.
> Let's ​imagine a scenario where a VM is acting as a router for other VMs on the same host; in that case the traffic isn't even touching a real physical interface.
> ​
> ​Wrt. to how a router processes packets, I think an explanation about packets destined for Control-Plane/Management-Plane, or packets which need to go under some sort of operation before being forwarded, is missing. (QoS, PBR, MPLS, SR, etc.)

Given the existence of documents like RFC 1812 that don’t chase non-IP layers down, I’m not convinced that I understand the reason for writing a textbook on the topic. The IP sublayer receives a packet from the layer below it, which might be any of the things you mentioned or one of a long list of others, considers the parameters it is intended to consider (which typically includes the destination address, and might also include other information) to determine the next hop (and potentially queuing or other conditioning), and uses some internal or external API to hand the packet to another instance of the layer below it. The internals of said lower layers aren’t relevant to the function or routing an IP packet.

> ​​3.1 ​​Configuration

NETCONF could be added. 

> ​​3.4 ​Device Protection against Denial of Service Attacks
> ​Manufacturers and system integrators should test and clearly report the packet/traffic load handling capabilities of devices​ with and without various encryption methods enabled​
> ​Can this be more specific like ​reporting ​PPS / CPS, throughout, etc?

Again, here there be dragons. For example, if the test is for packet performance, I would expect the report to indicate packet performance. Note that in a packet performance test, a 64 byte packet and a 9000 byte packet are identical - they are both packets. In an encrypt/decrypt test, the size of the packet is of great importance, as each byte (or each code word, depending on the type of encryption in use) has to be handled separately and in succession. I tend to think that the manufacturer (or other implementer) is on the hook to describe what they produced and the results of their testing. At that point, buyer beware: the point of having the maker report his or her testing is to inform the potential buyer, who will very likely repeat the testing for themselves in their environment (which may differ from the manufacturer’s test bench, and those differences may be important), but who can use manufacturer testing as a first laugh test.

---

From: Fred Baker <[email-masked]>
Date: Fri, 30 Dec 2016 13:51:28 -0800

> On Dec 28, 2016, at 1:50 PM, Mark Smith <[email-masked]> wrote:
> 
> This draft looks to be an individual draft, and I don't remember it being posted here for discussion. 

It is indeed an individual draft, and to my knowledge no given working group has been asked for opinions. That said, we welcome any and all review. Specifically, I have copied v6ops and 6man on this note.

---

From: "Russ White" <[email-masked]>
Date: Fri, 30 Dec 2016 16:59:09 -0500

> It is indeed an individual draft, and to my knowledge no given working
group
> has been asked for opinions. That said, we welcome any and all review.
> Specifically, I have copied v6ops and 6man on this note.

We would like to present it to a WG as a work item--which WG would be best
for this one? There are some sections that need to be filled before we
present it, I think.

:-)

Russ

---

From: Bob Hinden <[email-masked]>
Date: Fri, 30 Dec 2016 14:51:46 -0800

Russ,

> On Dec 30, 2016, at 1:59 PM, Russ White <[email-masked]> wrote:
> 
> 

Suggest you request a slot when we call for agenda items for 6MAN in a month or so.

We can figure out base on interest if 6MAN would take it on.  In the mean time, please ask for comments on the IPv6 list (as I think Fred just did).

Bob

> 
> :-)
> 
> Russ
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------