Subject: [v6ops] Eating one's own dog food

From: Nick Hilliard <[email-masked]>
Date: Thu, 30 Mar 2017 12:23:42 +0100

No comment is necessary here:

https://twitter.com/jaredmauch/status/847227063467560961

Nick

---

From: Enno Rey <[email-masked]>
Date: Thu, 30 Mar 2017 13:32:32 +0200

Here's another stat, from a recent security event

https://twitter.com/Enno_Insinuator/status/847410736041152512

Enno

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

-- 
Enno Rey

ERNW GmbH - Carl-Bosch-Str. 4 - 69115 Heidelberg - www.ernw.de
Tel. +49 6221 480390 - Fax 6221 419008 - Cell +49 173 6745902 

Handelsregister Mannheim: HRB 337135
Geschaeftsfuehrer: Enno Rey

=======================================================
Blog: www.insinuator.net || Conference: www.troopers.de
Twitter: @Enno_Insinuator
=======================================================

---

From: Philip Homburg <[email-masked]>
Date: Thu, 30 Mar 2017 13:48:10 +0200

>https://twitter.com/Enno_Insinuator/status/847410736041152512

What I see as my dog food, is that wifi just has to provide dual stack.

If people want to play around with other stuff, fine. I personally consider
dual stack the only sensible way of providing both IPv6 and IPv4 to a host.
(The wifi access point is free to do 464xlat, I don't care)

So in places where dual stack is not the default (FOSDEM for example), I 
specifically connect to a 'legacy' network that provides dual stack.

If, in the far future 99% of the content I need is available over IPv6, 
then I'm willing to entertain the notion of connecting to an IPv6-only
network.

I find the relatively large number of connections IETF-legacy more interesting.
Do these people have trouble connecting to 802.1X or is there another reason?

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 30 Mar 2017 13:58:39 +0200 (CEST)

On Thu, 30 Mar 2017, Philip Homburg wrote:

> I find the relatively large number of connections IETF-legacy more 
> interesting. Do these people have trouble connecting to 802.1X or is 
> there another reason?

Most people at the IETF meeting show up and their devices connect to some 
network that is in the connection table. If they've been to an IETF 
before, it's likely they have one or several networks in there and "it 
just works" and they never check what SSID they're connected to.

So I imagine it's not a conscious decision.

If I were there, I would probably use the NAT64 one on my iOS devices, so 
far my testing has shown that it works very well (with recent iOS that 
does the NAT64 prefix bump-in-API functionality to handle IPv4 literals). 
On MacOS, not so much.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 30 Mar 2017 07:11:36 -0500

Actually, here at the IETF network, I got a /64 delegated to my laptop and I’m running a VM with a CLAT. So, I’m connected to the NAT64 network and running dual-stack with private IPv4 addresses, and making sure that everything I run works, even if uses literal addresses.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Philip Homburg <[email-masked]>
Responder a: <[email-masked]>
Fecha: jueves, 30 de marzo de 2017, 6:48
Para: <[email-masked]>
Asunto: Re: [v6ops] Eating one's own dog food

    

    

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 30 Mar 2017 09:22:25 -0500

pinging while on ietf-legacy ESSID:

- on IPv6 there seems to be longer RTT for a same service, than on IPv4.

RTT for 2001:4860:4860::8888, or for www.kame.net, averages 150ms; 
whereas RTT for 8.8.8.8, or for (ipv4) www.kame.net averages 40ms.  
That's maybe three times faster on IPv4.

Alex

---

From: Nabil Benamar <[email-masked]>
Date: Thu, 30 Mar 2017 15:36:12 +0100

Alex,

The average values I can read from the  capture screen are different from
what you mentioned! !
IPv6 is faster.

Best regards
Nabil

On Mar 30, 2017 15:23, "Alexandre Petrescu" <[email-masked]>
wrote:

> v6ops mailing [email-masked]://www.ietf.org/mailman/listinfo/v6ops
>
>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 30 Mar 2017 09:38:58 -0500

Ah yes sorry!  My reading mistake, I retract that.

Le 30/03/2017 à 09:36, Nabil Benamar a écrit :
> Alex,
>
> The average values I can read from the  capture screen are different 
> from what you mentioned! !
> IPv6 is faster.
>
> Best regards
> Nabil
>
>
> On Mar 30, 2017 15:23, "Alexandre Petrescu" 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     RTT for 2001:4860:4860::8888, or for www.kame.net
>     <http://www.kame.net>, averages 150ms; whereas RTT for 8.8.8.8, or
>     for (ipv4) www.kame.net <http://www.kame.net> averages 40ms. 
>>     <https://twitter.com/jaredmauch/status/847227063467560961>
>>
>>     Nick
>>
>>
>>
>>     [email-masked] <mailto:[email-masked]>
>>     <https://www.ietf.org/mailman/listinfo/v6ops>
>     _______________________________________________ v6ops mailing list
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/v6ops> 
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 30 Mar 2017 09:56:37 -0500

On Mar 30, 2017, at 6:58 AM, Mikael Abrahamsson <[email-masked]> wrote:
> Most people at the IETF meeting show up and their devices connect to some network that is in the connection table. If they've been to an IETF before, it's likely they have one or several networks in there and "it just works" and they never check what SSID they're connected to.

Yup.   I had to figure out how to enable ietf-nat64 because of the non-PKI cert.   I did so, ironically, after I noticed that there were only 13 hosts on ietf-nat64, which I noticed because I saw the person taking this picture.

I would prefer that the default ietf ssid were IPv6-only with NAT64 for legacy service.   If people want IPv4, they should switch to ietf-legacy.   And if we really want this data to be meaningful, we should change the name of ietf-legacy every IETF so that people have to choose it to get it.

:)

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 30 Mar 2017 16:17:52 +0100

Ted Lemon wrote:
> I would prefer that the default ietf ssid were IPv6-only with NAT64 for
> legacy service.   If people want IPv4, they should switch to
> ietf-legacy.   And if we really want this data to be meaningful, we
> should change the name of ietf-legacy every IETF so that people have to
> choose it to get it.

I'd be pleased if this were done at meetings that I regularly attend.

Nick

---

From: Alejandro Acosta <[email-masked]>
Date: Thu, 30 Mar 2017 11:38:32 -0400

Hello there,

  Regarding RTT v4 vs v6 I did something "interesting" recently, would
like to know your thoughs.

  If you ping6 your loopback (let´s say 1000 packets) interface with
Windows or Linux, v6 is faster.

  Now try the same on MAC.., v6 is 20-25% slower.

  I did the above with many devices (and asked some friends) and the
behavior was pretty much the same.

MAC:

--- 127.0.0.1 ping statistics ---
100 packets transmitted, 100 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.037/*0.098*/1.062/0.112 ms

--- ::1 ping6 statistics ---
100 packets transmitted, 100 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 0.058/*0.120*/0.194/0.027 ms

Linux:

--- 127.0.0.1 ping statistics ---
100 packets transmitted, 100 received, 0% packet loss, time 98999ms
rtt min/avg/max/mdev = 0.015/0.021/*0.049*/0.007 ms

--- ::1 ping statistics ---
100 packets transmitted, 100 received, 0% packet loss, time 99013ms
rtt min/avg/max/mdev = 0.019/0.031/*0.040*/0.004 ms

Windows 10:

Ping statistics for ::1:
    Packets: Sent = 100, Received = 100, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, *Average = 0ms*

Ping statistics for 127.0.0.1:
    Packets: Sent = 100, Received = 100, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, *Maximum = 4ms*, *Average = 0ms*

El 30/3/17 a las 10:38 a.m., Alexandre Petrescu escribió:
>>     <http://www.kame.net>, averages 150ms; whereas RTT for 8.8.8.8,
>>     or for (ipv4) www.kame.net <http://www.kame.net> averages 40ms. 
>>     _______________________________________________ v6ops mailing
>>     list [email-masked] <mailto:[email-masked]>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 30 Mar 2017 11:06:43 -0500

I had an error in interpreting the word "TTL" displayed rightmost in 
ping IPv4, as the "time" displayed rightmost on IPv6 ping, in Windows.

Did you use Windows for the test of loopback?

---

From: Tim Chown <[email-masked]>
Date: Thu, 30 Mar 2017 20:59:50 +0000

>> https://twitter.com/jaredmauch/status/847227063467560961

Anyone know what software is putting that display together?

Tim

---

From: Michael Breuer <[email-masked]>
Date: Thu, 30 Mar 2017 23:38:59 +0200

It's done using Grafana (grafana.com).

You can access the dashboard at http://dashboard.meeting.ietf.org:3000/

But apparently it's ipv4 only.

Michael

---

From: Alejandro Acosta <[email-masked]>
Date: Thu, 30 Mar 2017 21:54:24 -0400

I tested on different Windows, Linux & MAC

El 30/3/17 a las 12:06 p.m., Alexandre Petrescu escribió:
>>   Regarding RTT v4 vs v6 I did something "interesting" recently,
>> would like to know your thoughs.
>>
>>>> The average values I can read from the  capture screen are
>>>> different from what you mentioned! !
>>>> IPv6 is faster.
>>>>
>>>> Best regards
>>>> Nabil
>>>>
>>>>    
>>>>
>>>> <[email-masked]
>>>> <mailto:[email-masked]>> wrote:
>>>>
>>>>     or for (ipv4) www.kame.net <http://www.kame.net> averages
>>>>     40ms.  That's maybe three times faster on IPv4.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>     Alex
>>>>
>>>>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 30 Mar 2017 21:52:56 -0500

And what application on Macintosh relies a lot on using a loopback 
interface?  Maybe no Mac application uses it.

Alex

Le 30/03/2017 à 20:54, Alejandro Acosta a écrit :
>>>>>     <http://www.kame.net>, averages 150ms; whereas RTT for
>>>>>     8.8.8.8, or for (ipv4) www.kame.net <http://www.kame.net>
>>>>>     averages 40ms.  That's maybe three times faster on IPv4.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>     Alex
>>>>>
>>>>>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 30 Mar 2017 21:54:12 -0500

Alex

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 31 Mar 2017 12:20:11 +0100

Mikael Abrahamsson wrote:
> Most people at the IETF meeting show up and their devices connect to
> some network that is in the connection table. If they've been to an IETF

https://www.ietf.org/registration/MeetingWiki/wiki/doku.php?id=94net

ietf-legacy is unencrypted, so perhaps lots of people have set their
laptops to auto-join open access networks (wow, nuts!).

802.1x on "ietf", hm.

Not surprising that the other networks are not used widely then.

Nick

---

From: Joe Touch <[email-masked]>
Date: Fri, 31 Mar 2017 06:08:14 -0700

> On Mar 31, 2017, at 4:20 AM, Nick Hilliard <[email-masked]> wrote:
> 

Or phones.

Joe