Subject: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-rfc7084-bis-00.txt

From: Yannis Nikolopoulos <[email-masked]>
Date: Wed, 1 Mar 2017 11:14:27 +0200

Jordi,

unless I'm reading an earlier version, unlike MAP-E/T, lw4o6 is 
optional. From 
https://tools.ietf.org/html/draft-palet-v6ops-rfc7084-bis-00#section-4.4.7:

" The CE router MAY support lw4o6 functionality"

regards,

Yannis

On 02/28/2017 10:42 PM, JORDI PALET MARTINEZ wrote:
> Hi Yannis,
>
> I’m not sure to understand your point.
>
> Unless I did a mistake while editing the draft, all them are with SHOULD.
>
> Regards,
> Jordi
>   
>
> -----Mensaje original-----
> De: Yannis Nikolopoulos <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: martes, 28 de febrero de 2017, 21:29
> Para: <[email-masked]>, <[email-masked]>
> Asunto: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-rfc7084-bis-00.txt
>
>      Hi,
>      
>      I just don't get why is lw4o6 differentiated from MAP. To me, it does
>      not make sense that one is optional and the other two are not. The
>      rationale does not help much either
>      
>      
>      regards,
>      
>      Yannis
>      
>      
>      On 02/21/2017 11:11 AM, JORDI PALET MARTINEZ wrote:
>      > Hi,
>      >
>      > I’ve submitted a -bis draft for updating RFC7084 (Basic Requirements for IPv6 Customer Edge Routers).
>      
>      <snip>
>      
>      > 1) Considering that there’re no more IPv4 addresses and according to my experience with service providers, they will prefer to avoid dual stack in the WAN ASAP, and avoid CGN, I think 6rd and DS-LITE need to be changed to MAY.
>      >
>      > 2) At the same time, I’ve included lw4o6, also with MAY. The rationale for this: Many service providers try to avoid the CGN, and lw4o6 is a way to do so, without increasing the cost of the CE. Basically, a CE that supports a regular IPv4 NAT+DS-Lite, is already capable of supporting lw4o6. The cost in terms of CE flash memory for DS-Lite is about 1Kb. The open source package available for DS-Lite that I’ve been digging-in takes 6Kb, but already includes also support for both MAP versions.
>      >
>      > 3) Include support for 464XLAT, MAP-E, MAP-T as SHOULD. Those protocols are the 3 alternatives that a service provider has to deploy IPv6-only WAN, but at the same time provide dual-stack in the LANs, with practically the same functionalities or even more, that what CGN requires. At the service provider network, it requires, instead of CGN, a stateful NAT64 (which cellular providers are already using) or a Border Relay (for MAP). Basically, a CE needs only 3Kbytes of code in the flash to support CLAT (the CE part of 464XLAT). The support for MAP (both versions and also lw6o4), requires about 6Kb.
>      >
>      > Regards,
>      > Jordi
>      >
>      >
>      >
>      
>      
>      
>
>
>
> **********************************************
> IPv4 is over
> Are you ready for the new Internet ?
> http://www.consulintel.es
> The IPv6 Company
>
> This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.
>
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 01 Mar 2017 10:17:04 +0100

Yeah, it has been updated already to 01:

https://tools.ietf.org/html/draft-palet-v6ops-rfc7084-bis

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Yannis Nikolopoulos <[email-masked]>
Responder a: <[email-masked]>
Fecha: miércoles, 1 de marzo de 2017, 10:14
Para: <[email-masked]>
Asunto: Re: [v6ops] FW: New Version Notification for draft-palet-v6ops-rfc7084-bis-00.txt

    Jordi,

    
    regards,
    
    Yannis

---

From: Yannis Nikolopoulos <[email-masked]>
Date: Wed, 1 Mar 2017 12:12:21 +0200

Thanks Jordi, I missed this update