Subject: [v6ops] Fwd: IETF 98 v6ops agenda request

From: Fred Baker <[email-masked]>
Date: Wed, 8 Mar 2017 11:20:28 -0800

The chairs have received this request, and (surprise) are in the process of planning our agenda. Do folks want to discuss it?

> Begin forwarded message:
> 
> From: David Schinazi <[email-masked]>
> Subject: IETF 98 v6ops agenda request
> Date: March 8, 2017 at 10:50:53 AM PST
> To: [email-masked], [email-masked], Ron Bonica <[email-masked]>
> Cc: [email-masked], Tommy Pauly <[email-masked]>
> 
> Hi v6ops chairs,
> 
> Tommy Pauly and myself have written up what we've learned
> in the past few years maintaining and improving Apple's Happy Eyeballs stack,
> and submitted it as draft-pauly-v6ops-happy-eyeballs-update.
> We'd like the opportunity to present this at the v6ops session in Chicago.
> 
> I think this would be a 15 minute presentation (including questions),
> with the title "An Update to Happy Eyeballs". Would that be possible?
> 
> Full draft available here:
> https://tools.ietf.org/html/draft-pauly-v6ops-happy-eyeballs-update <https://www.ietf.org/id/draft-pauly-v6ops-happy-eyeballs-update-00.txt>
> 
> Thanks!
> David Schinazi

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 08 Mar 2017 21:28:49 +0100

I think we should.

Actually, I wondered several times if we should start working on “retiring” HE.

Reason for that. Is hiding IPv6 network problems. Many times, operators don’t realize that something failed with IPv6 because it falls back to IPv4.

If IPv4 fails, we don’t have such mechanism, right?

I fully understand the reason why HE was developed, but the situation is not the same, and the only way for operators and data centers to realize it now, is to force a customer complain.

Maybe updating the document and explicitly saying that HE is updated with this document AND will be deprecated, let’s say at the end of 2017, could be a nice deal.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Fred Baker <[email-masked]>
Responder a: <[email-masked]>
Fecha: miércoles, 8 de marzo de 2017, 20:20
Para: "[email-masked] WG" <[email-masked]>
Asunto: [v6ops] Fwd: IETF 98 v6ops agenda request

    Begin forwarded message:

    

    Hi v6ops chairs,

    
    
    Thanks!
    David Schinazi

    
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Fred Baker <[email-masked]>
Date: Wed, 8 Mar 2017 12:42:16 -0800

On Mar 8, 2017, at 12:28 PM, JORDI PALET MARTINEZ <[email-masked]> wrote:
> operators don’t realize that something failed with IPv6 because it falls back to IPv4.
> 

Actually, they fail over mutually. And by the same mechanism, if a device has two interfaces and therefore two addresses, or two addresses on the same interface (note that I didn't say whether that was IPv4 or IPv6), and one address stops working (pick a reason), it selects the working address and all that comes with it.

---

From: Gert Doering <[email-masked]>
Date: Wed, 8 Mar 2017 21:55:55 +0100

Hi,

On Wed, Mar 08, 2017 at 12:42:16PM -0800, Fred Baker wrote:
> Actually, they fail over mutually. And by the same mechanism, if
> a device has two interfaces and therefore two addresses, or two
> addresses on the same interface (note that I didn't say whether
> that was IPv4 or IPv6), and one address stops working (pick a
> reason), it selects the working address and all that comes with it.

It does?  For two v6 addresses with both global scope?

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                        Vorstand: Sebastian v. Bomhard
Joseph-Dollinger-Bogen 14          Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                   HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444           USt-IdNr.: DE813185279

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 8 Mar 2017 21:05:20 +0000

Yes. I think HE has proven incredibly valuable and will continue to be needed - not just for selecting between IPv4 and IPv6, but also for selecting from among multiple IPv6 interfaces. Increased understanding and improvements are a good thing.
Barbara

From: v6ops [mailto:[email-masked]] On Behalf Of Fred Baker
Sent: Wednesday, March 08, 2017 2:20 PM
To: [email-masked] WG <[email-masked]>
Subject: [v6ops] Fwd: IETF 98 v6ops agenda request

Begin forwarded message:

From: David Schinazi <[email-masked]<mailto:[email-masked]>>
Subject: IETF 98 v6ops agenda request
Date: March 8, 2017 at 10:50:53 AM PST
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, Ron Bonica <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>, Tommy Pauly <[email-masked]<mailto:[email-masked]>>

Hi v6ops chairs,

Full draft available here:
https://tools.ietf.org/html/draft-pauly-v6ops-happy-eyeballs-update<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_id_draft-2Dpauly-2Dv6ops-2Dhappy-2Deyeballs-2Dupdate-2D00.txt&d=DQMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=UpwsLalmy8GAZAXB3boJ5cD9LwLWD5RLWBwJdxYCTDA&s=DN3vSMd5e1fw3G_JUKA3MRwBPDxQ3-dlXRAbc2QtJDg&e=>

Thanks!
David Schinazi

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 8 Mar 2017 21:15:47 +0000

> > Actually, they fail over mutually. And by the same mechanism, if a
> > device has two interfaces and therefore two addresses, or two
> > addresses on the same interface (note that I didn't say whether that
> > was IPv4 or IPv6), and one address stops working (pick a reason), it
> > selects the working address and all that comes with it.
> 

If current HE algorithms aren't able to select from among multiple globally scoped IPv6 addresses, then addition of that functionality would definitely be a valuable improvement. I do believe that support for multiple interfaces (whether the interfaces are on the device or attached to a multi-homed network), and being able to select the best interface without sequential trying, is important.
Barbara

---

From: Fred Baker <[email-masked]>
Date: Wed, 8 Mar 2017 13:26:30 -0800

> On Mar 8, 2017, at 12:55 PM, Gert Doering <[email-masked]> wrote:
> 
> Hi,
> 

The algorithm doesn't discuss scope or address type. It does mention address *family*; it states the algorithm in an arbitrarily narrow range - one has an IPv6 address and an IPv4 address for itself and for the peer, and is choosing between address pairs. I commented in the discussion, but the authors didn't pick up on the comment. To me, it is fundamentally about multihoming (host or network), and choosing between two access methods. If I can get there using IPv6 or Bluetooth LE 4.2, ... Given a choice, any choice, the suggestion is that one tries both choices in a staged manner, and selects the one that first demonstrably works.

Freds-MacBook-Pro:rfc fred$ rfc 'happy eyeballs'
https://tools.ietf.org/html/rfc6555
6555 Happy Eyeballs: Success with Dual-Stack Hosts. D. Wing, A.
     Yourtchenko. April 2012. (Format: TXT=34048 bytes) (Status: PROPOSED
     STANDARD) (DOI: 10.17487/RFC6555)

Freds-MacBook-Pro:rfc fred$ fgrep -i scope rfc6555.txt
   connection-oriented transports (e.g., TCP, SCTP), which is the scope
Freds-MacBook-Pro:rfc fred$ fgrep -i global rfc6555.txt
Freds-MacBook-Pro:rfc fred$

---

From: Enno Rey <[email-masked]>
Date: Wed, 8 Mar 2017 22:27:41 +0100

Hi,

On Wed, Mar 08, 2017 at 09:05:20PM +0000, STARK, BARBARA H wrote:
> Yes. I think HE has proven incredibly valuable and will continue to be needed - not just for selecting between IPv4 and IPv6, but also for selecting from among multiple IPv6 interfaces.

isn't RFC 6724 supposed to address this?

best

Enno

 Increased understanding and improvements are a good thing.

-- 
Enno Rey

ERNW GmbH - Carl-Bosch-Str. 4 - 69115 Heidelberg - www.ernw.de
Tel. +49 6221 480390 - Fax 6221 419008 - Cell +49 173 6745902 

Handelsregister Mannheim: HRB 337135
Geschaeftsfuehrer: Enno Rey

=======================================================
Blog: www.insinuator.net || Conference: www.troopers.de
Twitter: @Enno_Insinuator
=======================================================

---

From: Gert Doering <[email-masked]>
Date: Wed, 8 Mar 2017 22:40:09 +0100

Hi,

On Wed, Mar 08, 2017 at 01:26:30PM -0800, Fred Baker wrote:
> The algorithm doesn't discuss scope or address type. 

Well, it does not discuss *source* addresses either - which was my point,
it picks destination addresses.  So, your device with "two addresses on
the same interface", if they are both IPv6, will not benefit from HE
as I understand it.

Or maybe I'm totally misunderanding the paragraph quoted above.

Gert Doering
        -- NetMaster