Subject: [v6ops] OT: Requesting information/experience

From: Fred Baker <[email-masked]>
Date: Thu, 2 Mar 2017 09:40:03 -0800

ISOC has asked me to put together a report for them to publish in June regarding the state of IPv6 deployment. I'd appreciate any help folks on this list can give me, but I must ask that you reply privately, as it is off-topic. I'll include some notes ISOC gave me about the intended report, so you can see the objective and the kind of information I'm looking for.

> Project Overview
> 
> The State of IPv6 Deployment Report project aims to produce a thorough, well-presented and impactful report on the state of IPv6 deployment in time for the anniversary of World IPv6 Launch on June 6th, 2017.
> 
>  
> Project Goals
> 
> The goals of the project are as follows:
> 
> ·  To document the current state of IPv6 deployment, as thoroughly and objectively as possible
> 
> ·  To provide a ’one-stop-shop’ for someone interested in understanding the state of IPv6 deployment progress in mid-2017
> 
> ·  To stimulate further deployment: "If you think IPv6 isn't happening and that you don't need to act, here's how wrong you are."
> 
> ·  To pull together into one place all the various IPv6 deployment statistics that are scattered across the Internet
> 
> ·  To provide a reference point and baseline for future reports so that we can chart growth in IPv6 deployment in the months and years ahead
> 
> ·  To document some of the innovations that are happening as well as some of the challenges
> 
> ·  To identify and discuss the gaps in IPv6 deployment: where are the pockets of non-deployment?
> 
>  
> Audiences
> 
> The report has two primary audiences as follows:
> 
> ·  Executive Summary: Targeted at decision makers (business and policy) wanting to get a quick feel for the state of IPv6 deployment as it might impact their business and what they should do/think about it. This section of the report will also help technology journalists writing stories about IPv6.
> 
> ·  Body of the report: Targeted at engineers interested in a comprehensive picture of the state of IPv6 deployment, including some projections, recommendations and pointers to further resources.
> 

Much of the content will point to existing reports and content (and if you have favorite content to point to, please share), but hopefully pull it together in a way that makes the intended points. Specific content that folks here may be able to give me or point me to include operator case studies (timeline, what you did, what worked, what didn't), measurement methodologies (what was measured and how it was measured), specifics if they can be divulged (traffic ratios, customer numbers, ratios for dual-stacked customers), regional differences, specific applications (DNS, Email, web, etc), services (cloud, hosting, mail, geolocation, security, etc), IoT reality, ongoing incentives and challenges, and so on.

---

From: joel jaeggli <[email-masked]>
Date: Tue, 7 Mar 2017 07:43:26 -0800

On 3/2/17 9:40 AM, Fred Baker wrote:
> ISOC has asked me to put together a report for them to publish in June
> regarding the state of IPv6 deployment. I'd appreciate any help folks
> on this list can give me, but I must ask that you reply privately, as
> it is off-topic. I'll include some notes ISOC gave me about the
> intended report, so you can see the objective and the kind of
> information I'm looking for.
This sounds like a fairly worthwhile activity, I think a key distinction
compared to attempting something similar under the ruberic of v6ops
other than timelilyness is a lack of need to stake out a consensus
position WRT matters of opinion.
>>
>> *Project Overview*
>>
>> The State of IPv6 Deployment Report project aims to produce a
>> thorough, well-presented and impactful report on the state of IPv6
>> deployment in time for the anniversary of World IPv6 Launch on June
>> 6^th , 2017.
>>
>>  
>>
>> *Project Goals*
>>
>> ·  To provide a ’one-stop-shop’ for someone interested in
>> understanding the state of IPv6 deployment progress in mid-2017
>>
>> ·  To stimulate further deployment: "If you think IPv6 isn't
>> happening and that you don't need to act, here's how wrong you are."
>>
it strikes me a likely that the pool of doubters is not likely to be
swayed out of their positions on the rogers curve by a paper. market
signals that constrain future choices on the other hand do.
>>
>> ·  To pull together into one place all the various IPv6 deployment
>> statistics that are scattered across the Internet
>>
>> ·  To provide a reference point and baseline for future reports so
>> that we can chart growth in IPv6 deployment in the months and years ahead
>>
I personally don't value innovation as much as stability with respect to
base specifications. if it means distilling out the pieces w find hard
to or don't use or which don't offer the utility that was assumed great,
a key innovation is shedding the things you don't actually need.

>> *Audiences*
>> ·  Executive Summary: Targeted at decision makers (business and
>> policy) wanting to get a quick feel for the state of IPv6 deployment
>> as it might impact their business and what they should do/think about
>> it. This section of the report will also help technology journalists
>> writing stories about IPv6.
>>
>> ·  Body of the report: Targeted at engineers interested in a
>> comprehensive picture of the state of IPv6 deployment, including some
>> projections, recommendations and pointers to further resources.
>>
>
> Much of the content will point to existing reports and content (and if
> you have favorite content to point to, please share), but hopefully
> pull it together in a way that makes the intended points. Specific
> content that folks here may be able to give me or point me to include
> operator case studies (timeline, what you did, what worked, what
> didn't), measurement methodologies (what was measured and how it was
> measured), specifics if they can be divulged (traffic ratios, customer
> numbers, ratios for dual-stacked customers), regional differences,
> specific applications (DNS, Email, web, etc), services (cloud,
> hosting, mail, geolocation, security, etc), IoT reality, ongoing
> incentives and challenges, and so on.
the existance and feasibility of single-stacked edges is probably
interesting. I hear that a fair amount when dealing with future mobile
or stb/cpe upgrade cycles.
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Tim Chown <[email-masked]>
Date: Wed, 8 Mar 2017 09:36:05 +0000

Hi,

On 7 Mar 2017, at 15:43, joel jaeggli <[email-masked]<mailto:[email-masked]>> wrote:

Indeed.

One of the things one sees is the variety in the numbers, depending on the measurement methods.  Some analysis of that would be interesting.

For example, for the UK:

Google, 17% (to their content)
https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6-adoption&tab=per-country-ipv6-adoption

Akamai, 11% (to their CDN)
https://www.akamai.com/uk/en/our-thinking/state-of-the-internet-report/state-of-the-internet-ipv6-adoption-visualization.jsp

APNIC, 25% (by use of paid adverts, I believe)
https://stats.labs.apnic.net/ipv6/GB

*Project Overview*

*Project Goals*

·  To document the current state of IPv6 deployment, as thoroughly
and objectively as possible

There are a couple of very good lists already, which you probably already know of, but see
http://www.worldipv6launch.org/measurements/
and
https://labs.ripe.net/Members/mirjam/content-ipv6-measurement-compilation

·  To document some of the innovations that are happening as well as
some of the challenges

·  To identify and discuss the gaps in IPv6 deployment: where are the
pockets of non-deployment?

*Audiences*

Some reporting on IPv6-only deployment at the edges would be good, and its practicality, whether in mobile networks (where most of it seems to be) or elsewhere.

Tim

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

---

From: t.petch <[email-masked]>
Date: Fri, 10 Mar 2017 10:57:51 +0000

----- Original Message -----
From: "Tim Chown" <[email-masked]>
Sent: Wednesday, March 08, 2017 9:36 AM

> On 7 Mar 2017, at 15:43, joel jaeggli wrote:
>
> One of the things one sees is the variety in the numbers, depending on
the measurement methods.  Some analysis of that would be interesting.
> Google, 17% (to their content)
https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6
-adoption&tab=per-country-ipv6-adoption
> Akamai, 11% (to their CDN)
https://www.akamai.com/uk/en/our-thinking/state-of-the-internet-report/s
tate-of-the-internet-ipv6-adoption-visualization.jsp
> https://stats.labs.apnic.net/ipv6/GB

which sounds great until you drill down and see that BSKYB is 88.88% and
realise that that is for subscription TV - especially Association
Football - and not for a traditional ISP.

Take a major UK ISP, such as TalkTalk and you see that 'IPv6 Capable',
separated out by ASN, ranges from 0.00% to 0.01%, which bears out my
experience of the availability of IPv6 in the UK; ask a salesperson for
it and they will ask you how to spell it:-)

The major mobile provider, Vodafone, reaches the dizzy heights of 0.73%
availability.

The only place I have seen IPv6 used in anger is for outdoor sporting
venues connecting the various buildings back to the main office.

Ah well, back to academia of rfc4291bis.

Tom Petch

>   To document the current state of IPv6 deployment, as thoroughly
>   To provide a one-stop-shop for someone interested in
>   To stimulate further deployment: "If you think IPv6 isn't
>   To pull together into one place all the various IPv6 deployment
https://labs.ripe.net/Members/mirjam/content-ipv6-measurement-compilatio
n
>
>   To provide a reference point and baseline for future reports so
>   To document some of the innovations that are happening as well as
> some of the challenges
>
>   To identify and discuss the gaps in IPv6 deployment: where are the
>   Executive Summary: Targeted at decision makers (business and
>   Body of the report: Targeted at engineers interested in a
> Some reporting on IPv6-only deployment at the edges would be good, and
its practicality, whether in mobile networks (where most of it seems to
be) or elsewhere.

---

From: Simon Hobson <[email-masked]>
Date: Fri, 10 Mar 2017 11:30:09 +0000

> Football - and not for a traditional ISP.

Sky do do broadband (they push hard for triple play - voice line, broadband, and TV in one package), and AIUI they are IP6 enabled for that. In some respects they are better placed than most ISPs as they are one of the ones that mandate use of their own router (and won't release DSL/PPP login details).
I've also read that BT Internet (the retail ISP, not BT the voice carrier) have been IP6 enabled for some time and have enabled it on their (latest model) routers. 

> The major mobile provider, Vodafone, reaches the dizzy heights of 0.73%

Don't get me going on Vodamoan - I've been dealing with them for a couple of months now over some DSL installs and they still can't sort out some simple problems ! "What's our IP6 prefix is going to be one of the questions I ask them - but I don't want to confuse things until they get the rest of the problems fixed. For DSL in the UK, my advice is don't use Vodamoan !
Though to be fair, on the last leased line internet we had installed for a client site, they did provide an IP6 prefix - but for various reasons (including our own manglement) nothing got provided to the tenants. That is a different part of Vodamoan though.

At home I'm with Plusnet. They ran a couple of trials, but have since gone very quiet - it's been (IIRC) 2-3 years now with no news and not even any "we're working on it".

So yes, it's a bit of a mixed bag, with some ISPs (particularly smaller ones such as A&A and Zen) on the ball, and others in the ... well heck knows what their plans are !

---

From: Tim Chown <[email-masked]>
Date: Fri, 10 Mar 2017 15:02:15 +0000

Hi,

On 10 Mar 2017, at 10:57, t.petch <[email-masked]<mailto:[email-masked]>> wrote:

----- Original Message -----
From: "Tim Chown" <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 08, 2017 9:36 AM

This sounds like a fairly worthwhile activity, I think a key
distinction

Indeed.

For example, for the UK:

No, Sky provide broadband to their customers too - 4.5M residences, 93% enabled.

Updates from them, and BT, at http://www.ipv6.org.uk/2016/08/31/ipv6-council-meeting-october-2016/.

BT are done in the network, about to do rolling HomeHub updates to turn it on; if you plug your own router in on BT, it just works.

Their BT Smart Hub has it on by default already for users with that.

EE have approaching 1M IPv6-only handsets, see https://indico.uknof.org.uk/event/38/other-view?view=standard at the 14:15 slot.

Heh, I have 645 unread emails there… good luck!

Tim

Tom Petch

*Project Overview*

*Project Goals*

There are a couple of very good lists already, which you probably
already know of, but see
http://www.worldipv6launch.org/measurements/
and

 To provide a reference point and baseline for future reports so
that we can chart growth in IPv6 deployment in the months and years
ahead

I personally don't value innovation as much as stability with respect
to
base specifications. if it means distilling out the pieces w find hard
to or don't use or which don't offer the utility that was assumed
great,
a key innovation is shedding the things you don't actually need.

*Audiences*

Tim

---

From: t.petch <[email-masked]>
Date: Fri, 10 Mar 2017 17:52:44 +0000

----- Original Message -----
From: "Tim Chown" <[email-masked]>
To: "t.petch" <[email-masked]>
Cc: "joel jaeggli" <[email-masked]>; "IPv6 Operations"
<[email-masked]>
Sent: Friday, March 10, 2017 3:02 PM
>
> On 10 Mar 2017, at 10:57, t.petch
> Updates from them, and BT, at
http://www.ipv6.org.uk/2016/08/31/ipv6-council-meeting-october-2016/.

Tim

Simon forwarded me a link to the BT announcement which says

'their roll-out of the Internet Protocol v6 (IPv6) addressing standard
was completed for “all BT Broadband lines” in October 2016 '

and I note the wording; looking at the announcement itself, it says that
“all BT Broadband lines”
means what BT always means by that phrase, namely domestic use only, not
business users (which I am).  That choice seems odd to me that they
expect to do more with domestic users who likely have never heard of it
as opposed to business users who I would expect to be more clued up.

Ah well, I will have to stop saying that there is no public IPv6 service
from a UK ISP; shame, I rather enjoyed saying it.

Tom Petch

> BT are done in the network, about to do rolling HomeHub updates to
turn it on; if you plug your own router in on BT, it just works.
> EE have approaching 1M IPv6-only handsets, see
https://indico.uknof.org.uk/event/38/other-view?view=standard at the
14:15 slot.

---

From: Tim Chown <[email-masked]>
Date: Fri, 10 Mar 2017 19:22:58 +0000

Hi,

On 10 Mar 2017, at 17:52, t.petch <[email-masked]<mailto:[email-masked]>> wrote:

----- Original Message -----
From: "Tim Chown" <[email-masked]<mailto:[email-masked]>>
To: "t.petch" <[email-masked]<mailto:[email-masked]>>
Cc: "joel jaeggli" <[email-masked]<mailto:[email-masked]>>; "IPv6 Operations"
<[email-masked]<mailto:[email-masked]>>
Sent: Friday, March 10, 2017 3:02 PM

On 10 Mar 2017, at 10:57, t.petch
<[email-masked]<mailto:[email-masked]><mailto:[email-masked]>> wrote:

----- Original Message -----
From: "Tim Chown" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>
Sent: Wednesday, March 08, 2017 9:36 AM

Indeed.

For example, for the UK:

which sounds great until you drill down and see that BSKYB is 88.88%
and
realise that that is for subscription TV - especially Association
Football - and not for a traditional ISP.

No, Sky provide broadband to their customers too - 4.5M residences,
93% enabled.

Tim

I thought BT business customers were being enabled around now, as per the residential HomeHub updates?

We’ve had that for around 10 years.

Tim

Tom Petch

Take a major UK ISP, such as TalkTalk and you see that 'IPv6 Capable',
separated out by ASN, ranges from 0.00% to 0.01%, which bears out my
experience of the availability of IPv6 in the UK; ask a salesperson
for
it and they will ask you how to spell it:-)

The major mobile provider, Vodafone, reaches the dizzy heights of
0.73%
availability.

Tim

Tom Petch

*Project Overview*

*Project Goals*

*Audiences*

Some reporting on IPv6-only deployment at the edges would be good, and
its practicality, whether in mobile networks (where most of it seems
to
be) or elsewhere.

Tim