Subject: [v6ops] transition-ipv4aas: Usage Scenarios and End-User Network Architecture

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 25 Apr 2018 18:59:56 +0000

My next set of comments for the transition-ipv4aas draft is on the Usage Scenarios and End-User Network Architecture sections.

I admit to having a low tolerance for what I consider unnecessary introductory material. If the goal is to get CE router vendors to implement the requirements in Section 5, and make this easy for operators to use this draft to request these features, then don't make readers have to go through 5 pages of largely unnecessary introductory material to get to the really important stuff. Also, the more introductory material that is included, the more comments there will be against the introductory material (and the more time gets spent in discussion of those comments -- to the detriment of discussion of requirements and making it take longer to get to publication). 

The more this draft is focused on the requirements, the more likely it is those requirements will be read and implemented, and the faster it will be to review and publish.

If you really want to include the usage scenarios, I would suggest putting them at the end. My preference would be not to include, at all (because there is no need to discuss and fix what isn't there). Same for the end-user network architecture.

I would suggest replacing these two sections with a really short section maybe titled Scope. Something like:

Scope

This document specifies the requirements for an IPv6 Transition CE Router. The IPv6 Transition CE Router builds upon the IPv6 CE Router defined and specified in [RFC7084] by including mandatory support for several transition technologies. The IPv6 Transition CE Router is intended to be used in the same manner (same types of customers and end-user network architecture) as the IPv6 CE Router. 

The IPv6 Transition CE Router will implement the specified transition mechanisms and related provisioning and configuration mechanisms specified in this document in addition to complying with [RFC7084].

Barbara

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 26 Apr 2018 20:26:31 +0200

Hi Barbara,

Lee also suggested removing part of this, and I have been able to compress it a little bit ... but I still think it is useful.

Some folks have asked for that in previous versions, and I see the need, but agree that for the majority of the readers, it is not needed at the beginning of the document, so I'm moving them to annexes.

I think the "Scope" section is not needed, as there is already equivalent text in the introduction.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de "STARK, BARBARA H" <[email-masked]>
Fecha: miércoles, 25 de abril de 2018, 21:00
Para: V6 Ops List <[email-masked]>
Asunto: [v6ops] transition-ipv4aas: Usage Scenarios and End-User Network Architecture

    

    
    Scope

    
    Barbara
    
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.