Subject: [v6ops] transition-ipv4aas: IPv4 Multicast

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 25 Apr 2018 19:01:08 +0000

The transition-ipv4aas draft has the following section:

6.  IPv4 Multicast Support
   Actual deployments support IPv4 multicast for services such as IPTV.
   In the transition phase it is expected that multicast services will
   still be provided using IPv4 to the customer LANs.
   In order to support the delivery of IPv4 multicast services to IPv4
   clients over an IPv6 multicast network, the IPv6 Transition CE router
   SHOULD support [RFC8114] and [RFC8115].

WAN to LAN IPv4 Multicast (such as used for delivery of IPTV) is not supported by many IPv4 CE routers today. Those that do "support" IPv4 multicast often do it poorly. Since I do not believe IPv4 CE routers, in general, should or can be expected to support delivery of IPv4 multicast services, I disagree that an IPv6 Transition CE Routers SHOULD support delivery of IPv4 multicast services. I suggest removing this entire section.

Alternately, rephrase to say "If the IPv6 Transition CE Router supports delivery of IPv4 multicast services, then it SHOULD (MUST?) support [RFC8114] and [RFC8115]."

Barbara

---

From: <[email-masked]>
Date: Thu, 26 Apr 2018 05:32:21 +0000

Hi Barbara, 

Your alternate wording works for me. 

Cheers,
Med

> -----Message d'origine-----
> De : v6ops [mailto:[email-masked]] De la part de STARK, BARBARA H
> Envoyé : mercredi 25 avril 2018 21:01
> À : V6 Ops List
> Objet : [v6ops] transition-ipv4aas: IPv4 Multicast
> 
> WAN to LAN IPv4 Multicast (such as used for delivery of IPTV) is not
> supported by many IPv4 CE routers today. Those that do "support" IPv4
> multicast often do it poorly. Since I do not believe IPv4 CE routers, in
> general, should or can be expected to support delivery of IPv4 multicast
> services, I disagree that an IPv6 Transition CE Routers SHOULD support
> delivery of IPv4 multicast services. I suggest removing this entire section.
> 
> Alternately, rephrase to say "If the IPv6 Transition CE Router supports
> delivery of IPv4 multicast services, then it SHOULD (MUST?) support [RFC8114]
> and [RFC8115]."
> 
> Barbara
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops