Subject: [v6ops] transition-ipv4aas: positioning the draft

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 25 Apr 2018 18:58:42 +0000

I have a number of comments for draft-palet-v6ops-transition-ipv4aas. I'm grouping comments under different email subject headers so it's easier to track the topic of any resulting discussion.

The first area of comments I have is on how to position this draft relative to RFC 7084 and in a way that will maximize its impact and likelihood of achieving its goal (which I think is to drive availability of CE routers that support *all* of the included transition technologies).

I notice the draft introduces the term "IPv6 transition CE". Sometimes this is "IPv6 transition CE router". I like this idea, but would suggest capitalizing and using the longer "IPv6 Transition CE Router". I think if this is a more formal term and this draft is positioned as defining requirements for an IPv6 Transition CE Router (rather than simply specifying "the transition requirements for an IPv6 Customer Edge (CE) router") then it becomes ok to make most of the SHOULD requirements into a MUST. That is, the draft is not an extension of a CE Router (RFC 7084). It's something new that is specified and defined here. And should be the title of the draft.

Saying "MUST" is stronger than "SHOULD" and will increase likelihood of success. It will also increase likelihood that *all* of the included technologies are implemented (as currently written it would be possible to do one or 2 of the technologies and still claim compliance). And it will make it easier to create a subsequent certification program, if there is demand for one. If the MUST statements apply only to the IPv6 Transition CE Router this draft defines, then there is no problem with saying "MUST". The requirements have no scope outside this draft.

----------

If taking this approach, requirements for DS-Lite would need to be included. Those can be copied from RFC 7084.

----------

RFC 7084 can still be a basis for this new thing (MUST comply with RFC 7084).

The current requirement for RFC 7084 compliance is "The IPv6 Transition CE router must comply with all the requirements stated in [RFC7084]." 
I suggest staying away from "all the requirements", since the RFC 7084 SHOULD and MAY requirements are also requirements, and I don't think it's intended to mandate those. I recommend simply saying:
The IPv6 Transition CE router MUST comply with [RFC7084].

---------

If done this way, I don't think it's necessary to make mention of 6rd in any way. It's omission from this draft will make it clear that it's not a component of an IPv6 Transition CE Router.

Barbara

---

From: Hans Liu <[email-masked]>
Date: Thu, 26 Apr 2018 08:56:59 +0800

>
>
> If taking this approach, requirements for DS-Lite would need to be
> included. Those can be copied from RFC 7084.
>
> If done this way, I don't think it's necessary to make mention of 6rd in
> any way. It's omission from this draft will make it clear that it's not a
> component of an IPv6 Transition CE Router.
>
>
> Barbara
>
>
Thank Barbara for the comments.  I do also think we should include DS-Lite
so this document can serve the title better and it may facilitate my OEM
vendors to get a whole picture.

Best regards,
Hans

---

From: <[email-masked]>
Date: Thu, 26 Apr 2018 06:19:48 +0000

Re-,

I do think this would be so simple if the WG went for a bis document. 

I don't understand the rationale for duplicating DS-Lite content given that Jordi's I-D points to 7084. 

Cheers,
Med

> -----Message d'origine-----
> De : v6ops [mailto:[email-masked]] De la part de STARK, BARBARA H
> Envoyé : mercredi 25 avril 2018 20:59
> À : V6 Ops List
> Objet : [v6ops] transition-ipv4aas: positioning the draft
> 
> I have a number of comments for draft-palet-v6ops-transition-ipv4aas. I'm
> grouping comments under different email subject headers so it's easier to
> track the topic of any resulting discussion.
> 
> The first area of comments I have is on how to position this draft relative
> to RFC 7084 and in a way that will maximize its impact and likelihood of
> achieving its goal (which I think is to drive availability of CE routers that
> support *all* of the included transition technologies).
> 
> I notice the draft introduces the term "IPv6 transition CE". Sometimes this
> is "IPv6 transition CE router". I like this idea, but would suggest
> capitalizing and using the longer "IPv6 Transition CE Router". I think if
> this is a more formal term and this draft is positioned as defining
> requirements for an IPv6 Transition CE Router (rather than simply specifying
> "the transition requirements for an IPv6 Customer Edge (CE) router") then it
> becomes ok to make most of the SHOULD requirements into a MUST. That is, the
> draft is not an extension of a CE Router (RFC 7084). It's something new that
> is specified and defined here. And should be the title of the draft.
> 
> Saying "MUST" is stronger than "SHOULD" and will increase likelihood of
> success. It will also increase likelihood that *all* of the included
> technologies are implemented (as currently written it would be possible to do
> one or 2 of the technologies and still claim compliance). And it will make it
> easier to create a subsequent certification program, if there is demand for
> one. If the MUST statements apply only to the IPv6 Transition CE Router this
> draft defines, then there is no problem with saying "MUST". The requirements
> have no scope outside this draft.
> 
> ----------
> 
> The current requirement for RFC 7084 compliance is "The IPv6 Transition CE
> router must comply with all the requirements stated in [RFC7084]."
> I suggest staying away from "all the requirements", since the RFC 7084 SHOULD
> and MAY requirements are also requirements, and I don't think it's intended
> to mandate those. I recommend simply saying:
> If done this way, I don't think it's necessary to make mention of 6rd in any
> way. It's omission from this draft will make it clear that it's not a
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops