Subject: [v6ops] Internet engineers tear into United Nations' plan to move us all to IPv6 • The Register

From: Brian E Carpenter <[email-masked]>
Date: Thu, 31 May 2018 15:51:34 +1200

Ignoring the journalistic exaggerations in the article (2nd link below),
do we have a liaison comment going to the ITU about this draft?
https://regmedia.co.uk/2018/05/30/itu-ipv6-may18.pdf
It seems to be an excellent recipe for burning up address space.
The due date appears to be now.

http://www.theregister.co.uk/2018/05/30/internet_engineers_united_nations_ipv6/

Regards
   Brian

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 31 May 2018 08:41:53 +0200

It was presented two weeks ago in the IPv6 WG of the RIPE meeting in Marseille, with a strong opposition.

You can track also the comments in the mailing list archive.

I explicitly suggested that this is topic of IETF, and they should come to v6ops or 6man or one of the IoT WGs if they really believe this is right.

RIRs also have liaison and are working to tell them that this is really broken.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Brian E Carpenter <[email-masked]>
Organización: University of Auckland
Fecha: jueves, 31 de mayo de 2018, 5:52
Para: IPv6 Operations <[email-masked]>
Asunto: [v6ops] Internet engineers tear into United Nations' plan to move us all to IPv6 • The Register

    
    Regards
       Brian

    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 31 May 2018 09:46:23 +0100

> RIRs also have liaison and are working to tell them that this is really broken.

the principal problem with that work item is not that it's broken and 
arbitrary (which it is), it's that this is out of scope for the ITU.

IP resource number models are simply not their business and they should 
refrain from scope creep like this.

Nick

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 31 May 2018 11:00:47 +0200

I think we all know (my "broken" was not only in the technical sense ...), and even if we solve the political issues, the right scope is IETF and/or RIRs, which I said during the meeting and in the RIPE IPv6 WG mailing list.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Nick Hilliard <[email-masked]>
Fecha: jueves, 31 de mayo de 2018, 10:47
Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>
CC: IPv6 Operations <[email-masked]>
Asunto: Re: [v6ops]  Internet engineers tear into United Nations' plan to move us all to IPv6 • The Register

    
    
    Nick

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 31 May 2018 11:45:40 +0200

The ITU recommendation should be discussed here.

We should update that recommendation at least in one point: the 64bit 
limit.  It too much reckons the IIDs to be of length 64; this can block 
Internet growth.   On another hand, at least RFC7277 "Opaque IIDs" and 
its BSD SLAAC implementation permits it to be 65, and at least one large 
cellular operator uses DHCPv6 Prefix Delegation for prefixes of length 
e.g. 56 (not 64).

Does ITU SG20 know this?

Alex

---

From: Lee Howard <[email-masked]>
Date: Thu, 31 May 2018 11:35:04 -0400

I note that the IAB had a measured response:

https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-04-04-iab-itu-t-sg-20-response-to-liaison-1546-attachment-1.pdf

I support that statement.

Bearing in mind that I have no official position, and therefore any 
opinions expressed below are mine only:

The IETF, and any working group in it, has only one way to make a 
statement: an RFC from the IETF stream. No other kind of document 
requires IETF consensus, which is the only way to reflect an IETF 
statement. I am skeptical that we can generate a timely consensus document.

We don't need to say, "Stay out of our sandbox." Turf wars are stupid: 
as engineers, we don't care who does the work, we care about the quality 
of the work. Getting defensive is a sign that we care more about 
protecting some interest than about making the Internet work better.

Comments about the technical problems with the proposed model are 
appropriate. I would include implementation considerations, such as the 
potential for people to think the model is compulsory, or overrides 
other local network considerations. However, I have no reason to believe 
that comments on v6ops or other IETF mailing lists will be received by SG20.

On those bases, RIPE may be a more effective place for discussion.

Lee

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 1 Jun 2018 09:32:04 +1200

> I support that statement.

I'm a little puzzled why this list wasn't informed of this statement
at the time.

> that comments on v6ops or other IETF mailing lists will be received by SG20.

They can be, via our liaison channel. But it seems to be too late now
(see above comment).

    Brian

---

From: Fred Baker <[email-masked]>
Date: Thu, 31 May 2018 16:40:58 -0700

The Register, as it often does, has an article on the topic. It's not very supportive of SG20 :-)

https://www.theregister.co.uk/2018/05/30/internet_engineers_united_nations_ipv6/

> On May 31, 2018, at 8:35 AM, Lee Howard <[email-masked]> wrote:
> 
> Bearing in mind that I have no official position, and therefore any opinions expressed below are mine only:
> 
> The IETF, and any working group in it, has only one way to make a statement: an RFC from the IETF stream. No other kind of document requires IETF consensus, which is the only way to reflect an IETF statement. I am skeptical that we can generate a timely consensus document.
> 
> We don't need to say, "Stay out of our sandbox." Turf wars are stupid: as engineers, we don't care who does the work, we care about the quality of the work. Getting defensive is a sign that we care more about protecting some interest than about making the Internet work better.
> 
> Comments about the technical problems with the proposed model are appropriate. I would include implementation considerations, such as the potential for people to think the model is compulsory, or overrides other local network considerations. However, I have no reason to believe that comments on v6ops or other IETF mailing lists will be received by SG20.
>