Subject: [v6ops] apnic IPv6 stats

From: <[email-masked]>
Date: Tue, 4 Dec 2018 16:06:21 +0000

Hey

Does someone know and could they please give me a brief description of technically how apnic get gather these % IPv6 capable stats ?

https://stats.labs.apnic.net/ipv6/AS2856?c=GB&p=1&v=1&w=30&x=1

Many thanks in advance

Mal

---

From: Yu Tianpeng <[email-masked]>
Date: Tue, 4 Dec 2018 16:52:19 +0000

Hi Mal,
This might help.
https://labs.apnic.net/?p=266
Regards,
Tim

On Tue, 4 Dec 2018, 16:06 <[email-masked] wrote:

> Hey
>
>
>
> Does someone know and could they please give me a brief description of
> technically how apnic get gather these % IPv6 capable stats ?
>
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Lee Howard <[email-masked]>
Date: Tue, 4 Dec 2018 12:03:03 -0500

Paging Geoff Huston and George Michaelson!

One explanatory blog post is at https://labs.apnic.net/?p=266

Briefly, as I understand it, APNIC buys ads on a global ad network. When 
the ad is served to a device, it pulls two unique objects, one IPv4-only 
and one IPv6-only. Because they're unique, they can tell when a device 
GETs the IPv4 object and whether they GET the IPv6 object. Then it's 
just the percentage of total fetches coming over IPv6.

They do a bit of normalizing the results, and of course knowing the 
source IP addresses is how they categorize the origin ASN.

I'm not authoritative, but that's my understanding.

Lee

---

From: Fred Baker <[email-masked]>
Date: Tue, 4 Dec 2018 09:38:35 -0800

> On Dec 4, 2018, at 9:03 AM, Lee Howard <[email-masked]> wrote:
> 
> Briefly, as I understand it, APNIC buys ads on a global ad network. When the ad is served to a device, it pulls two unique objects, one IPv4-only and one IPv6-only. Because they're unique, they can tell when a device GETs the IPv4 object and whether they GET the IPv6 object. Then it's just the percentage of total fetches coming over IPv6.

It actually has three names that it resolves and uses. One only has an A record, and an access in today's Internet tells APNIC that there was an access. One only has a AAAA record; if that address is accessed, APNIC knows that the entire path from client to server is IPv6-capable. One has both resource records; if the client uses the IPv6 one, George infers that it *prefers* IPv6, as it made that choice.

> They do a bit of normalizing the results, and of course knowing the source IP addresses is how they categorize the origin ASN.
> 

--------------------------------------------------------------------------------
Victorious warriors win first and then go to war,
Defeated warriors go to war first and then seek to win.
     Sun Tzu