Subject: [v6ops] Operational Headache: Provisioning domains

From: Fred Baker <[email-masked]>
Date: Fri, 29 Mar 2019 06:37:36 +0100

https://datatracker.ietf.org/doc/slides-104-v6ops-deutsche-telekom-terastream/, slide 5

What do we want to say on this issue? Mikael mentions draft-ietf-intarea-provisioning-domains; in this case, I think I need to send a note to the relevant authors and chairs asking them what the prognosis is and expressing operational interest. First, is there a consensus to do that? Second, do we have additional comments to pass along? Our comments might be adequately summarized by forwarding a link to this thread, or might rise to the level that needs to be discussed in an internet draft in v6ops. Comments?

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 30 Mar 2019 13:28:13 +1300

Well, first I'd like to understand why Terastream decided to use address bits
to convey these semantics, when diffserv was designed for this exact purpose?

Frankly I'm not surprised that using address bits in this way leads to
problems.

Regards
   Brian Carpenter

On 29-Mar-19 18:37, Fred Baker wrote:
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sat, 30 Mar 2019 09:07:20 +0100 (CET)

> to convey these semantics, when diffserv was designed for this exact purpose?

It doesn't matter exactly what we call it. Think of it as "walled garden", 
"network policy" or whatever. It all results in the same thing. It's more 
than what diffserv does.

> Frankly I'm not surprised that using address bits in this way leads to 

Please don't rathole on the diffserv part of it. The problem space for 
"VPN" etc is the same.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 31 Mar 2019 09:00:29 +1300

Hi Mikael,

> "network policy" or whatever. It all results in the same thing. It's more 

Yes, but that doesn't really answer my question. What does this do for you
that diffserv traffic classes don't already provide?

I see this in your slide:
> without needing DPI for setting TOS etc.
In an ideal world, you need the host to do that. But in any case
your requirements seem to need significant changes to the host stack,
especially to support PVDs.

Note that I am not not denying the requirement for localised behaviours.
Please see https://tools.ietf.org/html/draft-carpenter-limited-domains .

> Please don't rathole on the diffserv part of it. The problem space for 

If I'm ratholing, it's on the use of address bits to carry traffic semantics.

   Brian

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sat, 30 Mar 2019 22:12:45 +0100 (CET)

On Sun, 31 Mar 2019, Brian E Carpenter wrote:

> In an ideal world, you need the host to do that. But in any case your 
> requirements seem to need significant changes to the host stack, 

I don't understand your apparent opposition to PVD support. You might 
consider our use of PVD strange, but that doesn't invalidate the other 
use-cases for PVDs.

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 31 Mar 2019 11:56:16 +1300

> consider our use of PVD strange, but that doesn't invalidate the other 

I didn't say I'm against PVDs. I just said that they need widespread
host support to be useful. (As does RFC8028, to alleviate some of the
problems even without PVDs.)

By the way, there was this a few years ago:
https://tools.ietf.org/html/draft-jiang-v6ops-semantic-prefix
I'm still worried by using bits in a GUA prefix for essentially
semantic purposes. I fully realise we have a large supply of IPv6
prefixes. But mixing addresses and service semantics just seems
very likely to cause problems sooner or later. I'm sorry, that
reads like FUD, but that's my feeling.

    Brian

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sun, 31 Mar 2019 07:03:59 +0200 (CEST)

> https://tools.ietf.org/html/draft-jiang-v6ops-semantic-prefix

Yes, my colleague Ian Farrer is co-author of that document.

> I'm still worried by using bits in a GUA prefix for essentially semantic 
> purposes. I fully realise we have a large supply of IPv6 prefixes. But 
> mixing addresses and service semantics just seems very likely to cause 
> problems sooner or later. I'm sorry, that reads like FUD, but that's my 
> feeling.

I share your concern and this approach has to be done with care. However, 
it's not uncommon for operators to have 3-4 different vlans to the HGW to 
separate services video/voice/management/Internet. This basically does the 
same thing.

We also use diffserv to do some PHB differentiation within the same 
prefix.

---

From: Fred Baker <[email-masked]>
Date: Sun, 31 Mar 2019 12:06:11 +0200

> On Mar 30, 2019, at 11:56 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> By the way, there was this a few years ago: https://tools.ietf.org/html/draft-jiang-v6ops-semantic-prefix I'm still worried by using bits in a GUA prefix for essentially semantic purposes. I fully realise we have a large supply of IPv6 prefixes. But mixing addresses and service semantics just seems very likely to cause problems sooner or later. I'm sorry, that reads like FUD, but that's my feeling.

No hats

That, BTW, was the reason I pushed back on Jiang's draft, and I have the same fundamental question about Terastream's use case. I understand both concepts to essentially say something about what address one uses for an application; putting it into the address has the characteristic of ensuring that the same set of bits is present in the packet end to end, which differs from DiffServ. It basically allows DT to make an end to end service, and change the IPv6 head to support it, with actually having to change the IPv6 header. It affects, or can affect, routing, and as I understand it required DT to allocate a truly large prefix. I find myself wondering - what if this were general? Everybody was allocating /24 or larger prefixes to get the equivalent of a DSCP to be usable end to end? The fact of asking the question seems crazy, but at some point, that seems to me to limit the availability of IPv6 address space. Is that a rathole we want the network to go down?

Just me worrying.
--------------------------------------------------------------------------------
Victorious warriors win first and then go to war,
Defeated warriors go to war first and then seek to win.
     Sun Tzu

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sun, 31 Mar 2019 12:23:35 +0200

If we have a way to say (just examples, in a common case):

1) This residential user gets this /48, assigned with DHCPv6-PD
2) The 1st /64 is reserved for the point to point link, WAN port
3) The 2nd /64 is for VoIP in VLAN 2, Eth2
4) The 3rd /64 is for IPTV in VLAN 3, Eth3
5) The 4th /64 is for x in VLAN 4 ...
6) The user can use all the others (automatic LAN numbering), Eth0, WiFi, etc.
7) The CE recognize it

We could achieve that, I think, in a much easier way.

RFC6603, I believe (need to re-read it), only allows 2) above.

Does it make sense to work in an updated version of RFC6603, probably using as well some of the text in draft-palet-v6ops-p2p-links (which I'm going to update anyway), instead of two different documents?

Regards,
Jordi

El 31/3/19 12:06, "v6ops en nombre de Fred Baker" <[email-masked] en nombre de [email-masked]> escribió:

    
    No hats

    Just me worrying.

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sun, 31 Mar 2019 13:15:43 +0200 (CEST)

On Sun, 31 Mar 2019, Fred Baker wrote:

> some point, that seems to me to limit the availability of IPv6 address 
> space. Is that a rathole we want the network to go down?

Can we start a new thread to discuss this PHB / addressing issue, 
separated from the PVD concept?

I don't want to lose the PVD discussion in a discussion of what good use 
of addresses is or not. They're orthogonal issues.