Subject: Re: [v6ops] draft-smith-v6ops-larger-ipv6-loopback-prefix-04

From: Fred Baker <[email-masked]>
Date: Sun, 1 Nov 2020 22:35:02 -0800

> On Oct 29, 2020, at 1:42 AM, Mark Smith <[email-masked]> wrote:
> 
> I've thought that the use of Anycast would increase, and have thought that it would be useful to have a specially designated anycast prefix. It has also occurred to me that anycast has some of the properties of unicast as well as some of the properties of multicast, so could be seen to fit in between unicast and multicast (1:1 -> 1:Any -> 1:Many)

That's a reasonable description of anycast as deployed.

My question in that would be exactly what you might want to change. We have some pretty widespread use of anycast today (https://www.iana.org/domains/root/servers https://root-servers.org), and to my knowledge it seems to work just fine. If we're going to replace existing anycast with some sort of anycast prefix, the first big change we have to make is in BGP; it can advertise a unicast prefix or address, but can't, today at least, advertise an anycast prefix.Then we have to tell hosts that they can send traffic to such addresses and should. I think we should have a good reason if we're going to boil the ocean.

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 2 Nov 2020 04:12:31 -0500

On Thu, Oct 29, 2020 at 4:43 AM Mark Smith <[email-masked]> wrote:

> Hi Gyan,
>
> On Wed, 28 Oct 2020, 09:10 Gyan Mishra, <[email-masked]> wrote:
>
>> Hi Mark
>>
>> <snip>
>>
>>     Gyan> That is definitely an interesting idea and I think makes sense
>> and viable for sure.  There maybe other use cases I am thinking out loud
>> maybe with BIER IPv6  MVPN and possible some other use cases.  I wonder
>> even for the SRv6 locator maybe having a special range outside of GUI
>> allocation as it has special handling with steering.
>>
>> Another question related to IPv6 Anycast.  IPv6 has built in anycast
>> address, I believe it’s the last 7 bits subnet router Anycast address.
>> Since any routable prefix can be Anycasted for services proximity routing,
>>  what is the real use case or functionality of the IPv6 built in Anycast
>> /121 range.
>>
>
>
> There isn't really an IPv6 anycast range, IPv6 anycast addresses come out
> of the unicast address space, and are only designated as anycast either by
> announcing a "unicast" route from multiple different locations on purpose
> (if it's not on purpose, it's a fault), and by configuring the host with
> the anycast address to know that it is an anycast address.
>
> I've thought that the use of Anycast would increase, and have thought that
> it would be useful to have a specially designated anycast prefix. It has
> also occurred to me that anycast has some of the properties of unicast as
> well as some of the properties of multicast, so could be seen to fit in
> between unicast and multicast (1:1 -> 1:Any -> 1:Many)
>
> "IPv6 Formal Anycast and Functional Anycast Addresses"
>
> IETF 106 presentation -
> https://www.ietf.org/proceedings/106/slides/slides-106-6man-sessa-ipv6-formal-anycast-addresses-and-functional-anycast-addresses-00.pdf
>
> Draft -
> https://tools.ietf.org/html/draft-smith-6man-form-func-anycast-addresses-01
>

   Gyan> Thanks for the info!

>
> Regards,
> Mark.
>
>
>
>
>
>>
>>> Regards,
>>> Mark.
>>>
>>>
>>>> Thanks
>>>>
>>>> Gyan
>>>>
>>>> On Mon, Oct 26, 2020 at 9:22 PM Mark Smith <[email-masked]>
>>>> wrote:
>>>>
>>>>> Hi Gyan,
>>>>>
>>>>> Sorry not to get back to you sooner.
>>>>>
>>>>> On Tue, 20 Oct 2020 at 00:26, Gyan Mishra <[email-masked]>
>>>>> wrote:
>>>>> >
>>>>> >
>>>>> > Hi Mark
>>>>> >
>>>>> > What ended up happening with this draft
>>>>>
>>>>> I let it expire, as I didn't think it would be adopted by the WG.
>>>>>
>>>>> There seemed to be a bit of resistance to it as people said that ULAs
>>>>> could be used instead.
>>>>>
>>>>> The link local prefix is also required on any IPv6 interface, per
>>>>> RFC4291, so there is supposed to be a link-local /64 on the loopback
>>>>> interface(s) providing many addresses to which a process could be
>>>>> separately bound, although a drawback of using the link-local prefix
>>>>> is having to deal with scope/zone IDs (although Linux doesn't comply
>>>>> with that requirement, it doesn't have a link-local address on the
>>>>> loopback interface by default).
>>>>>
>>>>> > and was the work picked up in any other draft.
>>>>>
>>>>> Not as far as I'm aware.
>>>>>
>>>>> What is your use case?
>>>>>
>>>>> Regards,
>>>>> Mark.
>>>>>
>>>>>
>>>>> >
>>>>> > Thanks
>>>>> >
>>>>> > Gyan
>>>>> >
>>>>> > Sent from my iPhone
>>>>>
>>>> --
>>>>
>>>> <http://www.verizon.com/>
>>>>
>>>> *Gyan Mishra*
>>>>
>>>> *Network Solutions A**rchitect *
>>>>
>>>>
>>>>
>>>> *M 301 502-134713101 Columbia Pike
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike%C2%A0+Silver+Spring,+MD?entry=gmail&source=g>*Silver
>>>> Spring, MD
>>>> <https://www.google.com/maps/search/13101+Columbia+Pike%C2%A0+Silver+Spring,+MD?entry=gmail&source=g>
>>>>
>>>> --
>>
>> <http://www.verizon.com/>
>>
>> *Gyan Mishra*
>>
>> *Network Solutions A**rchitect *
>>
>>
>>
>> *M 301 502-134713101 Columbia Pike
>> <https://www.google.com/maps/search/13101+Columbia+Pike%C2%A0+Silver+Spring,+MD?entry=gmail&source=g>*Silver
>> Spring, MD
>> <https://www.google.com/maps/search/13101+Columbia+Pike%C2%A0+Silver+Spring,+MD?entry=gmail&source=g>
>>
>> --

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 2 Nov 2020 04:28:02 -0500

On Mon, Nov 2, 2020 at 1:35 AM Fred Baker <[email-masked]> wrote:

> > I've thought that the use of Anycast would increase, and have thought
> that it would be useful to have a specially designated anycast prefix. It
> has also occurred to me that anycast has some of the properties of unicast
> as well as some of the properties of multicast, so could be seen to fit in

   Gyan> Agreed

>
>
> My question in that would be exactly what you might want to change. We
> have some pretty widespread use of anycast today (
> https://www.iana.org/domains/root/servers https://root-servers.org), and
> to my knowledge it seems to work just fine. If we're going to replace
> existing anycast with some sort of anycast prefix, the first big change we
> have to make is in BGP; it can advertise a unicast prefix or address, but
> can't, today at least, advertise an anycast prefix.Then we have to tell
> hosts that they can send traffic to such addresses and should. I think we
> should have a good reason if we're going to boil the ocean.

   Gyan> Good point and as you mention services such as DNS, NTP
predominantly but even Syslog, snmp, netflow have gone the way of Anycast
VIP advertisement via a lb for proximity routing to unicast address for a
just about any service can be done the ASM way and works very well.

I think with IPv6 a lot of thought was put into the addressing schema I am
guessing like the built in Anycast range out of the GUI range without a use
case but hopes for if you build they will come which I guess never
happened.  So then I guess it never took of as it would require some
changes to BGP.  Working with BGP on parameters and codepoint development
in some of the other WGs, if there is a real gain or use case for an
Anycast BGP SAFI  I could author a draft to make it happen but I would need
to figure out the why and what gap is not being filled by the existing
Anycast capability via unicast today which has been widely  proliferated.

*Gyan Mishra*